summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/hyperscan/Makefile31
-rw-r--r--devel/hyperscan/distinfo6
2 files changed, 18 insertions, 19 deletions
diff --git a/devel/hyperscan/Makefile b/devel/hyperscan/Makefile
index 522a95d46942..a3f908943625 100644
--- a/devel/hyperscan/Makefile
+++ b/devel/hyperscan/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= hyperscan
-PORTVERSION= 4.4.0
+PORTVERSION= 4.4.1
DISTVERSIONPREFIX= v
CATEGORIES= devel textproc
MASTER_SITES= SF/boost/boost/1.61.0:boost
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ragel:devel/ragel
USE_GITHUB= yes
GH_ACCOUNT= 01org
-USES= compiler:c++11-lib cmake:outsource pathfix python:build pkgconfig sqlite:3
+USES= compiler:c++11-lib cmake:outsource pathfix python:build
ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON= SSSE3 is required for work
@@ -25,23 +25,15 @@ SHARED_DESC= Build shared library
NATIVE_DESC= Build with native CPU tunes
OPTIONS_DEFAULT= SHARED
-.ifndef DEBUG_FLAGS
-CMAKE_BUILD_TYPE= Release
-.else
-CMAKE_BUILD_TYPE= Debug
-.endif
-
CMAKE_ARGS+= -DBOOST_ROOT=${WRKDIR}/boost_1_61_0
-.include <bsd.port.options.mk>
+NATIVE_CXXFLAGS= -march=native -mtune=native
+NATIVE_CFLAGS= -march=native -mtune=native
-.if ${PORT_OPTIONS:MNATIVE}
-CXXFLAGS+= -march=native -mtune=native
-CFLAGS+= -march=native -mtune=native
-.else
-CXXFLAGS+= -march=core2
-CFLAGS+= -march=core2
-.endif
+NATIVE_CXXFLAGS_OFF= -march=core2
+NATIVE_CFLAGS_OFF= -march=core2
+
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSHARED}
CMAKE_ARGS+= -DBUILD_STATIC_AND_SHARED=ON
@@ -52,4 +44,11 @@ PLIST_SUB+= SHARED="" \
PLIST_SUB+= SHARED="@comment "
.endif
+# don't build hsbench tool
+post-patch:
+ ${RM} ${WRKSRC}/tools/CMakeLists.txt
+
+do-test:
+ cd ${BUILD_WRKSRC} && ${MAKE_CMD} unit
+
.include <bsd.port.mk>
diff --git a/devel/hyperscan/distinfo b/devel/hyperscan/distinfo
index 12c6978bcaa7..a9f5a6bbe8f2 100644
--- a/devel/hyperscan/distinfo
+++ b/devel/hyperscan/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1487173124
+TIMESTAMP = 1490739901
SHA256 (boost_1_61_0.tar.gz) = a77c7cc660ec02704c6884fbb20c552d52d60a18f26573c9cee0788bf00ed7e6
SIZE (boost_1_61_0.tar.gz) = 104864830
-SHA256 (01org-hyperscan-v4.4.0_GH0.tar.gz) = 6ff1b47ce9888803ce6dfa8e1efbab30ec53f984410275d7a45138825af0a0d5
-SIZE (01org-hyperscan-v4.4.0_GH0.tar.gz) = 1514719
+SHA256 (01org-hyperscan-v4.4.1_GH0.tar.gz) = 3a082d92a3cb0cd724bc1190d24cc39752bd3db35d22115fda03d2e91ccd94cd
+SIZE (01org-hyperscan-v4.4.1_GH0.tar.gz) = 1515106