summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/six/Makefile9
-rw-r--r--games/six/files/patch-sixplayer.cpp10
2 files changed, 16 insertions, 3 deletions
diff --git a/games/six/Makefile b/games/six/Makefile
index 0992982c4a75..b51164a3ff17 100644
--- a/games/six/Makefile
+++ b/games/six/Makefile
@@ -15,7 +15,10 @@ COMMENT= KDE HEX clone
USE_KDELIBS_VER= 3
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+post-patch:
+ ${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS}," ${WRKSRC}/configure
+
+
+.include <bsd.port.mk>
diff --git a/games/six/files/patch-sixplayer.cpp b/games/six/files/patch-sixplayer.cpp
new file mode 100644
index 000000000000..ac3374e56e95
--- /dev/null
+++ b/games/six/files/patch-sixplayer.cpp
@@ -0,0 +1,10 @@
+--- six/sixplayer.cpp.orig Tue May 25 11:58:16 2004
++++ six/sixplayer.cpp Tue May 25 11:58:33 2004
+@@ -5,6 +5,7 @@
+ #include <cassert>
+ #include <algorithm>
+ #include <cmath>
++#include <ctype.h>
+
+ using std::endl;
+