summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/ruby-racc/Makefile10
-rw-r--r--japanese/rbnamazu/Makefile9
-rw-r--r--mail/ruby-tmail/Makefile9
-rw-r--r--mail/rubygem-tmail/Makefile9
-rw-r--r--ports-mgmt/portupgrade-devel/Makefile5
-rw-r--r--ports-mgmt/portupgrade/Makefile5
-rw-r--r--sysutils/libchk/Makefile9
-rw-r--r--sysutils/portupgrade-devel/Makefile5
-rw-r--r--sysutils/portupgrade/Makefile5
-rw-r--r--textproc/ruby-rdtool/Makefile10
-rw-r--r--textproc/ruby-xmlscan-old/Makefile9
-rw-r--r--textproc/ruby-xmlscan/Makefile9
12 files changed, 20 insertions, 74 deletions
diff --git a/devel/ruby-racc/Makefile b/devel/ruby-racc/Makefile
index 30085008c8df..5e07835d38f5 100644
--- a/devel/ruby-racc/Makefile
+++ b/devel/ruby-racc/Makefile
@@ -19,18 +19,12 @@ MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
USE_RUBY_SETUP= yes
+USE_RUBY_FEATURES= racc-runtime
CONFIGURE_ARGS= --with=racc
WRKDIR_RACC= ${WRKSRC}/packages/racc
-.include <bsd.port.pre.mk>
-
-.if ${RUBY_VER} < 1.7
-RUN_DEPENDS+= ${RUBY_SITELIBDIR}/racc/parser.rb:${PORTSDIR}/lang/ruby16-shim-ruby18 \
- ${RUBY_SITEARCHLIBDIR}/strscan.so:${PORTSDIR}/lang/ruby16-shim-ruby18
-.endif
-
post-extract:
${CP} -p ${WRKDIR_RACC}/misc/* ${WRKDIR_RACC}/bin/
@@ -43,4 +37,4 @@ do-install:
${INSTALL_DATA} ${WRKDIR_RACC}/doc.ja/* ${RUBY_DOCDIR}/${PORTNAME}/ja/
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/japanese/rbnamazu/Makefile b/japanese/rbnamazu/Makefile
index 0a5e31c45219..fb861eaa08e5 100644
--- a/japanese/rbnamazu/Makefile
+++ b/japanese/rbnamazu/Makefile
@@ -14,6 +14,7 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
+USE_RUBY_FEATURES= optparse
.if !defined(NOPORTDOCS)
USE_RUBY_RD= yes
.endif
@@ -23,12 +24,6 @@ NO_BUILD= yes
MODULES= rbnamazu.rb nmzqr.rb nmzqr.tab.rb nmzdoc.rb
RD_DOCS= rbnamazu.rd.ja rbnamazu.rd.en
-.include <bsd.port.pre.mk>
-
-.if ${RUBY_VER} < 1.7
-RUN_DEPENDS+= ${RUBY_SITELIBDIR}/optparse.rb:${PORTSDIR}/lang/ruby16-shim-ruby18
-.endif
-
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/namazu.rb ${PREFIX}/bin/
${LN} -sf namazu.rb ${PREFIX}/bin/rbnamazu
@@ -49,4 +44,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/ruby-tmail/Makefile b/mail/ruby-tmail/Makefile
index 1b74af57f95a..6ba2c842c720 100644
--- a/mail/ruby-tmail/Makefile
+++ b/mail/ruby-tmail/Makefile
@@ -19,17 +19,12 @@ MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
USE_RUBY_SETUP= yes
+USE_RUBY_FEATURES= racc-runtime
CONFIGURE_ARGS= --with=tmail
WRKDIR_TMAIL= ${WRKSRC}/packages/tmail
-.include <bsd.port.pre.mk>
-
-.if ${RUBY_VER} < 1.7
-RUN_DEPENDS+= ${RUBY_SITELIBDIR}/racc/parser.rb:${PORTSDIR}/lang/ruby16-shim-ruby18
-.endif
-
do-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
@@ -39,4 +34,4 @@ do-install:
${CP} -R ${WRKDIR_TMAIL}/Incompatibilities.ja ${WRKDIR_TMAIL}/README.ja ${WRKDIR_TMAIL}/doc.ja/* ${RUBY_DOCDIR}/${PORTNAME}/ja/
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/rubygem-tmail/Makefile b/mail/rubygem-tmail/Makefile
index 1b74af57f95a..6ba2c842c720 100644
--- a/mail/rubygem-tmail/Makefile
+++ b/mail/rubygem-tmail/Makefile
@@ -19,17 +19,12 @@ MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
USE_RUBY_SETUP= yes
+USE_RUBY_FEATURES= racc-runtime
CONFIGURE_ARGS= --with=tmail
WRKDIR_TMAIL= ${WRKSRC}/packages/tmail
-.include <bsd.port.pre.mk>
-
-.if ${RUBY_VER} < 1.7
-RUN_DEPENDS+= ${RUBY_SITELIBDIR}/racc/parser.rb:${PORTSDIR}/lang/ruby16-shim-ruby18
-.endif
-
do-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
@@ -39,4 +34,4 @@ do-install:
${CP} -R ${WRKDIR_TMAIL}/Incompatibilities.ja ${WRKDIR_TMAIL}/README.ja ${WRKDIR_TMAIL}/doc.ja/* ${RUBY_DOCDIR}/${PORTNAME}/ja/
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/ports-mgmt/portupgrade-devel/Makefile b/ports-mgmt/portupgrade-devel/Makefile
index 16aed7712e66..897ced101ff4 100644
--- a/ports-mgmt/portupgrade-devel/Makefile
+++ b/ports-mgmt/portupgrade-devel/Makefile
@@ -30,6 +30,7 @@ RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/bdb1.so:${PORTSDIR}/databases/ruby-bdb1
USE_BZIP2= yes
USE_RUBY= yes
+USE_RUBY_FEATURES= optparse ruby18
MAKE_ARGS= PREFIX="${PREFIX}" RUBY="${RUBY}"
@@ -63,10 +64,6 @@ PKG_CREATE_OK!= /usr/sbin/pkg_create 2>&1 | ${GREP} ' -b ' || ${TRUE}
IGNORE= pkg_create does not support -b. Please update pkg_* tools or stick with portupgrade-20020920 + pkg_tarup-1.2_3, which work just fine
.endif
-.if ${RUBY_VER} < 1.7
-RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/features/ruby18/file_ruby18.so:${PORTSDIR}/lang/ruby16-shim-ruby18
-.endif
-
post-install:
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \
diff --git a/ports-mgmt/portupgrade/Makefile b/ports-mgmt/portupgrade/Makefile
index 16aed7712e66..897ced101ff4 100644
--- a/ports-mgmt/portupgrade/Makefile
+++ b/ports-mgmt/portupgrade/Makefile
@@ -30,6 +30,7 @@ RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/bdb1.so:${PORTSDIR}/databases/ruby-bdb1
USE_BZIP2= yes
USE_RUBY= yes
+USE_RUBY_FEATURES= optparse ruby18
MAKE_ARGS= PREFIX="${PREFIX}" RUBY="${RUBY}"
@@ -63,10 +64,6 @@ PKG_CREATE_OK!= /usr/sbin/pkg_create 2>&1 | ${GREP} ' -b ' || ${TRUE}
IGNORE= pkg_create does not support -b. Please update pkg_* tools or stick with portupgrade-20020920 + pkg_tarup-1.2_3, which work just fine
.endif
-.if ${RUBY_VER} < 1.7
-RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/features/ruby18/file_ruby18.so:${PORTSDIR}/lang/ruby16-shim-ruby18
-.endif
-
post-install:
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \
diff --git a/sysutils/libchk/Makefile b/sysutils/libchk/Makefile
index 7aa2bbea6d5f..6f5351824e3e 100644
--- a/sysutils/libchk/Makefile
+++ b/sysutils/libchk/Makefile
@@ -16,16 +16,11 @@ MAINTAINER= knu@FreeBSD.org
USE_BZIP2= yes
USE_RUBY= yes
+USE_RUBY_FEATURES= optparse
MAKE_ARGS= PREFIX="${PREFIX}"
MAN1= libchk.1
MANCOMPRESSED= maybe
-.include <bsd.port.pre.mk>
-
-.if ${RUBY_VER} < 1.7
-RUN_DEPENDS+= ${RUBY_SITELIBDIR}/optparse.rb:${PORTSDIR}/lang/ruby16-shim-ruby18
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/portupgrade-devel/Makefile b/sysutils/portupgrade-devel/Makefile
index 16aed7712e66..897ced101ff4 100644
--- a/sysutils/portupgrade-devel/Makefile
+++ b/sysutils/portupgrade-devel/Makefile
@@ -30,6 +30,7 @@ RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/bdb1.so:${PORTSDIR}/databases/ruby-bdb1
USE_BZIP2= yes
USE_RUBY= yes
+USE_RUBY_FEATURES= optparse ruby18
MAKE_ARGS= PREFIX="${PREFIX}" RUBY="${RUBY}"
@@ -63,10 +64,6 @@ PKG_CREATE_OK!= /usr/sbin/pkg_create 2>&1 | ${GREP} ' -b ' || ${TRUE}
IGNORE= pkg_create does not support -b. Please update pkg_* tools or stick with portupgrade-20020920 + pkg_tarup-1.2_3, which work just fine
.endif
-.if ${RUBY_VER} < 1.7
-RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/features/ruby18/file_ruby18.so:${PORTSDIR}/lang/ruby16-shim-ruby18
-.endif
-
post-install:
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \
diff --git a/sysutils/portupgrade/Makefile b/sysutils/portupgrade/Makefile
index 16aed7712e66..897ced101ff4 100644
--- a/sysutils/portupgrade/Makefile
+++ b/sysutils/portupgrade/Makefile
@@ -30,6 +30,7 @@ RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/bdb1.so:${PORTSDIR}/databases/ruby-bdb1
USE_BZIP2= yes
USE_RUBY= yes
+USE_RUBY_FEATURES= optparse ruby18
MAKE_ARGS= PREFIX="${PREFIX}" RUBY="${RUBY}"
@@ -63,10 +64,6 @@ PKG_CREATE_OK!= /usr/sbin/pkg_create 2>&1 | ${GREP} ' -b ' || ${TRUE}
IGNORE= pkg_create does not support -b. Please update pkg_* tools or stick with portupgrade-20020920 + pkg_tarup-1.2_3, which work just fine
.endif
-.if ${RUBY_VER} < 1.7
-RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/features/ruby18/file_ruby18.so:${PORTSDIR}/lang/ruby16-shim-ruby18
-.endif
-
post-install:
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \
diff --git a/textproc/ruby-rdtool/Makefile b/textproc/ruby-rdtool/Makefile
index 2d8d6374c5b9..45fd102832f2 100644
--- a/textproc/ruby-rdtool/Makefile
+++ b/textproc/ruby-rdtool/Makefile
@@ -18,6 +18,7 @@ BUILD_DEPENDS= ${DEPEND_RUBY_AMSTD} \
racc:${PORTSDIR}/devel/ruby-racc
USE_RUBY= yes
+USE_RUBY_FEATURES= optparse strscan
RUBY_SHEBANG_FILES= ${WRKSRC}/rmi2html.rb
@@ -27,13 +28,6 @@ XEMACSLISPDIR= ${PREFIX}/lib/xemacs/site-lisp
DOCS_EN= README.html doc/rd-draft.rd doc/rd-draft.html
DOCS_JA= README.ja.html doc/rd-draft.rd.ja doc/rd-draft.ja.html
-.include <bsd.port.pre.mk>
-
-.if ${RUBY_VER} < 1.7
-BUILD_DEPENDS+= ${RUBY_SITELIBDIR}/optparse.rb:${PORTSDIR}/lang/ruby16-shim-ruby18
-RUN_DEPENDS+= ${RUBY_SITELIBDIR}/optparse.rb:${PORTSDIR}/lang/ruby16-shim-ruby18
-.endif
-
do-configure:
@cd ${WRKSRC}; \
${SETENV} ${CONFIGURE_ENV} ${RUBY} rdtoolconf.rb
@@ -71,4 +65,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/ruby-xmlscan-old/Makefile b/textproc/ruby-xmlscan-old/Makefile
index 5ed1ec80747e..934ebb633d8d 100644
--- a/textproc/ruby-xmlscan-old/Makefile
+++ b/textproc/ruby-xmlscan-old/Makefile
@@ -17,12 +17,7 @@ MAINTAINER= knu@FreeBSD.org
BUILD_DEPENDS= racc:${PORTSDIR}/devel/ruby-racc
USE_RUBY= yes
-
-.include <bsd.port.pre.mk>
-
-.if ${RUBY_VER} < 1.7
-RUN_DEPENDS+= ${RUBY_SITELIBDIR}/racc/parser.rb:${PORTSDIR}/lang/ruby16-shim-ruby18
-.endif
+USE_RUBY_FEATURES= racc-runtime
do-build:
cd ${WRKSRC}; racc -v -g -c -o xmldtd.rb xmldtd.ry
@@ -34,4 +29,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${RUBY_DOCDIR}/${PORTNAME}/ja/
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/ruby-xmlscan/Makefile b/textproc/ruby-xmlscan/Makefile
index 5ed1ec80747e..934ebb633d8d 100644
--- a/textproc/ruby-xmlscan/Makefile
+++ b/textproc/ruby-xmlscan/Makefile
@@ -17,12 +17,7 @@ MAINTAINER= knu@FreeBSD.org
BUILD_DEPENDS= racc:${PORTSDIR}/devel/ruby-racc
USE_RUBY= yes
-
-.include <bsd.port.pre.mk>
-
-.if ${RUBY_VER} < 1.7
-RUN_DEPENDS+= ${RUBY_SITELIBDIR}/racc/parser.rb:${PORTSDIR}/lang/ruby16-shim-ruby18
-.endif
+USE_RUBY_FEATURES= racc-runtime
do-build:
cd ${WRKSRC}; racc -v -g -c -o xmldtd.rb xmldtd.ry
@@ -34,4 +29,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${RUBY_DOCDIR}/${PORTNAME}/ja/
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>