summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/epiphany/Makefile6
-rw-r--r--www/galeon/Makefile6
-rw-r--r--www/mplayer-plugin/Makefile10
3 files changed, 21 insertions, 1 deletions
diff --git a/www/epiphany/Makefile b/www/epiphany/Makefile
index 5869e343b9c4..e10845e49180 100644
--- a/www/epiphany/Makefile
+++ b/www/epiphany/Makefile
@@ -65,6 +65,12 @@ NO_WERROR= yes
CONFIGURE_ARGS+= --disable-werror
.endif
+.if ${OSVERSION} < 500000
+.if ${MOZILLA}=="mozilla-devel"
+USE_GCC= 3.4
+.endif
+.endif
+
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} " By default epiphany uses www/mozilla for html rendering, but you can"
diff --git a/www/galeon/Makefile b/www/galeon/Makefile
index 4f84383b25bb..450fa3641cda 100644
--- a/www/galeon/Makefile
+++ b/www/galeon/Makefile
@@ -67,6 +67,12 @@ NO_WERROR= yes
CONFIGURE_ARGS+= --disable-werror
.endif
+.if ${OSVERSION} < 500000
+.if ${MOZILLA}=="mozilla-devel"
+USE_GCC= 3.4
+.endif
+.endif
+
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} " By default the port uses www/mozilla for html rendering, but you can"
diff --git a/www/mplayer-plugin/Makefile b/www/mplayer-plugin/Makefile
index 777074afe53a..6346f30f313a 100644
--- a/www/mplayer-plugin/Makefile
+++ b/www/mplayer-plugin/Makefile
@@ -50,6 +50,14 @@ HEADERS_SUFX=
.endif
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+.if ${WITH_MOZILLA}=="mozilla-devel"
+USE_GCC= 3.4
+.endif
+.endif
+
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} " By default this port uses www/mozilla for Gecko support, but you can"
@@ -89,4 +97,4 @@ do-install:
${PREFIX}/etc/mplayerplug-in.types ;\
fi
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>