summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/bmp-fc/Makefile8
-rw-r--r--audio/festalon/Makefile4
-rw-r--r--audio/xmms-openspc/Makefile8
3 files changed, 18 insertions, 2 deletions
diff --git a/audio/bmp-fc/Makefile b/audio/bmp-fc/Makefile
index 5d9e8cbed4ad..d9bfcf69e187 100644
--- a/audio/bmp-fc/Makefile
+++ b/audio/bmp-fc/Makefile
@@ -21,7 +21,13 @@ USE_LDCONFIG= yes
PLIST_FILES= lib/bmp/Input/libfc.so lib/bmp/Input/libfc.la
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 1000000
+BROKEN= does not build on FreeBSD 10.x and later
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|\(objformat=\).*|\1elf|' ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/festalon/Makefile b/audio/festalon/Makefile
index 2b742efb497f..a47159a87a62 100644
--- a/audio/festalon/Makefile
+++ b/audio/festalon/Makefile
@@ -29,6 +29,10 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
+.if ${OSVERSION} >= 1000000
+BROKEN= does not build on FreeBSD 10.x and later
+.endif
+
.if ${PKGNAMEPREFIX} == ""
USE_SDL= yes
diff --git a/audio/xmms-openspc/Makefile b/audio/xmms-openspc/Makefile
index ed1fb1a7f6e6..bceff7b2bb14 100644
--- a/audio/xmms-openspc/Makefile
+++ b/audio/xmms-openspc/Makefile
@@ -24,7 +24,13 @@ PLIST_FILES= lib/xmms/Input/openspc.la \
ONLY_FOR_ARCHS= i386 # contains x86 assembler code
GNU_CONFIGURE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 1000000
+BROKEN= does not build on FreeBSD 10.x and later
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/objformat=/s|=.*|=elf|' ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>