summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/Makefile1
-rw-r--r--misc/pear-Text_Figlet/Makefile41
-rw-r--r--misc/pear-Text_Figlet/distinfo2
-rw-r--r--misc/pear-Text_Figlet/pkg-descr3
4 files changed, 47 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 2d9a85f1d74c..f27f8242254f 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -328,6 +328,7 @@
SUBDIR += pdfmap
SUBDIR += pdmenu
SUBDIR += pear-Services_Weather
+ SUBDIR += pear-Text_Figlet
SUBDIR += peq
SUBDIR += pg
SUBDIR += php4-calendar
diff --git a/misc/pear-Text_Figlet/Makefile b/misc/pear-Text_Figlet/Makefile
new file mode 100644
index 000000000000..69a2b4bc5c6d
--- /dev/null
+++ b/misc/pear-Text_Figlet/Makefile
@@ -0,0 +1,41 @@
+# Ports collection makefile for: pear-Text_Figlet
+# Date created: 15 December 2004
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text_Figlet
+PORTVERSION= 0.8.0
+CATEGORIES= misc pear
+
+MAINTAINER= antonio@php.net
+COMMENT= Render text using FIGlet fonts
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PHP= yes
+
+CATEGORY= Text
+FILES= Figlet.php
+DOCS= README.TXT
+EXAMPLES= 3-d.flf alligator2.flf bell.flf block.flf contessa.flf cybermedium.flf \
+ isometric1.flf larry3d.flf script.flf slant.flf figlet.php
+_EXAMPLESDIR= docs/examples
+
+post-extract:
+ ${MKDIR} ${WRKSRC}
+ ${MV} ${WRKDIR}/docs ${WRKSRC}/
+ ${MV} ${WRKDIR}/Figlet.php ${WRKSRC}/
+
+.include <bsd.port.pre.mk>
+
+PHP_VERS= ${PHP_VERSION:S/.//g}
+
+.if defined(PHP_VERS) && ${PHP_VERS} < 404
+IGNORE= "You need PHP 4.0.4 or later to install PEAR::Text_Figlet"
+.endif
+
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/misc/pear-Text_Figlet/distinfo b/misc/pear-Text_Figlet/distinfo
new file mode 100644
index 000000000000..74994cf53123
--- /dev/null
+++ b/misc/pear-Text_Figlet/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Text_Figlet-0.8.0.tgz) = 8010fee97da24e69f2c1f879e92939b9
+SIZE (PEAR/Text_Figlet-0.8.0.tgz) = 22756
diff --git a/misc/pear-Text_Figlet/pkg-descr b/misc/pear-Text_Figlet/pkg-descr
new file mode 100644
index 000000000000..2a43db2cab10
--- /dev/null
+++ b/misc/pear-Text_Figlet/pkg-descr
@@ -0,0 +1,3 @@
+Engine for use FIGlet fonts to rendering text.
+
+WWW: http://pear.php.net/package/Text_Figlet/