summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/lincvs/Makefile4
-rw-r--r--devel/lincvs/files/patch-src-PixmapTimer.h11
-rw-r--r--net-p2p/qtella/files/patch-include__AudioMp3.h11
-rw-r--r--net-p2p/qtella/files/patch-include__AudioOgg.h11
-rw-r--r--net-p2p/qtella/files/patch-include__AudioWav.h11
-rw-r--r--net-p2p/qtella/files/patch-include__BitTorrent.h11
6 files changed, 55 insertions, 4 deletions
diff --git a/devel/lincvs/Makefile b/devel/lincvs/Makefile
index d741dcdefd38..dc1ca8f6d40c 100644
--- a/devel/lincvs/Makefile
+++ b/devel/lincvs/Makefile
@@ -27,10 +27,6 @@ ALL_TARGET= install
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' \
${WRKSRC}/src/main.cpp \
diff --git a/devel/lincvs/files/patch-src-PixmapTimer.h b/devel/lincvs/files/patch-src-PixmapTimer.h
new file mode 100644
index 000000000000..c344d4e7613a
--- /dev/null
+++ b/devel/lincvs/files/patch-src-PixmapTimer.h
@@ -0,0 +1,11 @@
+--- src/PixmapTimer.h.orig Tue May 29 17:05:42 2007
++++ src/PixmapTimer.h Tue May 29 17:05:59 2007
+@@ -84,7 +84,7 @@
+
+ public:
+ CPixmapTimer(QObject * parent = 0, const char * name = 0);
+- CPixmapTimer::~CPixmapTimer();
++ ~CPixmapTimer();
+
+ signals:
+ void signalTimeout(const QPixmap &);
diff --git a/net-p2p/qtella/files/patch-include__AudioMp3.h b/net-p2p/qtella/files/patch-include__AudioMp3.h
new file mode 100644
index 000000000000..ea4de9f26a3a
--- /dev/null
+++ b/net-p2p/qtella/files/patch-include__AudioMp3.h
@@ -0,0 +1,11 @@
+--- include/AudioMp3.h.orig Tue May 29 17:24:13 2007
++++ include/AudioMp3.h Tue May 29 17:27:29 2007
+@@ -11,7 +11,7 @@
+ class AudioMp3: public MyAudioFile
+ {
+ public:
+- AudioMp3::AudioMp3( std::string filename );
++ AudioMp3( std::string filename );
+ std::string &getTitle() { return _title; };
+ void setTitle( std::string str ) { _title = str; };
+ std::string &getArtist() { return _artist;} ;
diff --git a/net-p2p/qtella/files/patch-include__AudioOgg.h b/net-p2p/qtella/files/patch-include__AudioOgg.h
new file mode 100644
index 000000000000..79c988346fbd
--- /dev/null
+++ b/net-p2p/qtella/files/patch-include__AudioOgg.h
@@ -0,0 +1,11 @@
+--- include/AudioOgg.h.otih Tue May 29 17:25:30 2007
++++ include/AudioOgg.h Tue May 29 17:27:46 2007
+@@ -11,7 +11,7 @@
+ class AudioOgg: public MyAudioFile
+ {
+ public:
+- AudioOgg::AudioOgg( std::string filename );
++ AudioOgg( std::string filename );
+ std::string &getTitle() { return _title; };
+ void setTitle( std::string str ) { _title = str; }
+ std::string &getArtist() { return _artist;} ;
diff --git a/net-p2p/qtella/files/patch-include__AudioWav.h b/net-p2p/qtella/files/patch-include__AudioWav.h
new file mode 100644
index 000000000000..7df28a433fbc
--- /dev/null
+++ b/net-p2p/qtella/files/patch-include__AudioWav.h
@@ -0,0 +1,11 @@
+--- include/AudioWav.h.orig Tue May 29 17:25:24 2007
++++ include/AudioWav.h Tue May 29 17:27:38 2007
+@@ -11,7 +11,7 @@
+ class AudioWav: public MyAudioFile
+ {
+ public:
+- AudioWav::AudioWav( std::string filename );
++ AudioWav( std::string filename );
+ std::string &getTitle() { return _title; };
+ std::string &getArtist() { return _artist;} ;
+ // std::string &getAlbum() { return _album; };
diff --git a/net-p2p/qtella/files/patch-include__BitTorrent.h b/net-p2p/qtella/files/patch-include__BitTorrent.h
new file mode 100644
index 000000000000..2e9f10ccab30
--- /dev/null
+++ b/net-p2p/qtella/files/patch-include__BitTorrent.h
@@ -0,0 +1,11 @@
+--- include/BitTorrent.h.orig Tue May 29 17:19:03 2007
++++ include/BitTorrent.h Tue May 29 17:19:18 2007
+@@ -67,7 +67,7 @@
+ public:
+ ~BitTorrent();
+ static BitTorrent* decode( const char* buf, int len );
+- static BitTorrent* BitTorrent::bt_decode_file( const char* filename );
++ static BitTorrent* bt_decode_file( const char* filename );
+ void setAnnounce( const std::string& announce );
+ const std::string& getAnnounce() const;
+ void setSingleFile( bool s );