summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/Makefile1
-rw-r--r--misc/ipbt/Makefile34
-rw-r--r--misc/ipbt/distinfo3
-rw-r--r--misc/ipbt/pkg-descr12
4 files changed, 50 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 6b915bd2d9ad..d805afafff90 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -157,6 +157,7 @@
SUBDIR += instant-server
SUBDIR += instant-tinderbox
SUBDIR += instant-workstation
+ SUBDIR += ipbt
SUBDIR += iselect
SUBDIR += iso-codes
SUBDIR += jargon
diff --git a/misc/ipbt/Makefile b/misc/ipbt/Makefile
new file mode 100644
index 000000000000..a9b96a785798
--- /dev/null
+++ b/misc/ipbt/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: ipbt
+# Date created: 7 May 2006
+# Whom: Matt Mills <matt_mills@btopenworld.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipbt
+DISTVERSION= r6489
+CATEGORIES= misc
+MASTER_SITES= http://www.chiark.greenend.org.uk/~sgtatham/ipbt/
+
+MAINTAINER= matt_mills@btopenworld.com
+COMMENT= A high-tech ttyrec player with improvements over ttyplay
+
+USE_PERL5_BUILD= yes
+
+ALL_TARGET= ${PORTNAME}
+PLIST_FILES= bin/ipbt
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= requires mbrtowc() and wcrtomb()
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e '1s|.*|#!${PERL} -w|' ${WRKSRC}/sbcsgen.pl
+ @${REINPLACE_CMD} -e 's|perl|${PERL}|' ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/misc/ipbt/distinfo b/misc/ipbt/distinfo
new file mode 100644
index 000000000000..a7c35921ef2b
--- /dev/null
+++ b/misc/ipbt/distinfo
@@ -0,0 +1,3 @@
+MD5 (ipbt-r6489.tar.gz) = 9fe27f435f270bfd55172721a41e9ac0
+SHA256 (ipbt-r6489.tar.gz) = 703f753cd799e09d9f020e233c87d4eccb6a750b2ea5f935969f172db3c82c8c
+SIZE (ipbt-r6489.tar.gz) = 158469
diff --git a/misc/ipbt/pkg-descr b/misc/ipbt/pkg-descr
new file mode 100644
index 000000000000..3eeff4fea5d1
--- /dev/null
+++ b/misc/ipbt/pkg-descr
@@ -0,0 +1,12 @@
+IPBT (It's Play-Back Time) is a ttyrec player with many features
+that ttyplay lacks. Notable features are:
+
+ * Pausing
+ * Move forward/backward frame by frame
+ * Adjustable play speed (faster/slower)
+ * Jump to beginning/end in a single keystroke
+
+IPBT works by reading the entire input file and running it through
+an internal terminal emulator (the one from PuTTY).
+
+WWW: http://www.chiark.greenend.org.uk/~sgtatham/ipbt/