summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/wmweather+/Makefile29
-rw-r--r--misc/wmweather+/pkg-plist2
2 files changed, 31 insertions, 0 deletions
diff --git a/misc/wmweather+/Makefile b/misc/wmweather+/Makefile
index a54da9b47636..df112928e084 100644
--- a/misc/wmweather+/Makefile
+++ b/misc/wmweather+/Makefile
@@ -6,6 +6,7 @@
PORTNAME= wmweather+
PORTVERSION= 2.4
+PORTREVISION= 1
CATEGORIES= misc windowmaker
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= wmweatherplus
@@ -13,8 +14,22 @@ MASTER_SITE_SUBDIR= wmweatherplus
MAINTAINER= harald.wille@students.jku.at
COMMENT= Think wmweather with forecasts, weather map, and a sky cond. display
+LIB_DEPENDS= www[a-z]+:${PORTSDIR}/www/libwww \
+ xmltok:${PORTSDIR}/www/libwww \
+ xmlparse:${PORTSDIR}/www/libwww \
+ wraster:${PORTSDIR}/x11-wm/windowmaker \
+ pcre:${PORTSDIR}/devel/pcre \
+ Xpm:${PORTSDIR}/graphics/xpm \
+ tiff:${PORTSDIR}/graphics/tiff \
+ Hermes:${PORTSDIR}/graphics/Hermes \
+ png:${PORTSDIR}/graphics/png \
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ ungif:${PORTSDIR}/graphics/libungif \
+ iconv:${PORTSDIR}/converters/libiconv
+
GNU_CONFIGURE= yes
USE_X_PREFIX= yes
+USE_XLIB= yes
USE_XPM= yes
MAN1= wmweather+.1
@@ -23,4 +38,18 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmweather+ ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/wmweather+.1 ${PREFIX}/man/man1
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/example.conf ${EXAMPLESDIR}/example.conf
+
+ @${ECHO} ""
+ @${ECHO} "================================================="
+ @${ECHO} "Sample configuration file has been copied to"
+ @${ECHO} "${EXAMPLESDIR}/example.conf"
+ @${ECHO} ""
+ @${ECHO} "Please copy it to your homedir into .wmweather+"
+ @${ECHO} "as conf and adjust it to your needs!"
+ @${ECHO} "================================================="
+ @${ECHO} ""
+
.include <bsd.port.mk>
diff --git a/misc/wmweather+/pkg-plist b/misc/wmweather+/pkg-plist
index e2f90e874d55..c980c4066040 100644
--- a/misc/wmweather+/pkg-plist
+++ b/misc/wmweather+/pkg-plist
@@ -1 +1,3 @@
bin/wmweather+
+%%EXAMPLESDIR%%/example.conf
+@dirrm %%EXAMPLESDIR%%