summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/bonobo-activation/Makefile2
-rw-r--r--devel/libbonobo/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/devel/bonobo-activation/Makefile b/devel/bonobo-activation/Makefile
index d61819e0a04e..1dcc21ed06cf 100644
--- a/devel/bonobo-activation/Makefile
+++ b/devel/bonobo-activation/Makefile
@@ -27,7 +27,7 @@ USE_PERL5= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
--disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -pthread"
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= bonobo-activation-server.1
diff --git a/devel/libbonobo/Makefile b/devel/libbonobo/Makefile
index 7d9a7cd7ed70..e380bf1d6d1d 100644
--- a/devel/libbonobo/Makefile
+++ b/devel/libbonobo/Makefile
@@ -24,7 +24,7 @@ USE_LIBTOOL= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
--disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -pthread"
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAKE_ENV= gnomelocaledir=${PREFIX}/share/locale