summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/sawfish2/Makefile2
-rw-r--r--x11-wm/sawfish2/files/patch-lisp_sawfish_wm_windows.jl11
2 files changed, 12 insertions, 1 deletions
diff --git a/x11-wm/sawfish2/Makefile b/x11-wm/sawfish2/Makefile
index ada909aee287..b468b12534f7 100644
--- a/x11-wm/sawfish2/Makefile
+++ b/x11-wm/sawfish2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sawfish2
PORTVERSION= 1.2
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 2
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_GNOME}
diff --git a/x11-wm/sawfish2/files/patch-lisp_sawfish_wm_windows.jl b/x11-wm/sawfish2/files/patch-lisp_sawfish_wm_windows.jl
new file mode 100644
index 000000000000..1ee60c9f51cb
--- /dev/null
+++ b/x11-wm/sawfish2/files/patch-lisp_sawfish_wm_windows.jl
@@ -0,0 +1,11 @@
+--- lisp/sawfish/wm/windows.jl.orig Thu Feb 13 12:54:55 2003
++++ lisp/sawfish/wm/windows.jl Thu Feb 13 12:55:33 2003
+@@ -320,7 +320,7 @@
+ (t x))))
+
+ (define (adjust-position-for-gravity/y w grav y #!key inverse)
+- (let* ((tl-off (window-frame-offset w))
++ (let* ((tl-off (cdr (window-frame-offset w)))
+ (br-off (- (cdr (window-frame-dimensions w))
+ (cdr (window-dimensions w))))
+ (sign (if inverse -1 +1)))