summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/shlock/Makefile30
-rw-r--r--sysutils/shlock/distinfo1
-rw-r--r--sysutils/shlock/pkg-comment1
-rw-r--r--sysutils/shlock/pkg-descr8
-rw-r--r--sysutils/shlock/pkg-plist1
6 files changed, 42 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index a52abc31189a..e26e26a1cef6 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -176,6 +176,7 @@
SUBDIR += service-config
SUBDIR += setcdboot
SUBDIR += setquota
+ SUBDIR += shlock
SUBDIR += skill
SUBDIR += slay
SUBDIR += slmon
diff --git a/sysutils/shlock/Makefile b/sysutils/shlock/Makefile
new file mode 100644
index 000000000000..234a896dc9c4
--- /dev/null
+++ b/sysutils/shlock/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: shlock
+# Date created: 8 July 2002
+# Whom: dougb
+#
+# $FreeBSD$
+#
+
+PORTNAME= shlock
+PORTVERSION= 2.3.3
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.isc.org/isc/inn/
+
+DISTFILES= inn-${PORTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= DougB@FreeBSD.org
+
+HAS_CONFIGURE= yes
+
+MAN1= shlock.1
+
+WRKSRC= ${WRKDIR}/inn-${PORTVERSION}
+
+do-build:
+ cd ${WRKSRC}/backends && ${MAKE} shlock
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/backends/shlock ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/man/shlock.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/sysutils/shlock/distinfo b/sysutils/shlock/distinfo
new file mode 100644
index 000000000000..e751f2886bf8
--- /dev/null
+++ b/sysutils/shlock/distinfo
@@ -0,0 +1 @@
+MD5 (inn-2.3.3.tar.gz) = 97080ce1dcdc5fe8f3dacd230c9d4a0a
diff --git a/sysutils/shlock/pkg-comment b/sysutils/shlock/pkg-comment
new file mode 100644
index 000000000000..066a9af2ce3b
--- /dev/null
+++ b/sysutils/shlock/pkg-comment
@@ -0,0 +1 @@
+Create lock files for use in shell scripts
diff --git a/sysutils/shlock/pkg-descr b/sysutils/shlock/pkg-descr
new file mode 100644
index 000000000000..b2ec9c9d952f
--- /dev/null
+++ b/sysutils/shlock/pkg-descr
@@ -0,0 +1,8 @@
+The historical, and still very useful process-locking program. Use to make
+sure that your shell script is the only version of itself running on your
+system. There are many other creative ways to use this program.
+
+WWW: http://www.isc.org/products/INN/
+
+- Doug Barton
+DougB@FreeBSD.org
diff --git a/sysutils/shlock/pkg-plist b/sysutils/shlock/pkg-plist
new file mode 100644
index 000000000000..860912ac605e
--- /dev/null
+++ b/sysutils/shlock/pkg-plist
@@ -0,0 +1 @@
+bin/shlock