summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--archivers/bzip2/Makefile5
-rw-r--r--archivers/bzip2/distinfo6
-rw-r--r--archivers/bzip2/files/patch-aa16
-rw-r--r--archivers/bzip2/files/patch-bzip2.c93
-rw-r--r--archivers/bzip2/pkg-descr2
5 files changed, 15 insertions, 107 deletions
diff --git a/archivers/bzip2/Makefile b/archivers/bzip2/Makefile
index c1d1bb43f4e2..80866dff6ee2 100644
--- a/archivers/bzip2/Makefile
+++ b/archivers/bzip2/Makefile
@@ -7,15 +7,14 @@
#
PORTNAME= bzip2
-PORTVERSION= 1.0.3
-PORTREVISION= 1
+PORTVERSION= 1.0.4
CATEGORIES= archivers
MASTER_SITES= http://www.bzip.org/${PORTVERSION}/
MAINTAINER= jharris@widomaker.com
COMMENT= A block-sorting file compressor
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
PATCH_STRIP= -p3
MAN1= bzip2.1 bzgrep.1 bzmore.1
diff --git a/archivers/bzip2/distinfo b/archivers/bzip2/distinfo
index f78e907d7b4d..a8b5c63b94d7 100644
--- a/archivers/bzip2/distinfo
+++ b/archivers/bzip2/distinfo
@@ -1,3 +1,3 @@
-MD5 (bzip2-1.0.3.tar.gz) = 8a716bebecb6e647d2e8a29ea5d8447f
-SHA256 (bzip2-1.0.3.tar.gz) = 4aaa8e7b4ecf03d91c33e8bf92d489533fa6c1f99e825c34058003f18eb68c13
-SIZE (bzip2-1.0.3.tar.gz) = 669075
+MD5 (bzip2-1.0.4.tar.gz) = fc310b254f6ba5fbb5da018f04533688
+SHA256 (bzip2-1.0.4.tar.gz) = f41c3898fbd53e68e0b052418960e538813cc98afcd72b2b604079d8de3e529c
+SIZE (bzip2-1.0.4.tar.gz) = 841221
diff --git a/archivers/bzip2/files/patch-aa b/archivers/bzip2/files/patch-aa
index 5496acf507a6..3cb244c9242e 100644
--- a/archivers/bzip2/files/patch-aa
+++ b/archivers/bzip2/files/patch-aa
@@ -1,6 +1,6 @@
---- Makefile.orig Thu Feb 17 14:28:24 2005
-+++ Makefile Tue Jul 19 02:39:56 2005
-@@ -2,13 +2,15 @@
+--- Makefile.orig Tue Jan 2 22:49:21 2007
++++ Makefile Sat Jan 27 12:02:14 2007
+@@ -15,13 +15,15 @@
SHELL=/bin/sh
# To assist in cross-compiling
@@ -11,14 +11,14 @@
LDFLAGS=
BIGFILES=-D_FILE_OFFSET_BITS=64
--CFLAGS=-Wall -Winline -O -g $(BIGFILES)
+-CFLAGS=-Wall -Winline -O2 -g $(BIGFILES)
+CFLAGS?=-O2
+CFLAGS+=-Wall -Winline -fomit-frame-pointer -fno-strength-reduce $(BIGFILES)
+SOFLAGS=-fPIC -fpic -DPIC
# Where you want it installed when you do 'make install'
- PREFIX=/usr
-@@ -22,10 +24,18 @@
+ PREFIX=/usr/local
+@@ -35,10 +37,18 @@
decompress.o \
bzlib.o
@@ -40,7 +40,7 @@
bzip2recover: bzip2recover.o
$(CC) $(CFLAGS) $(LDFLAGS) -o bzip2recover bzip2recover.o
-@@ -39,6 +49,10 @@
+@@ -52,6 +62,10 @@
$(RANLIB) libbz2.a ; \
fi
@@ -51,7 +51,7 @@
check: test
test: bzip2
@cat words1
-@@ -96,9 +110,25 @@
+@@ -109,9 +123,25 @@
echo ".so man1/bzdiff.1" > $(PREFIX)/man/man1/bzcmp.1
clean:
diff --git a/archivers/bzip2/files/patch-bzip2.c b/archivers/bzip2/files/patch-bzip2.c
index dcf2cdb42987..8b137891791f 100644
--- a/archivers/bzip2/files/patch-bzip2.c
+++ b/archivers/bzip2/files/patch-bzip2.c
@@ -1,92 +1 @@
---- bzip2.c.orig Wed Feb 16 03:25:35 2005
-+++ bzip2.c Sun Oct 16 09:47:40 2005
-@@ -312,6 +312,7 @@
-
- static void copyFileName ( Char*, Char* );
- static void* myMalloc ( Int32 );
-+static int applySavedFileAttrToOutputFile ( int fd );
-
-
-
-@@ -457,6 +458,10 @@
- ret = fflush ( zStream );
- if (ret == EOF) goto errhandler_io;
- if (zStream != stdout) {
-+ int fd = fileno ( zStream );
-+ if (fd < 0) goto errhandler_io;
-+ ret = applySavedFileAttrToOutputFile ( fd );
-+ if (ret != 0) goto errhandler_io;
- ret = fclose ( zStream );
- outputHandleJustInCase = NULL;
- if (ret == EOF) goto errhandler_io;
-@@ -569,6 +574,12 @@
-
- closeok:
- if (ferror(zStream)) goto errhandler_io;
-+ if ( stream != stdout) {
-+ int fd = fileno ( stream );
-+ if (fd < 0) goto errhandler_io;
-+ ret = applySavedFileAttrToOutputFile ( fd );
-+ if (ret != 0) goto errhandler_io;
-+ }
- ret = fclose ( zStream );
- if (ret == EOF) goto errhandler_io;
-
-@@ -1129,7 +1140,7 @@
-
-
- static
--void applySavedMetaInfoToOutputFile ( Char *dstName )
-+void applySavedTimeInfoToOutputFile ( Char *dstName )
- {
- # if BZ_UNIX
- IntNative retVal;
-@@ -1138,16 +1149,26 @@
- uTimBuf.actime = fileMetaInfo.st_atime;
- uTimBuf.modtime = fileMetaInfo.st_mtime;
-
-- retVal = chmod ( dstName, fileMetaInfo.st_mode );
-- ERROR_IF_NOT_ZERO ( retVal );
--
- retVal = utime ( dstName, &uTimBuf );
- ERROR_IF_NOT_ZERO ( retVal );
-+# endif
-+}
-+
-+static
-+int applySavedFileAttrToOutputFile ( int fd )
-+{
-+# if BZ_UNIX
-+ IntNative retVal;
-+
-+ retVal = fchmod ( fd, fileMetaInfo.st_mode );
-+ if (retVal != 0)
-+ return retVal;
-
-- retVal = chown ( dstName, fileMetaInfo.st_uid, fileMetaInfo.st_gid );
-+ (void) fchown ( fd, fileMetaInfo.st_uid, fileMetaInfo.st_gid );
- /* chown() will in many cases return with EPERM, which can
- be safely ignored.
- */
-+ return 0;
- # endif
- }
-
-@@ -1370,7 +1391,7 @@
-
- /*--- If there was an I/O error, we won't get here. ---*/
- if ( srcMode == SM_F2F ) {
-- applySavedMetaInfoToOutputFile ( outName );
-+ applySavedTimeInfoToOutputFile ( outName );
- deleteOutputOnInterrupt = False;
- if ( !keepInputFiles ) {
- IntNative retVal = remove ( inName );
-@@ -1548,7 +1569,7 @@
- /*--- If there was an I/O error, we won't get here. ---*/
- if ( magicNumberOK ) {
- if ( srcMode == SM_F2F ) {
-- applySavedMetaInfoToOutputFile ( outName );
-+ applySavedTimeInfoToOutputFile ( outName );
- deleteOutputOnInterrupt = False;
- if ( !keepInputFiles ) {
- IntNative retVal = remove ( inName );
+
diff --git a/archivers/bzip2/pkg-descr b/archivers/bzip2/pkg-descr
index 1b629d33184d..8f8358f9ebdc 100644
--- a/archivers/bzip2/pkg-descr
+++ b/archivers/bzip2/pkg-descr
@@ -1,4 +1,4 @@
This is bzip2, a advanced block-sorting file compressor. It is
believed to be free from any patents.
-WWW: http://www.bzip.org
+WWW: http://www.bzip.org/