summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/cadaver/Makefile15
-rw-r--r--www/cadaver/distinfo6
-rw-r--r--www/cadaver/files/patch-Makefile.in23
-rw-r--r--www/cadaver/files/patch-aa11
-rw-r--r--www/cadaver/files/patch-src-cmdline.c8
-rw-r--r--www/cadaver/files/patch-src-commands.c71
-rw-r--r--www/cadaver/files/patch-src-ls.c8
-rw-r--r--www/cadaver/files/patch-src-search.c8
-rw-r--r--www/cadaver/files/patch-src-version.c8
9 files changed, 141 insertions, 17 deletions
diff --git a/www/cadaver/Makefile b/www/cadaver/Makefile
index 4aeea1d2fe49..700db7450368 100644
--- a/www/cadaver/Makefile
+++ b/www/cadaver/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cadaver
-PORTVERSION= 0.23.2
+PORTVERSION= 0.23.3
CATEGORIES= www
MASTER_SITES= http://www.webdav.org/cadaver/ \
http://www.tcbug.org/
@@ -14,12 +14,13 @@ MASTER_SITES= http://www.webdav.org/cadaver/ \
MAINTAINER= jpaetzel@FreeBSD.org
COMMENT= Commandline client for DAV
-LIB_DEPENDS= neon.28:${PORTSDIR}/www/neon28
+LIB_DEPENDS= neon:${PORTSDIR}/www/neon29
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-netrc
ALL_TARGET= cadaver
+MAKE_JOBS_SAFE= yes
MAN1= cadaver.1
PLIST_FILES= bin/cadaver
@@ -31,7 +32,9 @@ PLIST_FILES= bin/cadaver
EXTRACT_AFTER_ARGS= | ${TAR} -xf - \
--exclude '${PORTNAME}-${PORTVERSION}/lib/expat/*.[ch]' \
--exclude '${PORTNAME}-${PORTVERSION}/lib/intl/*.[ch]' \
- --exclude '${PORTNAME}-${PORTVERSION}/lib/neon/*.[ch]'
+ --exclude '${PORTNAME}-${PORTVERSION}/lib/neon/*.[ch]' \
+ --exclude 'glob.[ch]' --exclude 'mkstemp.[ch]' \
+ --exclude 'tempname.[ch]' --exclude 'basename.[ch]'
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
@@ -39,6 +42,12 @@ LDFLAGS= -L${LOCALBASE}/lib
.if !defined(WITHOUT_OPENSSL)
USE_OPENSSL= yes
CONFIGURE_ARGS+= --with-ssl --with-force-ssl
+post-install:
+ #
+ #
+ @${CAT} ${PKGMESSAGE}
+ #
+ #
.endif
.if !defined(WITHOUT_NLS)
diff --git a/www/cadaver/distinfo b/www/cadaver/distinfo
index 17e24c1208b6..e0f42d850add 100644
--- a/www/cadaver/distinfo
+++ b/www/cadaver/distinfo
@@ -1,3 +1,3 @@
-MD5 (cadaver-0.23.2.tar.gz) = 5ac79e41f3b7b4f68bf4003beed5dc26
-SHA256 (cadaver-0.23.2.tar.gz) = 9885511fe98c389a57e04d9d72334ac3b0752534e88710b0623b2f6aa9015844
-SIZE (cadaver-0.23.2.tar.gz) = 757303
+MD5 (cadaver-0.23.3.tar.gz) = 502ecd601e467f8b16056d2acca39a6f
+SHA256 (cadaver-0.23.3.tar.gz) = fd4ce68a3230ba459a92bcb747fc6afa91e46d803c1d5ffe964b661793c13fca
+SIZE (cadaver-0.23.3.tar.gz) = 831884
diff --git a/www/cadaver/files/patch-Makefile.in b/www/cadaver/files/patch-Makefile.in
new file mode 100644
index 000000000000..09e60593ed29
--- /dev/null
+++ b/www/cadaver/files/patch-Makefile.in
@@ -0,0 +1,23 @@
+--- Makefile.in 2008-02-11 05:29:53.000000000 -0500
++++ Makefile.in 2010-04-16 14:31:42.000000000 -0400
+@@ -42,6 +42,6 @@
+ src/cmdline.o src/options.o src/utils.o src/edit.o \
+ src/version.o src/search.o
+-LIBOBJS = lib/basename.o lib/dirname.o lib/rpmatch.o lib/yesno.o \
+- lib/glob.o lib/getpass.o lib/tempname.o lib/mkstemp.o \
++LIBOBJS = lib/rpmatch.o lib/yesno.o \
++ lib/getpass.o \
+ @LIBOBJS@
+ ALLOBJS = $(OBJECTS) $(LIBOBJS)
+@@ -92,8 +92,8 @@
+ src/options.h src/cmdline.h src/commands.h src/cadaver.h
+ src/options.o: src/options.c config.h src/options.h src/cadaver.h src/common.h
+-src/cmdline.o: src/cmdline.c src/cmdline.h src/cadaver.h lib/basename.h \
+- lib/glob.h src/commands.h src/common.h
++src/cmdline.o: src/cmdline.c src/cmdline.h src/cadaver.h \
++ src/commands.h src/common.h
+ src/commands.o: src/commands.c src/commands.h src/cadaver.h \
+- lib/basename.h src/options.h src/common.h
++ src/options.h src/common.h
+ src/edit.o: src/edit.c src/cadaver.h src/options.h src/common.h
+ src/common.o: src/common.c src/common.h config.h
diff --git a/www/cadaver/files/patch-aa b/www/cadaver/files/patch-aa
index a7687a337c33..e69de29bb2d1 100644
--- a/www/cadaver/files/patch-aa
+++ b/www/cadaver/files/patch-aa
@@ -1,11 +0,0 @@
---- lib/glob.h.orig Sun Oct 20 14:19:39 2002
-+++ lib/glob.h Sun Oct 20 14:19:56 2002
-@@ -47,7 +47,7 @@
- #endif /* C++ or ANSI C. */
-
- /* We need `size_t' for the following definitions. */
--#ifndef __size_t
-+#if !defined(__size_t) && !defined(__FreeBSD__)
- # if defined __GNUC__ && __GNUC__ >= 2
- typedef __SIZE_TYPE__ __size_t;
- # else
diff --git a/www/cadaver/files/patch-src-cmdline.c b/www/cadaver/files/patch-src-cmdline.c
new file mode 100644
index 000000000000..e9f9dc8d093d
--- /dev/null
+++ b/www/cadaver/files/patch-src-cmdline.c
@@ -0,0 +1,8 @@
+--- src/cmdline.c 2006-12-28 12:01:51.000000000 -0500
++++ src/cmdline.c 2010-04-16 14:31:42.000000000 -0400
+@@ -39,5 +39,4 @@
+ #include "i18n.h"
+ #include "glob.h"
+-#include "basename.h"
+
+ #include "common.h"
diff --git a/www/cadaver/files/patch-src-commands.c b/www/cadaver/files/patch-src-commands.c
new file mode 100644
index 000000000000..74e3f87cbf5b
--- /dev/null
+++ b/www/cadaver/files/patch-src-commands.c
@@ -0,0 +1,71 @@
+--- src/commands.c 2008-11-11 03:40:54.000000000 -0500
++++ src/commands.c 2010-04-16 14:31:42.000000000 -0400
+@@ -71,6 +71,5 @@
+
+ #include "i18n.h"
+-#include "basename.h"
+-#include "dirname.h"
++#include <libgen.h>
+ #include "cadaver.h"
+ #include "commands.h"
+@@ -765,9 +764,9 @@
+ src_is_coll = (src[strlen(src)-1] == '/');
+ if (strcmp(dest, ".") == 0) {
+- ret = resolve_path(p, base_name(src), false);
++ ret = resolve_path(p, basename(src), false);
+ } else if (strcmp(dest, "..") == 0) {
+ char *parent;
+ parent = ne_path_parent(p);
+- ret = resolve_path(parent, base_name(src), false);
++ ret = resolve_path(parent, basename(src), false);
+ free(parent);
+ } else if (!src_is_coll && dest_is_coll) {
+@@ -775,5 +774,5 @@
+ * be the basename of file concated with the collection. */
+ char *tmp = resolve_path(p, dest, true);
+- char *enc = escape_path(base_name(src));
++ char *enc = escape_path(basename(src));
+ ret = ne_concat(tmp, enc, NULL);
+ free(enc);
+@@ -950,5 +949,5 @@
+ struct stat st;
+ /* Choose an appropriate local filename */
+- if (stat(base_name(remote), &st) == 0) {
++ if (stat(basename(remote), &st) == 0) {
+ char buf[BUFSIZ];
+ /* File already exists... don't overwrite */
+@@ -962,5 +961,5 @@
+ }
+ } else {
+- filename = ne_strdup(base_name(remote));
++ filename = ne_strdup(basename(remote));
+ }
+ } else {
+@@ -1004,5 +1003,5 @@
+ char *real_remote;
+ if (remote == NULL) {
+- real_remote = resolve_path(session.uri.path, base_name(local), false);
++ real_remote = resolve_path(session.uri.path, basename(local), false);
+ } else {
+ real_remote = resolve_path(session.uri.path, remote, false);
+--- src/edit.c 2008-10-24 07:36:41.000000000 -0400
++++ src/edit.c 2010-04-16 14:37:24.000000000 -0400
+@@ -117,5 +117,5 @@
+ char fname[PATH_MAX] = "/tmp/cadaver-edit-XXXXXX";
+ const char *pnt;
+- int fd;
++ int fd, sufx_len;
+ int is_checkout, is_checkin;
+
+@@ -141,7 +141,9 @@
+ strncat(fname, pnt, PATH_MAX);
+ fname[PATH_MAX-1] = '\0';
+- }
++ sufx_len = strlen(pnt);
++ } else
++ sufx_len = 0;
+
+- fd = cad_mkstemp(fname);
++ fd = mkstemps(fname, sufx_len);
+ if (fd == -1) {
+ printf(_("Could not create temporary file %s:\n%s\n"), fname,
diff --git a/www/cadaver/files/patch-src-ls.c b/www/cadaver/files/patch-src-ls.c
new file mode 100644
index 000000000000..a63d88325f90
--- /dev/null
+++ b/www/cadaver/files/patch-src-ls.c
@@ -0,0 +1,8 @@
+--- src/ls.c 2008-10-10 11:29:05.000000000 -0400
++++ src/ls.c 2010-04-16 14:31:42.000000000 -0400
+@@ -40,5 +40,4 @@
+ #include "commands.h"
+ #include "cadaver.h"
+-#include "basename.h"
+ #include "utils.h"
+
diff --git a/www/cadaver/files/patch-src-search.c b/www/cadaver/files/patch-src-search.c
new file mode 100644
index 000000000000..c3016779c0c8
--- /dev/null
+++ b/www/cadaver/files/patch-src-search.c
@@ -0,0 +1,8 @@
+--- src/search.c 2007-08-22 08:24:56.000000000 -0400
++++ src/search.c 2010-04-16 14:31:42.000000000 -0400
+@@ -42,5 +42,4 @@
+ #include "commands.h"
+ #include "cadaver.h"
+-#include "basename.h"
+ #include "options.h"
+ #include "utils.h"
diff --git a/www/cadaver/files/patch-src-version.c b/www/cadaver/files/patch-src-version.c
new file mode 100644
index 000000000000..3f5c5efbd791
--- /dev/null
+++ b/www/cadaver/files/patch-src-version.c
@@ -0,0 +1,8 @@
+--- src/version.c 2007-08-22 08:17:27.000000000 -0400
++++ src/version.c 2010-04-16 14:31:42.000000000 -0400
+@@ -41,5 +41,4 @@
+ #include "commands.h"
+ #include "cadaver.h"
+-#include "basename.h"
+ #include "utils.h"
+