summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/gd/Makefile4
-rw-r--r--graphics/gd/files/patch-ac18
-rw-r--r--graphics/gd1/Makefile4
-rw-r--r--graphics/gd1/files/patch-ac18
-rw-r--r--graphics/gd2/Makefile4
-rw-r--r--graphics/gd2/files/patch-ac18
-rw-r--r--japanese/gd/Makefile25
-rw-r--r--japanese/gd/distinfo2
-rw-r--r--japanese/gd/files/patch-ab20
-rw-r--r--japanese/gd/pkg-comment1
-rw-r--r--japanese/gd/pkg-descr24
-rw-r--r--japanese/gd/pkg-plist19
-rw-r--r--japanese/gd1/Makefile25
-rw-r--r--japanese/gd1/distinfo2
-rw-r--r--japanese/gd1/files/patch-ab20
-rw-r--r--japanese/gd1/pkg-comment1
-rw-r--r--japanese/gd1/pkg-descr24
-rw-r--r--japanese/gd1/pkg-plist19
18 files changed, 47 insertions, 201 deletions
diff --git a/graphics/gd/Makefile b/graphics/gd/Makefile
index 8dfda987f477..6b00fe5be149 100644
--- a/graphics/gd/Makefile
+++ b/graphics/gd/Makefile
@@ -7,13 +7,13 @@
PORTNAME= gd
PORTVERSION= 1.8.4
-CATEGORIES= graphics
+CATEGORIES+= graphics
MASTER_SITES= http://www.boutell.com/gd/http/ \
ftp://ftp.boutell.com/pub/boutell/gd/ \
${MASTER_SITE_RINGSERVER}
MASTER_SITE_SUBDIR= graphics/gd
-MAINTAINER= billf@FreeBSD.org
+MAINTAINER?= billf@FreeBSD.org
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
diff --git a/graphics/gd/files/patch-ac b/graphics/gd/files/patch-ac
index c85d793c55c7..645f72cfa48b 100644
--- a/graphics/gd/files/patch-ac
+++ b/graphics/gd/files/patch-ac
@@ -1,5 +1,5 @@
--- Makefile.orig Fri Feb 2 05:23:56 2001
-+++ Makefile Sat Feb 3 09:24:57 2001
++++ Makefile Mon Feb 12 18:44:56 2001
@@ -3,11 +3,11 @@
#If you do not have gcc, change the setting for COMPILER, but you must
#use an ANSI standard C compiler (NOT the old SunOS 4.1.3 cc
@@ -14,7 +14,7 @@
#If you don't have FreeType, libjpeg and/or Xpm installed, including the
#header files, uncomment this (default). You really must install
-@@ -16,8 +16,10 @@
+@@ -16,8 +16,14 @@
#If you do have FreeType, libjpeg and/or Xpm fully installed, uncomment a
#variation of this and comment out the line above. See also LIBS below.
@@ -24,10 +24,14 @@
+.if defined(WITH_X11)
+CFLAGS+=-DHAVE_LIBXPM
+.endif
++
++.if defined(JISX0208)
++CFLAGS+=-DJISX0208
++.endif
#To use the old FreeType 1.x library, add this additional #define
#to the line above
-@@ -30,13 +32,15 @@
+@@ -30,13 +36,15 @@
#Some systems are very picky about link order. They don't all agree
#on the right order, either.
@@ -45,7 +49,7 @@
#Note: for Freetype 1.x, use DHAVE_LIBTTF and -lttf instead.
-@@ -45,7 +49,10 @@
+@@ -45,7 +53,10 @@
#ensure that the version of gd you are installing is used, and not an
#older release in your directory tree somewhere.
@@ -57,7 +61,7 @@
#Typical install locations for freetype, zlib, xpm and libpng libraries.
#If yours are somewhere else, other than a standard location
-@@ -55,16 +62,19 @@
+@@ -55,16 +66,19 @@
#on your system can't cause conflicts while building a new one.
#This line shouldn't hurt if you don't actually have some of the
#optional libraries and directories.
@@ -81,7 +85,7 @@
#
#
-@@ -74,34 +84,44 @@
+@@ -74,34 +88,44 @@
VERSION=1.8.4
@@ -147,7 +151,7 @@
gddemo: gddemo.o libgd.a
$(CC) gddemo.o -o gddemo $(LIBDIRS) $(LIBS)
-@@ -138,18 +158,21 @@
+@@ -138,18 +162,21 @@
gdtestttf: gdtestttf.o libgd.a
$(CC) --verbose gdtestttf.o -o gdtestttf $(LIBDIRS) $(LIBS)
diff --git a/graphics/gd1/Makefile b/graphics/gd1/Makefile
index 8dfda987f477..6b00fe5be149 100644
--- a/graphics/gd1/Makefile
+++ b/graphics/gd1/Makefile
@@ -7,13 +7,13 @@
PORTNAME= gd
PORTVERSION= 1.8.4
-CATEGORIES= graphics
+CATEGORIES+= graphics
MASTER_SITES= http://www.boutell.com/gd/http/ \
ftp://ftp.boutell.com/pub/boutell/gd/ \
${MASTER_SITE_RINGSERVER}
MASTER_SITE_SUBDIR= graphics/gd
-MAINTAINER= billf@FreeBSD.org
+MAINTAINER?= billf@FreeBSD.org
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
diff --git a/graphics/gd1/files/patch-ac b/graphics/gd1/files/patch-ac
index c85d793c55c7..645f72cfa48b 100644
--- a/graphics/gd1/files/patch-ac
+++ b/graphics/gd1/files/patch-ac
@@ -1,5 +1,5 @@
--- Makefile.orig Fri Feb 2 05:23:56 2001
-+++ Makefile Sat Feb 3 09:24:57 2001
++++ Makefile Mon Feb 12 18:44:56 2001
@@ -3,11 +3,11 @@
#If you do not have gcc, change the setting for COMPILER, but you must
#use an ANSI standard C compiler (NOT the old SunOS 4.1.3 cc
@@ -14,7 +14,7 @@
#If you don't have FreeType, libjpeg and/or Xpm installed, including the
#header files, uncomment this (default). You really must install
-@@ -16,8 +16,10 @@
+@@ -16,8 +16,14 @@
#If you do have FreeType, libjpeg and/or Xpm fully installed, uncomment a
#variation of this and comment out the line above. See also LIBS below.
@@ -24,10 +24,14 @@
+.if defined(WITH_X11)
+CFLAGS+=-DHAVE_LIBXPM
+.endif
++
++.if defined(JISX0208)
++CFLAGS+=-DJISX0208
++.endif
#To use the old FreeType 1.x library, add this additional #define
#to the line above
-@@ -30,13 +32,15 @@
+@@ -30,13 +36,15 @@
#Some systems are very picky about link order. They don't all agree
#on the right order, either.
@@ -45,7 +49,7 @@
#Note: for Freetype 1.x, use DHAVE_LIBTTF and -lttf instead.
-@@ -45,7 +49,10 @@
+@@ -45,7 +53,10 @@
#ensure that the version of gd you are installing is used, and not an
#older release in your directory tree somewhere.
@@ -57,7 +61,7 @@
#Typical install locations for freetype, zlib, xpm and libpng libraries.
#If yours are somewhere else, other than a standard location
-@@ -55,16 +62,19 @@
+@@ -55,16 +66,19 @@
#on your system can't cause conflicts while building a new one.
#This line shouldn't hurt if you don't actually have some of the
#optional libraries and directories.
@@ -81,7 +85,7 @@
#
#
-@@ -74,34 +84,44 @@
+@@ -74,34 +88,44 @@
VERSION=1.8.4
@@ -147,7 +151,7 @@
gddemo: gddemo.o libgd.a
$(CC) gddemo.o -o gddemo $(LIBDIRS) $(LIBS)
-@@ -138,18 +158,21 @@
+@@ -138,18 +162,21 @@
gdtestttf: gdtestttf.o libgd.a
$(CC) --verbose gdtestttf.o -o gdtestttf $(LIBDIRS) $(LIBS)
diff --git a/graphics/gd2/Makefile b/graphics/gd2/Makefile
index 8dfda987f477..6b00fe5be149 100644
--- a/graphics/gd2/Makefile
+++ b/graphics/gd2/Makefile
@@ -7,13 +7,13 @@
PORTNAME= gd
PORTVERSION= 1.8.4
-CATEGORIES= graphics
+CATEGORIES+= graphics
MASTER_SITES= http://www.boutell.com/gd/http/ \
ftp://ftp.boutell.com/pub/boutell/gd/ \
${MASTER_SITE_RINGSERVER}
MASTER_SITE_SUBDIR= graphics/gd
-MAINTAINER= billf@FreeBSD.org
+MAINTAINER?= billf@FreeBSD.org
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
diff --git a/graphics/gd2/files/patch-ac b/graphics/gd2/files/patch-ac
index c85d793c55c7..645f72cfa48b 100644
--- a/graphics/gd2/files/patch-ac
+++ b/graphics/gd2/files/patch-ac
@@ -1,5 +1,5 @@
--- Makefile.orig Fri Feb 2 05:23:56 2001
-+++ Makefile Sat Feb 3 09:24:57 2001
++++ Makefile Mon Feb 12 18:44:56 2001
@@ -3,11 +3,11 @@
#If you do not have gcc, change the setting for COMPILER, but you must
#use an ANSI standard C compiler (NOT the old SunOS 4.1.3 cc
@@ -14,7 +14,7 @@
#If you don't have FreeType, libjpeg and/or Xpm installed, including the
#header files, uncomment this (default). You really must install
-@@ -16,8 +16,10 @@
+@@ -16,8 +16,14 @@
#If you do have FreeType, libjpeg and/or Xpm fully installed, uncomment a
#variation of this and comment out the line above. See also LIBS below.
@@ -24,10 +24,14 @@
+.if defined(WITH_X11)
+CFLAGS+=-DHAVE_LIBXPM
+.endif
++
++.if defined(JISX0208)
++CFLAGS+=-DJISX0208
++.endif
#To use the old FreeType 1.x library, add this additional #define
#to the line above
-@@ -30,13 +32,15 @@
+@@ -30,13 +36,15 @@
#Some systems are very picky about link order. They don't all agree
#on the right order, either.
@@ -45,7 +49,7 @@
#Note: for Freetype 1.x, use DHAVE_LIBTTF and -lttf instead.
-@@ -45,7 +49,10 @@
+@@ -45,7 +53,10 @@
#ensure that the version of gd you are installing is used, and not an
#older release in your directory tree somewhere.
@@ -57,7 +61,7 @@
#Typical install locations for freetype, zlib, xpm and libpng libraries.
#If yours are somewhere else, other than a standard location
-@@ -55,16 +62,19 @@
+@@ -55,16 +66,19 @@
#on your system can't cause conflicts while building a new one.
#This line shouldn't hurt if you don't actually have some of the
#optional libraries and directories.
@@ -81,7 +85,7 @@
#
#
-@@ -74,34 +84,44 @@
+@@ -74,34 +88,44 @@
VERSION=1.8.4
@@ -147,7 +151,7 @@
gddemo: gddemo.o libgd.a
$(CC) gddemo.o -o gddemo $(LIBDIRS) $(LIBS)
-@@ -138,18 +158,21 @@
+@@ -138,18 +162,21 @@
gdtestttf: gdtestttf.o libgd.a
$(CC) --verbose gdtestttf.o -o gdtestttf $(LIBDIRS) $(LIBS)
diff --git a/japanese/gd/Makefile b/japanese/gd/Makefile
index b4ba246e5287..bb2fafec2fd0 100644
--- a/japanese/gd/Makefile
+++ b/japanese/gd/Makefile
@@ -5,29 +5,12 @@
# $FreeBSD$
#
-PORTNAME= gd
-PORTVERSION= 1.6.3
-CATEGORIES= japanese graphics
-MASTER_SITES= http://www.boutell.com/gd/http/ \
- ftp://ftp.boutell.com/pub/boutell/gd/
-
-PATCH_SITES= ftp://ftp.ipc.chiba-u.ac.jp/pub/pub.yamaga/gd/${PORTVERSION}/
-PATCHFILES= ${DISTNAME}.ttf-kanji.patch.990731
+CATEGORIES= japanese
MAINTAINER= ichiro@ichiro.org
-LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png
-
-FETCH_BEFORE_ARGS= -b
-USE_LIBTOOL= yes
-CFLAGS+= -DJISX0208
-CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include"
-CONFIGURE_ARGS+= --includedir=${PREFIX}/include/gd \
- --libdir=${PREFIX}/lib
-INSTALLS_SHLIB= yes
+MASTERDIR= ${.CURDIR}/../../graphics/gd
-pre-install:
- ${MKDIR} ${PREFIX}/include/gd
- ${MKDIR} ${PREFIX}/share/examples/gd
+MAKE_ARGS= -DJISX0208
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"
diff --git a/japanese/gd/distinfo b/japanese/gd/distinfo
deleted file mode 100644
index 540fbc4d5034..000000000000
--- a/japanese/gd/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (gd-1.6.3.tar.gz) = 519bfbb55e3b315dd3d5a37ab56c2d84
-MD5 (gd-1.6.3.ttf-kanji.patch.990731) = 4031e7c027f3d2ba418c6620f60428e2
diff --git a/japanese/gd/files/patch-ab b/japanese/gd/files/patch-ab
deleted file mode 100644
index 6c11a95d5c9b..000000000000
--- a/japanese/gd/files/patch-ab
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.in.orig Mon Aug 30 00:23:49 1999
-+++ Makefile.in Mon Aug 30 00:24:49 1999
-@@ -88,7 +88,7 @@
- libgd_la_SOURCES = gd.c gd_io.c gd_io_file.c gd_io_dp.c gd_io_ss.c gd_png.c gd_ss.c gd_gd.c gd_gd2.c gdfontt.c gdfonts.c gdfontmb.c gdfontl.c gdfontg.c gdttf.c gdcache.c gdkanji.c gd.h gdcache.h gdfontl.h gdfonts.h gd_io.h gdfontg.h gdfontmb.h gdfontt.h jisx0208.h
-
-
--libgd_la_LIBADD = @LIBS@
-+libgd_la_LIBADD = @LIBS@ -lm -L$(libdir) -lpng
-
- bin_PROGRAMS = pngtogd pngtogd2 gdtopng gd2topng gd2copypal gdparttopng webpng
-
-@@ -136,7 +136,7 @@
- LTLIBRARIES = $(lib_LTLIBRARIES)
-
-
--DEFS = @DEFS@ -I. -I$(srcdir)
-+DEFS = @DEFS@ -I. -I$(srcdir) -I$(includedir)
- CPPFLAGS = @CPPFLAGS@
- LDFLAGS = @LDFLAGS@
- LIBS = @LIBS@
diff --git a/japanese/gd/pkg-comment b/japanese/gd/pkg-comment
deleted file mode 100644
index c3e4e57602ef..000000000000
--- a/japanese/gd/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-A graphics library for fast GIF creation
diff --git a/japanese/gd/pkg-descr b/japanese/gd/pkg-descr
deleted file mode 100644
index c3898fc02fa1..000000000000
--- a/japanese/gd/pkg-descr
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION
-
- gd is a graphics library. It allows your code to quickly draw images
- complete with lines, arcs, text, multiple colors, cut and paste from
- other images, and flood fills, and write out the result as a .GIF file.
- This is particularly useful in World Wide Web applications, where .GIF
- is the format used for inline images.
-
- gd is not a paint program. If you are looking for a paint program, try
- xpaint by David Koblas, available by anonymous FTP from ftp.netcom.com
- in pub/ko/koblas. (That package is for the X Window System; for the Mac
- and the PC, paint programs are considerably easier to find.)
-
- gd does not provide for every possible desirable graphics operation. It
- is not necessary or desirable for gd to become a kitchen-sink graphics
- package, but version 1.3 incorporates most of the commonly requested
- features for an 8-bit 2D package. Support for scalable fonts, and
- truecolor images, JPEG and PNG is planned for version 2.0. Version 1.3
- was released to correct longstanding bugs and provide an LZW-free GIF
- compression routine.
-
-AUTHOR
- gd 1.2 was written by Thomas Boutell and is currently distributed by
- boutell.com, Inc.
diff --git a/japanese/gd/pkg-plist b/japanese/gd/pkg-plist
deleted file mode 100644
index 7805ecc07a44..000000000000
--- a/japanese/gd/pkg-plist
+++ /dev/null
@@ -1,19 +0,0 @@
-bin/pngtogd
-bin/pngtogd2
-bin/gdtopng
-bin/gd2topng
-bin/gd2copypal
-bin/gdparttopng
-bin/webpng
-include/gd/gd.h
-include/gd/gd_io.h
-include/gd/gdfontg.h
-include/gd/gdfontl.h
-include/gd/gdfontmb.h
-include/gd/gdfonts.h
-include/gd/gdfontt.h
-lib/libgd.a
-lib/libgd.so
-lib/libgd.so.0
-@dirrm include/gd
-@dirrm share/examples/gd
diff --git a/japanese/gd1/Makefile b/japanese/gd1/Makefile
index b4ba246e5287..bb2fafec2fd0 100644
--- a/japanese/gd1/Makefile
+++ b/japanese/gd1/Makefile
@@ -5,29 +5,12 @@
# $FreeBSD$
#
-PORTNAME= gd
-PORTVERSION= 1.6.3
-CATEGORIES= japanese graphics
-MASTER_SITES= http://www.boutell.com/gd/http/ \
- ftp://ftp.boutell.com/pub/boutell/gd/
-
-PATCH_SITES= ftp://ftp.ipc.chiba-u.ac.jp/pub/pub.yamaga/gd/${PORTVERSION}/
-PATCHFILES= ${DISTNAME}.ttf-kanji.patch.990731
+CATEGORIES= japanese
MAINTAINER= ichiro@ichiro.org
-LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png
-
-FETCH_BEFORE_ARGS= -b
-USE_LIBTOOL= yes
-CFLAGS+= -DJISX0208
-CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include"
-CONFIGURE_ARGS+= --includedir=${PREFIX}/include/gd \
- --libdir=${PREFIX}/lib
-INSTALLS_SHLIB= yes
+MASTERDIR= ${.CURDIR}/../../graphics/gd
-pre-install:
- ${MKDIR} ${PREFIX}/include/gd
- ${MKDIR} ${PREFIX}/share/examples/gd
+MAKE_ARGS= -DJISX0208
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"
diff --git a/japanese/gd1/distinfo b/japanese/gd1/distinfo
deleted file mode 100644
index 540fbc4d5034..000000000000
--- a/japanese/gd1/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (gd-1.6.3.tar.gz) = 519bfbb55e3b315dd3d5a37ab56c2d84
-MD5 (gd-1.6.3.ttf-kanji.patch.990731) = 4031e7c027f3d2ba418c6620f60428e2
diff --git a/japanese/gd1/files/patch-ab b/japanese/gd1/files/patch-ab
deleted file mode 100644
index 6c11a95d5c9b..000000000000
--- a/japanese/gd1/files/patch-ab
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.in.orig Mon Aug 30 00:23:49 1999
-+++ Makefile.in Mon Aug 30 00:24:49 1999
-@@ -88,7 +88,7 @@
- libgd_la_SOURCES = gd.c gd_io.c gd_io_file.c gd_io_dp.c gd_io_ss.c gd_png.c gd_ss.c gd_gd.c gd_gd2.c gdfontt.c gdfonts.c gdfontmb.c gdfontl.c gdfontg.c gdttf.c gdcache.c gdkanji.c gd.h gdcache.h gdfontl.h gdfonts.h gd_io.h gdfontg.h gdfontmb.h gdfontt.h jisx0208.h
-
-
--libgd_la_LIBADD = @LIBS@
-+libgd_la_LIBADD = @LIBS@ -lm -L$(libdir) -lpng
-
- bin_PROGRAMS = pngtogd pngtogd2 gdtopng gd2topng gd2copypal gdparttopng webpng
-
-@@ -136,7 +136,7 @@
- LTLIBRARIES = $(lib_LTLIBRARIES)
-
-
--DEFS = @DEFS@ -I. -I$(srcdir)
-+DEFS = @DEFS@ -I. -I$(srcdir) -I$(includedir)
- CPPFLAGS = @CPPFLAGS@
- LDFLAGS = @LDFLAGS@
- LIBS = @LIBS@
diff --git a/japanese/gd1/pkg-comment b/japanese/gd1/pkg-comment
deleted file mode 100644
index c3e4e57602ef..000000000000
--- a/japanese/gd1/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-A graphics library for fast GIF creation
diff --git a/japanese/gd1/pkg-descr b/japanese/gd1/pkg-descr
deleted file mode 100644
index c3898fc02fa1..000000000000
--- a/japanese/gd1/pkg-descr
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION
-
- gd is a graphics library. It allows your code to quickly draw images
- complete with lines, arcs, text, multiple colors, cut and paste from
- other images, and flood fills, and write out the result as a .GIF file.
- This is particularly useful in World Wide Web applications, where .GIF
- is the format used for inline images.
-
- gd is not a paint program. If you are looking for a paint program, try
- xpaint by David Koblas, available by anonymous FTP from ftp.netcom.com
- in pub/ko/koblas. (That package is for the X Window System; for the Mac
- and the PC, paint programs are considerably easier to find.)
-
- gd does not provide for every possible desirable graphics operation. It
- is not necessary or desirable for gd to become a kitchen-sink graphics
- package, but version 1.3 incorporates most of the commonly requested
- features for an 8-bit 2D package. Support for scalable fonts, and
- truecolor images, JPEG and PNG is planned for version 2.0. Version 1.3
- was released to correct longstanding bugs and provide an LZW-free GIF
- compression routine.
-
-AUTHOR
- gd 1.2 was written by Thomas Boutell and is currently distributed by
- boutell.com, Inc.
diff --git a/japanese/gd1/pkg-plist b/japanese/gd1/pkg-plist
deleted file mode 100644
index 7805ecc07a44..000000000000
--- a/japanese/gd1/pkg-plist
+++ /dev/null
@@ -1,19 +0,0 @@
-bin/pngtogd
-bin/pngtogd2
-bin/gdtopng
-bin/gd2topng
-bin/gd2copypal
-bin/gdparttopng
-bin/webpng
-include/gd/gd.h
-include/gd/gd_io.h
-include/gd/gdfontg.h
-include/gd/gdfontl.h
-include/gd/gdfontmb.h
-include/gd/gdfonts.h
-include/gd/gdfontt.h
-lib/libgd.a
-lib/libgd.so
-lib/libgd.so.0
-@dirrm include/gd
-@dirrm share/examples/gd