summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/fpc-libpng/Makefile19
2 files changed, 20 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index df9eaedd7847..75bfc796ccbe 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -129,6 +129,7 @@
SUBDIR += fpc-gtk2
SUBDIR += fpc-imlib
SUBDIR += fpc-libgd
+ SUBDIR += fpc-libpng
SUBDIR += fracplanet
SUBDIR += fractorama
SUBDIR += fraqtive
diff --git a/graphics/fpc-libpng/Makefile b/graphics/fpc-libpng/Makefile
new file mode 100644
index 000000000000..69190920684a
--- /dev/null
+++ b/graphics/fpc-libpng/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: fpc-libpng
+# Date created: 2006-06-05
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= graphics lang
+PKGNAMESUFFIX= -libpng
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Free Pascal interface to libpng, for reading PNG image files
+
+RUN_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+
+.include "${MASTERDIR}/Makefile"