summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/linux-quake4/Makefile115
-rw-r--r--games/linux-quake4/distinfo2
-rw-r--r--games/linux-quake4/files/run.sh.in4
-rw-r--r--games/linux-quake4/pkg-descr6
-rw-r--r--games/linux-quake4/pkg-message11
-rw-r--r--games/linux-quake4/pkg-plist395
7 files changed, 534 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index ab24c676d75e..27e71a3a1eda 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -331,6 +331,7 @@
SUBDIR += linux-nwnclient
SUBDIR += linux-nwserver
SUBDIR += linux-quake3-demo
+ SUBDIR += linux-quake4
SUBDIR += linux-spheresofchaos-demo
SUBDIR += linux-steam
SUBDIR += linux-ut2003-demo
diff --git a/games/linux-quake4/Makefile b/games/linux-quake4/Makefile
new file mode 100644
index 000000000000..6132746fd864
--- /dev/null
+++ b/games/linux-quake4/Makefile
@@ -0,0 +1,115 @@
+# New ports collection makefile for: Quake 4
+# Date created: 21 Oct 2005
+# Whom: Ed Schouten <ed@fxq.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= quake4
+PORTVERSION= 1.0.2147.12
+CATEGORIES= games linux
+MASTER_SITES= ftp://ftp.idsoftware.com/idstuff/quake4/linux/old/
+PKGNAMEPREFIX= linux-
+DISTNAME= ${PORTNAME}-linux-${PORTVERSION}.x86
+EXTRACT_SUFX= .run
+
+MAINTAINER= ed@fxq.nl
+COMMENT= Quake 4 for Linux
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
+
+ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+
+NO_WRKSUBDIR= yes
+
+Q4DIR= lib/${PORTNAME}/
+PLIST_SUB+= Q4DIR="${Q4DIR}"
+
+do-extract:
+ @${RM} -rf ${WRKDIR}
+ @${MKDIR} ${WRKDIR}
+ @cd ${WRKDIR} && ${TAIL} +376 ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX} | \
+ ${TAR} zxf -
+
+do-build:
+.for i in quake4 q4ded
+ ${BRANDELF} -t Linux ${WRKSRC}/bin/FreeBSD/x86/$i.x86
+
+ # Startup scripts
+ @${SED} \
+ -e 's|@Q4DIR@|${PREFIX}/${Q4DIR}|' \
+ -e 's|@APP@|$i.x86|' \
+ ${FILESDIR}/run.sh.in > ${WRKSRC}/$i.sh
+.endfor
+
+do-install:
+ # Executables
+ @${MKDIR} ${PREFIX}/${Q4DIR}
+.for i in quake4 q4ded
+ ${INSTALL_SCRIPT} ${WRKSRC}/$i.sh ${PREFIX}/bin/$i
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/FreeBSD/x86/$i.x86 ${PREFIX}/${Q4DIR}/
+.endfor
+
+ # Punkbuster
+ @${MKDIR} ${PREFIX}/${Q4DIR}/pb/htm
+.for i in ag ags cl cls sv
+ ${INSTALL_DATA} ${WRKSRC}/pb/pb$i.so ${PREFIX}/${Q4DIR}/pb/
+.endfor
+.for i in l m w
+ ${INSTALL_DATA} ${WRKSRC}/pb/htm/$ia001307.htm ${PREFIX}/${Q4DIR}/pb/htm/
+ ${INSTALL_DATA} ${WRKSRC}/pb/htm/$ic001095.htm ${PREFIX}/${Q4DIR}/pb/htm/
+.endfor
+
+ # Q4base
+ @${MKDIR} ${PREFIX}/${Q4DIR}/q4base
+.for i in \
+ arena_ctf.cfg ctf.cfg dm.cfg game100.pk4 \
+ mapcycle.scriptcfg teamdm.cfg tourney.cfg
+
+ ${INSTALL_DATA} ${WRKSRC}/q4base/$i ${PREFIX}/${Q4DIR}/q4base/
+.endfor
+
+ # Documentation
+.if !defined (NOPORTDOCS)
+. for i in ENG ENU ESP FRA ITA
+ @${MKDIR} ${DOCSDIR}/$i/images
+ @${MKDIR} ${DOCSDIR}/$i/htm
+
+. for j in \
+ License.txt MSR.txt PBEULA.txt help.htm htm/Default.htm \
+ htm/credits.htm htm/cs.htm htm/left.htm htm/man_def.htm \
+ htm/man_left.htm htm/man_top.htm htm/readme.htm \
+ htm/side_ie.css htm/style_ie.css htm/techhelp.htm htm/top.htm \
+ images/ATVIsmall.gif images/ATVIsmaller.jpg \
+ images/Bink_Video_4c_rev.png images/ammo_regen.png \
+ images/armor.png images/blaster.png images/doubler.png \
+ images/guard.png images/h01.gif images/h02.gif images/h03.gif \
+ images/h04.gif images/h05.gif images/h06.gif images/h07.gif \
+ images/h08.gif images/h09.gif images/h10.gif images/h17a.gif \
+ images/h17b.gif images/h26.gif images/h27.gif images/h28a.gif \
+ images/h28b.gif images/h28c.gif images/h_def.gif \
+ images/h_sup.gif images/h_tec.gif images/h_top.gif \
+ images/haste.png images/health.png images/health_pack.png \
+ images/id_logo_small.jpg images/ingamedisplay.png \
+ images/invisibility.png images/line1.gif images/line1_b.gif \
+ images/line2.gif images/line2_b.gif images/machinegun.png \
+ images/mega_health.png images/mpbrowser.png images/mssLogo.png \
+ images/pad.gif images/q4_logo_small.jpg images/quad_damage.png \
+ images/raven.gif images/regeneration.png images/save.png \
+ images/scout.png images/shotgun.png images/watermark.gif \
+ manual.htm readme.txt
+
+ ${INSTALL_DATA} ${WRKSRC}/Docs/$i/$j ${DOCSDIR}/$i/$j
+. endfor
+. endfor
+
+ ${INSTALL_DATA} ${WRKSRC}/License.txt ${DOCSDIR}/LICENSE
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
+ ${INSTALL_DATA} ${WRKSRC}/pb/PBEULA.txt ${DOCSDIR}/PBEULA
+.endif
+
+post-install:
+ @${SED} 's|@DOCSDIR@|${DOCSDIR}|' ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/games/linux-quake4/distinfo b/games/linux-quake4/distinfo
new file mode 100644
index 000000000000..73a2b10f1b70
--- /dev/null
+++ b/games/linux-quake4/distinfo
@@ -0,0 +1,2 @@
+MD5 (quake4-linux-1.0.2147.12.x86.run) = 96ac1b993dafe5d255a7ee85d07187db
+SIZE (quake4-linux-1.0.2147.12.x86.run) = 19216927
diff --git a/games/linux-quake4/files/run.sh.in b/games/linux-quake4/files/run.sh.in
new file mode 100644
index 000000000000..64fd225b0e5f
--- /dev/null
+++ b/games/linux-quake4/files/run.sh.in
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd @Q4DIR@ || exit 1
+exec @Q4DIR@/@APP@ "$@"
diff --git a/games/linux-quake4/pkg-descr b/games/linux-quake4/pkg-descr
new file mode 100644
index 000000000000..80df2cecfcbf
--- /dev/null
+++ b/games/linux-quake4/pkg-descr
@@ -0,0 +1,6 @@
+This package contains Quake 4 for Linux by id Software.
+
+In order to play this game, you need to add the data files
+that are available on the Quake 4 CD's or DVD.
+
+WWW: http://www.quake4game.com/
diff --git a/games/linux-quake4/pkg-message b/games/linux-quake4/pkg-message
new file mode 100644
index 000000000000..6e3219bbd146
--- /dev/null
+++ b/games/linux-quake4/pkg-message
@@ -0,0 +1,11 @@
+------------------------------------------------------------
+
+In order to play Quake 4, you need to copy some data files
+from the Quake 4 DVD or CD's. Please read the following
+file:
+
+@DOCSDIR@/README
+
+Have fun!
+
+------------------------------------------------------------
diff --git a/games/linux-quake4/pkg-plist b/games/linux-quake4/pkg-plist
new file mode 100644
index 000000000000..c358e579b79f
--- /dev/null
+++ b/games/linux-quake4/pkg-plist
@@ -0,0 +1,395 @@
+bin/q4ded
+bin/quake4
+%%Q4DIR%%pb/htm/la001307.htm
+%%Q4DIR%%pb/htm/lc001095.htm
+%%Q4DIR%%pb/htm/ma001307.htm
+%%Q4DIR%%pb/htm/mc001095.htm
+%%Q4DIR%%pb/htm/wa001307.htm
+%%Q4DIR%%pb/htm/wc001095.htm
+%%Q4DIR%%pb/pbag.so
+%%Q4DIR%%pb/pbags.so
+%%Q4DIR%%pb/pbcl.so
+%%Q4DIR%%pb/pbcls.so
+%%Q4DIR%%pb/pbsv.so
+%%Q4DIR%%q4base/arena_ctf.cfg
+%%Q4DIR%%q4base/ctf.cfg
+%%Q4DIR%%q4base/dm.cfg
+%%Q4DIR%%q4base/game100.pk4
+%%Q4DIR%%q4base/mapcycle.scriptcfg
+%%Q4DIR%%q4base/teamdm.cfg
+%%Q4DIR%%q4base/tourney.cfg
+%%Q4DIR%%q4ded.x86
+%%Q4DIR%%quake4.x86
+%%PORTDOCS%%%%DOCSDIR%%/ENG/License.txt
+%%PORTDOCS%%%%DOCSDIR%%/ENG/MSR.txt
+%%PORTDOCS%%%%DOCSDIR%%/ENG/PBEULA.txt
+%%PORTDOCS%%%%DOCSDIR%%/ENG/help.htm
+%%PORTDOCS%%%%DOCSDIR%%/ENG/htm/Default.htm
+%%PORTDOCS%%%%DOCSDIR%%/ENG/htm/credits.htm
+%%PORTDOCS%%%%DOCSDIR%%/ENG/htm/cs.htm
+%%PORTDOCS%%%%DOCSDIR%%/ENG/htm/left.htm
+%%PORTDOCS%%%%DOCSDIR%%/ENG/htm/man_def.htm
+%%PORTDOCS%%%%DOCSDIR%%/ENG/htm/man_left.htm
+%%PORTDOCS%%%%DOCSDIR%%/ENG/htm/man_top.htm
+%%PORTDOCS%%%%DOCSDIR%%/ENG/htm/readme.htm
+%%PORTDOCS%%%%DOCSDIR%%/ENG/htm/side_ie.css
+%%PORTDOCS%%%%DOCSDIR%%/ENG/htm/style_ie.css
+%%PORTDOCS%%%%DOCSDIR%%/ENG/htm/techhelp.htm
+%%PORTDOCS%%%%DOCSDIR%%/ENG/htm/top.htm
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/ATVIsmall.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/ATVIsmaller.jpg
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/Bink_Video_4c_rev.png
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/ammo_regen.png
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/armor.png
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/blaster.png
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/doubler.png
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/guard.png
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/h01.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/h02.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/h03.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/h04.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/h05.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/h06.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/h07.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/h08.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/h09.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/h10.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/h17a.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/h17b.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/h26.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/h27.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/h28a.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/h28b.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/h28c.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/h_def.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/h_sup.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/h_tec.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/h_top.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/haste.png
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/health.png
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/health_pack.png
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/id_logo_small.jpg
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/ingamedisplay.png
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/invisibility.png
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/line1.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/line1_b.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/line2.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/line2_b.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/machinegun.png
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/mega_health.png
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/mpbrowser.png
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/mssLogo.png
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/pad.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/q4_logo_small.jpg
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/quad_damage.png
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/raven.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/regeneration.png
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/save.png
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/scout.png
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/shotgun.png
+%%PORTDOCS%%%%DOCSDIR%%/ENG/images/watermark.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENG/manual.htm
+%%PORTDOCS%%%%DOCSDIR%%/ENG/readme.txt
+%%PORTDOCS%%%%DOCSDIR%%/ENU/License.txt
+%%PORTDOCS%%%%DOCSDIR%%/ENU/MSR.txt
+%%PORTDOCS%%%%DOCSDIR%%/ENU/PBEULA.txt
+%%PORTDOCS%%%%DOCSDIR%%/ENU/help.htm
+%%PORTDOCS%%%%DOCSDIR%%/ENU/htm/Default.htm
+%%PORTDOCS%%%%DOCSDIR%%/ENU/htm/credits.htm
+%%PORTDOCS%%%%DOCSDIR%%/ENU/htm/cs.htm
+%%PORTDOCS%%%%DOCSDIR%%/ENU/htm/left.htm
+%%PORTDOCS%%%%DOCSDIR%%/ENU/htm/man_def.htm
+%%PORTDOCS%%%%DOCSDIR%%/ENU/htm/man_left.htm
+%%PORTDOCS%%%%DOCSDIR%%/ENU/htm/man_top.htm
+%%PORTDOCS%%%%DOCSDIR%%/ENU/htm/readme.htm
+%%PORTDOCS%%%%DOCSDIR%%/ENU/htm/side_ie.css
+%%PORTDOCS%%%%DOCSDIR%%/ENU/htm/style_ie.css
+%%PORTDOCS%%%%DOCSDIR%%/ENU/htm/techhelp.htm
+%%PORTDOCS%%%%DOCSDIR%%/ENU/htm/top.htm
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/ATVIsmall.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/ATVIsmaller.jpg
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/Bink_Video_4c_rev.png
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/ammo_regen.png
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/armor.png
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/blaster.png
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/doubler.png
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/guard.png
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/h01.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/h02.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/h03.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/h04.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/h05.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/h06.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/h07.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/h08.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/h09.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/h10.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/h17a.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/h17b.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/h26.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/h27.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/h28a.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/h28b.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/h28c.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/h_def.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/h_sup.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/h_tec.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/h_top.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/haste.png
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/health.png
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/health_pack.png
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/id_logo_small.jpg
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/ingamedisplay.png
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/invisibility.png
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/line1.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/line1_b.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/line2.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/line2_b.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/machinegun.png
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/mega_health.png
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/mpbrowser.png
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/mssLogo.png
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/pad.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/q4_logo_small.jpg
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/quad_damage.png
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/raven.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/regeneration.png
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/save.png
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/scout.png
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/shotgun.png
+%%PORTDOCS%%%%DOCSDIR%%/ENU/images/watermark.gif
+%%PORTDOCS%%%%DOCSDIR%%/ENU/manual.htm
+%%PORTDOCS%%%%DOCSDIR%%/ENU/readme.txt
+%%PORTDOCS%%%%DOCSDIR%%/ESP/License.txt
+%%PORTDOCS%%%%DOCSDIR%%/ESP/MSR.txt
+%%PORTDOCS%%%%DOCSDIR%%/ESP/PBEULA.txt
+%%PORTDOCS%%%%DOCSDIR%%/ESP/help.htm
+%%PORTDOCS%%%%DOCSDIR%%/ESP/htm/Default.htm
+%%PORTDOCS%%%%DOCSDIR%%/ESP/htm/credits.htm
+%%PORTDOCS%%%%DOCSDIR%%/ESP/htm/cs.htm
+%%PORTDOCS%%%%DOCSDIR%%/ESP/htm/left.htm
+%%PORTDOCS%%%%DOCSDIR%%/ESP/htm/man_def.htm
+%%PORTDOCS%%%%DOCSDIR%%/ESP/htm/man_left.htm
+%%PORTDOCS%%%%DOCSDIR%%/ESP/htm/man_top.htm
+%%PORTDOCS%%%%DOCSDIR%%/ESP/htm/readme.htm
+%%PORTDOCS%%%%DOCSDIR%%/ESP/htm/side_ie.css
+%%PORTDOCS%%%%DOCSDIR%%/ESP/htm/style_ie.css
+%%PORTDOCS%%%%DOCSDIR%%/ESP/htm/techhelp.htm
+%%PORTDOCS%%%%DOCSDIR%%/ESP/htm/top.htm
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/ATVIsmall.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/ATVIsmaller.jpg
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/Bink_Video_4c_rev.png
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/ammo_regen.png
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/armor.png
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/blaster.png
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/doubler.png
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/guard.png
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/h01.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/h02.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/h03.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/h04.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/h05.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/h06.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/h07.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/h08.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/h09.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/h10.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/h17a.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/h17b.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/h26.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/h27.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/h28a.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/h28b.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/h28c.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/h_def.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/h_sup.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/h_tec.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/h_top.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/haste.png
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/health.png
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/health_pack.png
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/id_logo_small.jpg
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/ingamedisplay.png
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/invisibility.png
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/line1.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/line1_b.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/line2.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/line2_b.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/machinegun.png
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/mega_health.png
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/mpbrowser.png
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/mssLogo.png
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/pad.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/q4_logo_small.jpg
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/quad_damage.png
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/raven.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/regeneration.png
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/save.png
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/scout.png
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/shotgun.png
+%%PORTDOCS%%%%DOCSDIR%%/ESP/images/watermark.gif
+%%PORTDOCS%%%%DOCSDIR%%/ESP/manual.htm
+%%PORTDOCS%%%%DOCSDIR%%/ESP/readme.txt
+%%PORTDOCS%%%%DOCSDIR%%/FRA/License.txt
+%%PORTDOCS%%%%DOCSDIR%%/FRA/MSR.txt
+%%PORTDOCS%%%%DOCSDIR%%/FRA/PBEULA.txt
+%%PORTDOCS%%%%DOCSDIR%%/FRA/help.htm
+%%PORTDOCS%%%%DOCSDIR%%/FRA/htm/Default.htm
+%%PORTDOCS%%%%DOCSDIR%%/FRA/htm/credits.htm
+%%PORTDOCS%%%%DOCSDIR%%/FRA/htm/cs.htm
+%%PORTDOCS%%%%DOCSDIR%%/FRA/htm/left.htm
+%%PORTDOCS%%%%DOCSDIR%%/FRA/htm/man_def.htm
+%%PORTDOCS%%%%DOCSDIR%%/FRA/htm/man_left.htm
+%%PORTDOCS%%%%DOCSDIR%%/FRA/htm/man_top.htm
+%%PORTDOCS%%%%DOCSDIR%%/FRA/htm/readme.htm
+%%PORTDOCS%%%%DOCSDIR%%/FRA/htm/side_ie.css
+%%PORTDOCS%%%%DOCSDIR%%/FRA/htm/style_ie.css
+%%PORTDOCS%%%%DOCSDIR%%/FRA/htm/techhelp.htm
+%%PORTDOCS%%%%DOCSDIR%%/FRA/htm/top.htm
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/ATVIsmall.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/ATVIsmaller.jpg
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/Bink_Video_4c_rev.png
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/ammo_regen.png
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/armor.png
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/blaster.png
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/doubler.png
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/guard.png
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/h01.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/h02.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/h03.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/h04.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/h05.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/h06.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/h07.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/h08.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/h09.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/h10.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/h17a.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/h17b.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/h26.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/h27.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/h28a.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/h28b.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/h28c.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/h_def.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/h_sup.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/h_tec.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/h_top.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/haste.png
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/health.png
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/health_pack.png
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/id_logo_small.jpg
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/ingamedisplay.png
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/invisibility.png
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/line1.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/line1_b.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/line2.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/line2_b.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/machinegun.png
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/mega_health.png
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/mpbrowser.png
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/mssLogo.png
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/pad.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/q4_logo_small.jpg
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/quad_damage.png
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/raven.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/regeneration.png
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/save.png
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/scout.png
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/shotgun.png
+%%PORTDOCS%%%%DOCSDIR%%/FRA/images/watermark.gif
+%%PORTDOCS%%%%DOCSDIR%%/FRA/manual.htm
+%%PORTDOCS%%%%DOCSDIR%%/FRA/readme.txt
+%%PORTDOCS%%%%DOCSDIR%%/ITA/License.txt
+%%PORTDOCS%%%%DOCSDIR%%/ITA/MSR.txt
+%%PORTDOCS%%%%DOCSDIR%%/ITA/PBEULA.txt
+%%PORTDOCS%%%%DOCSDIR%%/ITA/help.htm
+%%PORTDOCS%%%%DOCSDIR%%/ITA/htm/Default.htm
+%%PORTDOCS%%%%DOCSDIR%%/ITA/htm/credits.htm
+%%PORTDOCS%%%%DOCSDIR%%/ITA/htm/cs.htm
+%%PORTDOCS%%%%DOCSDIR%%/ITA/htm/left.htm
+%%PORTDOCS%%%%DOCSDIR%%/ITA/htm/man_def.htm
+%%PORTDOCS%%%%DOCSDIR%%/ITA/htm/man_left.htm
+%%PORTDOCS%%%%DOCSDIR%%/ITA/htm/man_top.htm
+%%PORTDOCS%%%%DOCSDIR%%/ITA/htm/readme.htm
+%%PORTDOCS%%%%DOCSDIR%%/ITA/htm/side_ie.css
+%%PORTDOCS%%%%DOCSDIR%%/ITA/htm/style_ie.css
+%%PORTDOCS%%%%DOCSDIR%%/ITA/htm/techhelp.htm
+%%PORTDOCS%%%%DOCSDIR%%/ITA/htm/top.htm
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/ATVIsmall.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/ATVIsmaller.jpg
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/Bink_Video_4c_rev.png
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/ammo_regen.png
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/armor.png
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/blaster.png
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/doubler.png
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/guard.png
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/h01.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/h02.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/h03.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/h04.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/h05.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/h06.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/h07.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/h08.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/h09.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/h10.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/h17a.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/h17b.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/h26.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/h27.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/h28a.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/h28b.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/h28c.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/h_def.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/h_sup.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/h_tec.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/h_top.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/haste.png
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/health.png
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/health_pack.png
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/id_logo_small.jpg
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/ingamedisplay.png
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/invisibility.png
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/line1.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/line1_b.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/line2.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/line2_b.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/machinegun.png
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/mega_health.png
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/mpbrowser.png
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/mssLogo.png
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/pad.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/q4_logo_small.jpg
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/quad_damage.png
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/raven.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/regeneration.png
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/save.png
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/scout.png
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/shotgun.png
+%%PORTDOCS%%%%DOCSDIR%%/ITA/images/watermark.gif
+%%PORTDOCS%%%%DOCSDIR%%/ITA/manual.htm
+%%PORTDOCS%%%%DOCSDIR%%/ITA/readme.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/PBEULA
+%%PORTDOCS%%%%DOCSDIR%%/README
+@dirrm %%Q4DIR%%pb/htm
+@dirrm %%Q4DIR%%pb
+@dirrm %%Q4DIR%%q4base
+@dirrm %%Q4DIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/ENG/htm
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/ENG/images
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/ENG
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/ENU/htm
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/ENU/images
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/ENU
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/ESP/htm
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/ESP/images
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/ESP
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/FRA/htm
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/FRA/images
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/FRA
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/ITA/htm
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/ITA/images
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/ITA
+%%PORTDOCS%%@dirrm %%DOCSDIR%%