summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/lighttpd/Makefile2
-rw-r--r--www/lighttpd/files/patch-src__network.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 1ade21e63df9..d93c17a816f0 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= lighttpd
PORTVERSION= 1.4.26
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= http://download.lighttpd.net/lighttpd/releases-1.4.x/
diff --git a/www/lighttpd/files/patch-src__network.c b/www/lighttpd/files/patch-src__network.c
new file mode 100644
index 000000000000..996d8002a9aa
--- /dev/null
+++ b/www/lighttpd/files/patch-src__network.c
@@ -0,0 +1,11 @@
+--- src/network.c 2010-01-28 10:43:33.829209750 -0500
++++ src/network.c 2010-01-28 10:44:22.639208732 -0500
+@@ -525,7 +525,7 @@ int network_init(server *srv) {
+
+ if (!s->ssl_use_sslv2) {
+ /* disable SSLv2 */
+- if (SSL_OP_NO_SSLv2 != SSL_CTX_set_options(s->ssl_ctx, SSL_OP_NO_SSLv2)) {
++ if (!(SSL_OP_NO_SSLv2 & SSL_CTX_set_options(s->ssl_ctx, SSL_OP_NO_SSLv2))) {
+ log_error_write(srv, __FILE__, __LINE__, "ss", "SSL:",
+ ERR_error_string(ERR_get_error(), NULL));
+ return -1;