summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/ghc/Makefile5
-rw-r--r--security/drweb/Makefile3
2 files changed, 7 insertions, 1 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 0c5c68b08ee8..d9c45226fe40 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -31,10 +31,13 @@ DISTFILES= ${SRC_DIST}
DISTFILES+= ${BOOT_DIST}
.else
DISTFILES+= ${BOOT_DIST5}
+.if ${OSVERSION} >= 600000
+LIB_DEPENDS+= c.5:${PORTSDIR}/misc/compat5x
+.endif
.endif
WANT_AUTOCONF_VER=259 # Need this to regenerate patched configure in GLUT
-LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4 \
+LIB_DEPENDS+= gmp.6:${PORTSDIR}/math/libgmp4 \
glut.3:${PORTSDIR}/graphics/libglut \
openal.0:${PORTSDIR}/audio/openal
diff --git a/security/drweb/Makefile b/security/drweb/Makefile
index 2e9e8782b58f..c5eb54ab51c2 100644
--- a/security/drweb/Makefile
+++ b/security/drweb/Makefile
@@ -26,6 +26,9 @@ RUN_DEPENDS= ${LOCALBASE}/bin/wget:${PORTSDIR}/ftp/wget
DISTNAME= ${PORTNAME}-${PORTVERSION}-freebsd49
.else
DISTNAME= ${PORTNAME}-${PORTVERSION}-freebsd53
+.if ${OSVERSION} >= 600000
+LIB_DEPENDS+= c.5:${PORTSDIR}/misc/compat5x
+.endif
.endif
WRKSRC= ${WRKDIR}/${DISTNAME}