summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/tcpview/Makefile4
-rw-r--r--net/tcpview/files/patch-print_null.c20
2 files changed, 20 insertions, 4 deletions
diff --git a/net/tcpview/Makefile b/net/tcpview/Makefile
index 804bb8985872..884349416d16 100644
--- a/net/tcpview/Makefile
+++ b/net/tcpview/Makefile
@@ -22,10 +22,6 @@ MAN1= tcpview.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
post-patch:
.for f in nametoaddr.c addrtoname.c print-nfs.c detail-tcp.c tv_addrtoname.c
@${REINPLACE_CMD} -e 's/NTOHL/ntohl/ ; s/NTOHS/ntohs/' ${WRKSRC}/${f}
diff --git a/net/tcpview/files/patch-print_null.c b/net/tcpview/files/patch-print_null.c
new file mode 100644
index 000000000000..e9d2943a3750
--- /dev/null
+++ b/net/tcpview/files/patch-print_null.c
@@ -0,0 +1,20 @@
+--- print-null.c.orig Mon May 12 17:35:00 2003
++++ print-null.c Mon May 12 17:36:30 2003
+@@ -76,9 +76,17 @@
+ printf("ip: ");
+ break;
+
++#ifdef AF_NS
+ case AF_NS:
+ printf("ns: ");
+ break;
++#endif /* AF_NS */
++#ifdef AF_NETBIOS
++ case AF_NETBIOS:
++ printf("netbios: ");
++ break;
++#endif /* AF_NETBIOS */
++
+
+ default:
+ printf("AF %d: ", family);