summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--shells/zsh/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index ce02520d52a5..e6162f1e4788 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -26,6 +26,17 @@ PLIST_SUB= ZSH_VERSION=${DISTNAME:S/zsh-//}
# If you want to build a static binary, uncomment the following line
#CONFIGURE_ENV+= "LDFLAGS=-static"
+post-build:
+# Fix ".so" macro problem by using "soelim" command.
+ @(cd ${WRKSRC} ; \
+ ${LN} -sf ./Doc man1 ; \
+ if [ ! -f ./man1/zshall.1.source ]; then \
+ ${MV} -f ./man1/zshall.1 ./man1/zshall.1.source ; \
+ fi ; \
+ ${RM} -f ./man1/zshall.1 ; \
+ /usr/bin/soelim ./man1/zshall.1.source > ./man1/zshall.1 ; \
+ )
+
post-install:
@install-info ${PREFIX}/info/zsh.info ${PREFIX}/info/dir
@${ECHO} "Updating /etc/shells"