summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/frodo/Makefile5
-rw-r--r--emulators/frodo/files/patch-C64_x.i2
-rw-r--r--emulators/frodo/files/patch-TkGui.tcl2
-rw-r--r--irc/zircon/Makefile2
-rw-r--r--irc/zircon/files/patch-aa2
5 files changed, 7 insertions, 6 deletions
diff --git a/emulators/frodo/Makefile b/emulators/frodo/Makefile
index f169e46d57f2..82044e6b552c 100644
--- a/emulators/frodo/Makefile
+++ b/emulators/frodo/Makefile
@@ -7,6 +7,7 @@
PORTNAME= frodo
PORTVERSION= 4.1a
+PORTREVISION= 1
CATEGORIES= emulators tk83
MASTER_SITES= ftp://metalab.unc.edu/pub/micro/commodore/crossplatform/emulators/Frodo/ \
ftp://ftp.funet.fi/pub/cbm/crossplatform/emulators/Frodo/
@@ -15,7 +16,7 @@ DISTNAME= FrodoV4_1a.Src
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Emulates a Commodore 64
-RUN_DEPENDS= wish8.3:${PORTSDIR}/x11-toolkits/tk83
+RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
USE_X_PREFIX= yes
ALL_TARGET= Frodo
@@ -41,7 +42,7 @@ do-install:
${INSTALL_DATA} "${WRKDIR}/Frodo/${i} ROM" ${PREFIX}/libexec/frodo
.endfor
${INSTALL_DATA} "${WRKDIR}/Frodo/Frodo Logo" ${PREFIX}/libexec/frodo
- ${CP} "${WRKDIR}/Frodo/TkGui.tcl" ${PREFIX}/libexec/frodo
+ ${INSTALL_SCRIPT} "${WRKDIR}/Frodo/TkGui.tcl" ${PREFIX}/libexec/frodo
${MKDIR} ${PREFIX}/libexec/frodo/64prgs
@${TAR} -C ${WRKDIR}/Frodo/64prgs -cf - . | \
${TAR} -C ${PREFIX}/libexec/frodo/64prgs -xf -
diff --git a/emulators/frodo/files/patch-C64_x.i b/emulators/frodo/files/patch-C64_x.i
index a2b4a23d6673..b0948fc6dd93 100644
--- a/emulators/frodo/files/patch-C64_x.i
+++ b/emulators/frodo/files/patch-C64_x.i
@@ -5,7 +5,7 @@
#else
// try to start up Tk gui.
- gui = new CmdPipe("wish", "TkGui.tcl");
-+ gui = new CmdPipe("wish8.3", "TkGui.tcl");
++ gui = new CmdPipe("wish8.4", "TkGui.tcl");
if (gui) {
if (gui->fail) {
delete gui; gui = 0;
diff --git a/emulators/frodo/files/patch-TkGui.tcl b/emulators/frodo/files/patch-TkGui.tcl
index fcefa38ad682..cf8c2d7d675a 100644
--- a/emulators/frodo/files/patch-TkGui.tcl
+++ b/emulators/frodo/files/patch-TkGui.tcl
@@ -2,7 +2,7 @@
+++ ../TkGui.tcl Mon Apr 26 21:49:18 1999
@@ -1,9 +1,9 @@
-#!/usr/local/bin/X11/wish
-+#!%%LOCALBASE%%/bin/wish8.3 -f
++#!%%LOCALBASE%%/bin/wish8.4 -f
# Frodo Tk GUI by Lutz Vieweg <lkv@mania.robin.de>
# requires Tk >= 4.1
diff --git a/irc/zircon/Makefile b/irc/zircon/Makefile
index 65285832e8e7..3d7302fe0dc7 100644
--- a/irc/zircon/Makefile
+++ b/irc/zircon/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= ftp://catless.ncl.ac.uk/pub/
MAINTAINER= dinoex@FreeBSD.org
COMMENT= An X11 interface to Internet Relay Chat
-RUN_DEPENDS= wish8.3:${PORTSDIR}/x11-toolkits/tk83
+RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
NO_BUILD= yes
diff --git a/irc/zircon/files/patch-aa b/irc/zircon/files/patch-aa
index d438438861ab..21795fe21bb2 100644
--- a/irc/zircon/files/patch-aa
+++ b/irc/zircon/files/patch-aa
@@ -5,7 +5,7 @@
global CC GCC SCflag CFlags Type SLDflag share scflags
switch {} $CC {} default return
- set CFlags -O
-+ set CFlags {-O -I/usr/local/include/tcl8.3}
++ set CFlags {-O -I/usr/local/include/tcl8.4}
catch {set CFlags $cflags($Type)}
switch BSDI $Type {
set CC gcc2