summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/amarok-kde4/Makefile2
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_magnatunebrowser_magnatunealbumdownloader.cpp29
-rw-r--r--audio/amarok/Makefile2
-rw-r--r--audio/amarok/files/patch-amarok_src_magnatunebrowser_magnatunealbumdownloader.cpp29
4 files changed, 60 insertions, 2 deletions
diff --git a/audio/amarok-kde4/Makefile b/audio/amarok-kde4/Makefile
index 1887fd8ad7f8..9194ba769f71 100644
--- a/audio/amarok-kde4/Makefile
+++ b/audio/amarok-kde4/Makefile
@@ -6,7 +6,7 @@
PORTNAME= amarok
PORTVERSION= 1.4.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTNAME}/${PORTVERSION}/src
diff --git a/audio/amarok-kde4/files/patch-amarok_src_magnatunebrowser_magnatunealbumdownloader.cpp b/audio/amarok-kde4/files/patch-amarok_src_magnatunebrowser_magnatunealbumdownloader.cpp
new file mode 100644
index 000000000000..e63530991f61
--- /dev/null
+++ b/audio/amarok-kde4/files/patch-amarok_src_magnatunebrowser_magnatunealbumdownloader.cpp
@@ -0,0 +1,29 @@
+
+$FreeBSD$
+
+--- amarok/src/magnatunebrowser/magnatunealbumdownloader.cpp.orig
++++ amarok/src/magnatunebrowser/magnatunealbumdownloader.cpp
+@@ -89,19 +89,19 @@
+
+ //ok, now we have the .zip file downloaded. All we need is to unpack it to the desired location and add it to the collection.
+
+- QString unzipString = "unzip \""+m_tempDir.name() + m_currentAlbumFileName + "\" -d \"" + m_currentAlbumUnpackLocation + "\" &";
++ QString unzipString = "unzip "+ KProcess::quote( m_tempDir.name() + m_currentAlbumFileName) + " -d " +KProcess::quote( m_currentAlbumUnpackLocation ) + " &";
+
+ debug() << "unpacking: " << unzipString << endl;
+
+ system( unzipString.ascii() );
+
+-
++
+
+ if (m_currentAlbumId != -1 ) {
+
+- //now I really want to add the album cover to the same folder where I just unzipped the album... The
++ //now I really want to add the album cover to the same folder where I just unzipped the album... The
+ //only way of getting the actual location where the album was unpacked is using the artist and album names
+-
++
+ MagnatuneAlbum album = MagnatuneDatabaseHandler::instance()->getAlbumById( m_currentAlbumId );
+ MagnatuneArtist artist = MagnatuneDatabaseHandler::instance()->getArtistById( album.getArtistId() );
+
diff --git a/audio/amarok/Makefile b/audio/amarok/Makefile
index 1887fd8ad7f8..9194ba769f71 100644
--- a/audio/amarok/Makefile
+++ b/audio/amarok/Makefile
@@ -6,7 +6,7 @@
PORTNAME= amarok
PORTVERSION= 1.4.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTNAME}/${PORTVERSION}/src
diff --git a/audio/amarok/files/patch-amarok_src_magnatunebrowser_magnatunealbumdownloader.cpp b/audio/amarok/files/patch-amarok_src_magnatunebrowser_magnatunealbumdownloader.cpp
new file mode 100644
index 000000000000..e63530991f61
--- /dev/null
+++ b/audio/amarok/files/patch-amarok_src_magnatunebrowser_magnatunealbumdownloader.cpp
@@ -0,0 +1,29 @@
+
+$FreeBSD$
+
+--- amarok/src/magnatunebrowser/magnatunealbumdownloader.cpp.orig
++++ amarok/src/magnatunebrowser/magnatunealbumdownloader.cpp
+@@ -89,19 +89,19 @@
+
+ //ok, now we have the .zip file downloaded. All we need is to unpack it to the desired location and add it to the collection.
+
+- QString unzipString = "unzip \""+m_tempDir.name() + m_currentAlbumFileName + "\" -d \"" + m_currentAlbumUnpackLocation + "\" &";
++ QString unzipString = "unzip "+ KProcess::quote( m_tempDir.name() + m_currentAlbumFileName) + " -d " +KProcess::quote( m_currentAlbumUnpackLocation ) + " &";
+
+ debug() << "unpacking: " << unzipString << endl;
+
+ system( unzipString.ascii() );
+
+-
++
+
+ if (m_currentAlbumId != -1 ) {
+
+- //now I really want to add the album cover to the same folder where I just unzipped the album... The
++ //now I really want to add the album cover to the same folder where I just unzipped the album... The
+ //only way of getting the actual location where the album was unpacked is using the artist and album names
+-
++
+ MagnatuneAlbum album = MagnatuneDatabaseHandler::instance()->getAlbumById( m_currentAlbumId );
+ MagnatuneArtist artist = MagnatuneDatabaseHandler::instance()->getArtistById( album.getArtistId() );
+