summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/swish++/Makefile14
-rw-r--r--www/swish++/distinfo6
-rw-r--r--www/swish++/pkg-descr6
3 files changed, 11 insertions, 15 deletions
diff --git a/www/swish++/Makefile b/www/swish++/Makefile
index eb8121c24557..ac94036d2069 100644
--- a/www/swish++/Makefile
+++ b/www/swish++/Makefile
@@ -7,9 +7,10 @@
#
PORTNAME= swish++
-PORTVERSION= 6.0.4
+PORTVERSION= 6.1.4
CATEGORIES= www textproc
-MASTER_SITES= http://homepage.mac.com/pauljlucas/software/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= swishplusplus
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple Web Indexing System for Humans: C++ version
@@ -18,6 +19,7 @@ RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
USE_PERL5= yes
USE_GMAKE= yes
+USE_GCC= 3.4+
MAKEFILE= GNUmakefile
MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS} \
PERL=${PERL} PERL_VER=${PERL_VER}
@@ -27,12 +29,6 @@ MAN3= WWW.3
MAN4= swish++.conf.4 swish++.index.4
MAN8= searchd.8 searchmonitor.8
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-USE_GCC= 3.4
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/^#error/d' ${WRKSRC}/config.h
.for file in scripts/searchd scripts/searchmonitor
@@ -45,4 +41,4 @@ pre-install:
post-install:
${INSTALL_SCRIPT} ${FILESDIR}/swish++.sh ${PREFIX}/etc/rc.d/swish++.sh.sample
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/swish++/distinfo b/www/swish++/distinfo
index b7947e24e4a4..f0fe8c75ed0b 100644
--- a/www/swish++/distinfo
+++ b/www/swish++/distinfo
@@ -1,3 +1,3 @@
-MD5 (swish++-6.0.4.tar.gz) = 3a81a1ca59addd6198f89e680bc77bff
-SHA256 (swish++-6.0.4.tar.gz) = ad5eb3fd64c6206f0e259c79c894f24f4cc2b8ca1f909eb16bc9eb5acd5074d1
-SIZE (swish++-6.0.4.tar.gz) = 292826
+MD5 (swish++-6.1.4.tar.gz) = 08c0eac88e4f08c353037b893e243268
+SHA256 (swish++-6.1.4.tar.gz) = 35e2c3d98a0cfd8c9fac45b7e12d13462e2521f025daac81045e697f403721f7
+SIZE (swish++-6.1.4.tar.gz) = 302123
diff --git a/www/swish++/pkg-descr b/www/swish++/pkg-descr
index 5403b5cd5029..9b9c9b5a1b84 100644
--- a/www/swish++/pkg-descr
+++ b/www/swish++/pkg-descr
@@ -1,4 +1,4 @@
-SWISH++ is a Unix-based file indexing and searching engine (typically used to
-index and search files on web sites). It was based on SWISH-E
+SWISH++ is a Unix-based file indexing and searching engine (typically
+used to index and search files on web sites). It was based on SWISH-E.
-WWW: http://homepage.mac.com/pauljlucas/software/swish/
+WWW: http://swishplusplus.sourceforge.net/