summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/python-devel/Makefile1
-rw-r--r--lang/python/Makefile1
-rw-r--r--lang/python23/Makefile1
-rw-r--r--lang/python24/Makefile1
-rw-r--r--lang/python25/Makefile1
-rw-r--r--lang/python26/Makefile1
-rw-r--r--lang/python27/Makefile1
-rw-r--r--lang/python30/Makefile1
-rw-r--r--lang/python31/Makefile1
-rw-r--r--lang/python32/Makefile1
10 files changed, 10 insertions, 0 deletions
diff --git a/lang/python-devel/Makefile b/lang/python-devel/Makefile
index 3b275651461d..d88b5e0bcd2a 100644
--- a/lang/python-devel/Makefile
+++ b/lang/python-devel/Makefile
@@ -17,6 +17,7 @@ COMMENT?= An interpreted object-oriented programming language
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 3495e7ec11c2..5bee1a4457bc 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -20,6 +20,7 @@ CONFLICTS= stackless_python-*
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python23/Makefile b/lang/python23/Makefile
index 3495e7ec11c2..5bee1a4457bc 100644
--- a/lang/python23/Makefile
+++ b/lang/python23/Makefile
@@ -20,6 +20,7 @@ CONFLICTS= stackless_python-*
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index 3495e7ec11c2..5bee1a4457bc 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -20,6 +20,7 @@ CONFLICTS= stackless_python-*
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python25/Makefile b/lang/python25/Makefile
index 3b275651461d..d88b5e0bcd2a 100644
--- a/lang/python25/Makefile
+++ b/lang/python25/Makefile
@@ -17,6 +17,7 @@ COMMENT?= An interpreted object-oriented programming language
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index 3b275651461d..d88b5e0bcd2a 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -17,6 +17,7 @@ COMMENT?= An interpreted object-oriented programming language
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 3b275651461d..d88b5e0bcd2a 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -17,6 +17,7 @@ COMMENT?= An interpreted object-oriented programming language
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python30/Makefile b/lang/python30/Makefile
index 3b275651461d..d88b5e0bcd2a 100644
--- a/lang/python30/Makefile
+++ b/lang/python30/Makefile
@@ -17,6 +17,7 @@ COMMENT?= An interpreted object-oriented programming language
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index 3b275651461d..d88b5e0bcd2a 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -17,6 +17,7 @@ COMMENT?= An interpreted object-oriented programming language
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 3b275651461d..d88b5e0bcd2a 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -17,6 +17,7 @@ COMMENT?= An interpreted object-oriented programming language
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"