summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/ldapmodule/Makefile3
-rw-r--r--net/py-ldap1/Makefile3
-rw-r--r--net/py-ldap2/Makefile3
3 files changed, 6 insertions, 3 deletions
diff --git a/net/ldapmodule/Makefile b/net/ldapmodule/Makefile
index a1f2872adbb4..b4f6c00a6caa 100644
--- a/net/ldapmodule/Makefile
+++ b/net/ldapmodule/Makefile
@@ -18,7 +18,8 @@ LIB_DEPENDS= ldap.1:${PORTSDIR}/net/openldap
BUILD_DEPENDS= python:${PORTSDIR}/lang/python
RUN_DEPENDS= python:${PORTSDIR}/lang/python
-USE_PYTHON= yes
+# BROKEN for python 2.2
+PYTHON_VERSION= python2.1
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
WRKSRC= ${WRKDIR}/${DISTNAME:S=-src==}
diff --git a/net/py-ldap1/Makefile b/net/py-ldap1/Makefile
index a1f2872adbb4..b4f6c00a6caa 100644
--- a/net/py-ldap1/Makefile
+++ b/net/py-ldap1/Makefile
@@ -18,7 +18,8 @@ LIB_DEPENDS= ldap.1:${PORTSDIR}/net/openldap
BUILD_DEPENDS= python:${PORTSDIR}/lang/python
RUN_DEPENDS= python:${PORTSDIR}/lang/python
-USE_PYTHON= yes
+# BROKEN for python 2.2
+PYTHON_VERSION= python2.1
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
WRKSRC= ${WRKDIR}/${DISTNAME:S=-src==}
diff --git a/net/py-ldap2/Makefile b/net/py-ldap2/Makefile
index a1f2872adbb4..b4f6c00a6caa 100644
--- a/net/py-ldap2/Makefile
+++ b/net/py-ldap2/Makefile
@@ -18,7 +18,8 @@ LIB_DEPENDS= ldap.1:${PORTSDIR}/net/openldap
BUILD_DEPENDS= python:${PORTSDIR}/lang/python
RUN_DEPENDS= python:${PORTSDIR}/lang/python
-USE_PYTHON= yes
+# BROKEN for python 2.2
+PYTHON_VERSION= python2.1
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
WRKSRC= ${WRKDIR}/${DISTNAME:S=-src==}