summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--deskutils/gcal/Makefile10
-rw-r--r--devel/bison/Makefile13
-rw-r--r--devel/cppi/Makefile4
-rw-r--r--devel/gindent/Makefile4
-rw-r--r--lang/gawk/Makefile4
5 files changed, 23 insertions, 12 deletions
diff --git a/deskutils/gcal/Makefile b/deskutils/gcal/Makefile
index 2eebfa384cf1..7ba0d86bb4c1 100644
--- a/deskutils/gcal/Makefile
+++ b/deskutils/gcal/Makefile
@@ -22,12 +22,14 @@ CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
INFO= gcal
#MAN1= gcal.1 gcal2txt.1 tcal.1 txt2gcal.1
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
GCAL_SCRIPTS= daily/daily ddiff/ddiff ddiff/ddiffdrv dst/dst gcalltx/gcalltx \
diff --git a/devel/bison/Makefile b/devel/bison/Makefile
index 139478c0678e..7f651b40a608 100644
--- a/devel/bison/Makefile
+++ b/devel/bison/Makefile
@@ -27,12 +27,15 @@ MAN1= bison.1
INFO= bison
CONFIGURE_ARGS+=--disable-yacc
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
.ifdef USE_BISON
@@ -42,7 +45,7 @@ PLIST_SUB+= NLS=""
post-extract:
@${RM} -f ${WRKSRC}/doc/bison.info*
@${REINPLACE_CMD} 's/MANS = yacc.1/MANS =/' ${WRKSRC}/doc/Makefile.in
-.if defined(WITHOUT_NLS)
+.if empty(${PORT_OPTIONS:MNLS})
@${REINPLACE_CMD} 's/ install-exec-local//' ${WRKSRC}/lib/Makefile.in
.endif
diff --git a/devel/cppi/Makefile b/devel/cppi/Makefile
index 7327050884f7..0fda97726475 100644
--- a/devel/cppi/Makefile
+++ b/devel/cppi/Makefile
@@ -21,7 +21,9 @@ CPPFLAGS+= -I${LOCALBASE}/include
MAN1= cppi.1
-.ifndef WITHOUT_NLS
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
diff --git a/devel/gindent/Makefile b/devel/gindent/Makefile
index e105852122f0..01d9aec01d0b 100644
--- a/devel/gindent/Makefile
+++ b/devel/gindent/Makefile
@@ -23,7 +23,9 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --program-prefix=g
MAKE_JOBS_UNSAFE= yes
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
diff --git a/lang/gawk/Makefile b/lang/gawk/Makefile
index bc09505fcfee..ca848e3a87e9 100644
--- a/lang/gawk/Makefile
+++ b/lang/gawk/Makefile
@@ -27,7 +27,9 @@ MAN1= gawk.1 igawk.1 pgawk.1
PLIST_SUB= VERSION=${PORTVERSION}
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else