summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--devel/thrift-cpp/Makefile4
-rw-r--r--lang/ruby23/Makefile4
-rw-r--r--www/spdylay/Makefile6
3 files changed, 14 insertions, 0 deletions
diff --git a/devel/thrift-cpp/Makefile b/devel/thrift-cpp/Makefile
index 5940ee964f1e..c8fd81a6dc87 100644
--- a/devel/thrift-cpp/Makefile
+++ b/devel/thrift-cpp/Makefile
@@ -54,6 +54,10 @@ CFLAGS+= -I${OPENSSLINC}
USE_CXXSTD= c++11
.endif
+.if ${SSL_DEFAULT} == openssl-devel
+BROKEN= Cannot find libcrypto.
+.endif
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lib*.so
${LN} -sf libthrift-${PORTVERSION}.so ${STAGEDIR}${PREFIX}/lib/libthrift.so.0
diff --git a/lang/ruby23/Makefile b/lang/ruby23/Makefile
index 65af26c2eb57..4a28c22d0282 100644
--- a/lang/ruby23/Makefile
+++ b/lang/ruby23/Makefile
@@ -73,6 +73,10 @@ CPE_UPDATE= p${RUBY_PATCHLEVEL}
.include <bsd.port.pre.mk>
+.if ${SSL_DEFAULT} == openssl-devel
+BROKEN= Does not detect and buid the openssl*.rb bits.
+.endif
+
# PORTREVISION/PORTEPOCH hack
.if ${PORTREVISION} != 0
diff --git a/www/spdylay/Makefile b/www/spdylay/Makefile
index 3d37ac8e56f6..cd379e0146de 100644
--- a/www/spdylay/Makefile
+++ b/www/spdylay/Makefile
@@ -37,4 +37,10 @@ post-install:
${INSTALL_SCRIPT} ${WRKSRC}/examples/spdycli ${STAGEDIR}${PREFIX}/bin/
${INSTALL_DATA} ${WRKSRC}/shrpx.conf.sample ${STAGEDIR}${PREFIX}/etc/
+.include <bsd.port.options.mk>
+
+.if ${SSL_DEFAULT} == openssl-devel
+BROKEN= Does not build.
+.endif
+
.include <bsd.port.mk>