summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--graphics/gnofract4d/Makefile25
-rw-r--r--graphics/gnofract4d/distinfo4
-rw-r--r--graphics/gnofract4d/pkg-descr2
3 files changed, 18 insertions, 13 deletions
diff --git a/graphics/gnofract4d/Makefile b/graphics/gnofract4d/Makefile
index 535aea795d29..bc0ec1a5efa0 100644
--- a/graphics/gnofract4d/Makefile
+++ b/graphics/gnofract4d/Makefile
@@ -2,24 +2,27 @@
# $FreeBSD$
PORTNAME= gnofract4d
-PORTVERSION= 3.14.1
-PORTREVISION= 3
+DISTVERSIONPREFIX= V_
+DISTVERSION= 3_14_1
+PORTREVISION= 4
CATEGORIES= graphics gnome
-MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Weird GNOME fractal generator
-BROKEN= unfetchable
-
LICENSE= BSD3CLAUSE
+BUILD_DEPENDS= docbook-xsl>0:textproc/docbook-xsl
LIB_DEPENDS= libpng.so:graphics/png
+RUN_DEPENDS= xdg-open:devel/xdg-utils
+
+USE_GITHUB= yes
+GH_ACCOUNT= edyoung
-USES= desktop-file-utils jpeg pathfix pkgconfig python shared-mime-info
-USE_GNOME= gnomeprefix intlhack libgnomeui pygtk2
+USES= desktop-file-utils display:build jpeg pathfix pkgconfig \
+ python shared-mime-info
+USE_GNOME= intlhack libxslt:build pygtk2
USE_PYTHON= distutils autoplist
-USE_GCC= yes
CFLAGS+= -I${LOCALBASE}/include
@@ -28,8 +31,6 @@ PLIST_FILES= man/man1/gnofract4d.1.gz
PORTDOCS= README
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|/usr/include/|${LOCALBASE}/include/|; \
/# doc files/,+2d; /"html"/,+1d' \
@@ -42,6 +43,9 @@ post-patch:
${WRKSRC}/fract4d/test_codegen.py \
${WRKSRC}/fract4d/fractconfig.py
+post-build:
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} createdocs.py)
+
post-install:
.for l in fract4d_stdlib fract4dc
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/fract4d/${l}.so
@@ -50,6 +54,7 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1 \
${STAGEDIR}${MAN1PREFIX}/man/man1/
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/graphics/gnofract4d/distinfo b/graphics/gnofract4d/distinfo
index abcdb5fb27f2..dc510d4c696b 100644
--- a/graphics/gnofract4d/distinfo
+++ b/graphics/gnofract4d/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnofract4d-3.14.1.tar.gz) = dea77e4119a488cdc5ae29dc64f2975eaaa7bbaca84e1c02aa016ff1eb5c59dc
-SIZE (gnofract4d-3.14.1.tar.gz) = 884442
+SHA256 (edyoung-gnofract4d-V_3_14_1_GH0.tar.gz) = 29f05d9b07f7b53bf250b0f81f74b76dbd68efc5d6ba71f4d55ef332f6b6f83d
+SIZE (edyoung-gnofract4d-V_3_14_1_GH0.tar.gz) = 4660808
diff --git a/graphics/gnofract4d/pkg-descr b/graphics/gnofract4d/pkg-descr
index 3a4ce8f559cc..64b94ef952a2 100644
--- a/graphics/gnofract4d/pkg-descr
+++ b/graphics/gnofract4d/pkg-descr
@@ -4,4 +4,4 @@ the computer based on mathematical principles. These include the Mandelbrot
and Julia sets and many more. You don't need to do any math: you can explore
a universe of images just using a mouse.
-WWW: http://gnofract4d.sourceforge.net/
+WWW: https://github.com/edyoung/gnofract4d