summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--graphics/tkpng/Makefile8
-rw-r--r--x11-toolkits/tktray/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/graphics/tkpng/Makefile b/graphics/tkpng/Makefile
index 2c681d2f3bb6..4f785953a89d 100644
--- a/graphics/tkpng/Makefile
+++ b/graphics/tkpng/Makefile
@@ -35,4 +35,10 @@ post-install:
@${LN} -sf ${PREFIX}/lib/${TKPKG}/lib${TKPKG}.so \
${PREFIX}/lib/${TKPKG}/lib${TKPKG}.so.0
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not compile on 4.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/tktray/Makefile b/x11-toolkits/tktray/Makefile
index 40cd9921d030..aa93f6579305 100644
--- a/x11-toolkits/tktray/Makefile
+++ b/x11-toolkits/tktray/Makefile
@@ -33,4 +33,10 @@ post-patch:
post-install:
@${LN} -sf ${USE_LDCONFIG}/lib${TKPKG}.so ${USE_LDCONFIG}/lib${TKPKG}.so.0
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not compile on 4.x
+.endif
+
+.include <bsd.port.post.mk>