summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--mail/qmailanalog/Makefile1
-rw-r--r--mail/qmailanalog/files/patch-hier.c22
-rw-r--r--www/publicfile/Makefile1
-rw-r--r--www/publicfile/files/patch-hier.c14
4 files changed, 38 insertions, 0 deletions
diff --git a/mail/qmailanalog/Makefile b/mail/qmailanalog/Makefile
index 719d350e198c..43d9a6e84ce7 100644
--- a/mail/qmailanalog/Makefile
+++ b/mail/qmailanalog/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qmailanalog
PORTVERSION= 0.70
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ftp://cr.yp.to/software/
diff --git a/mail/qmailanalog/files/patch-hier.c b/mail/qmailanalog/files/patch-hier.c
new file mode 100644
index 000000000000..7b0c3652a07a
--- /dev/null
+++ b/mail/qmailanalog/files/patch-hier.c
@@ -0,0 +1,22 @@
+--- hier.c.orig Tue Apr 20 11:14:18 2004
++++ hier.c Tue Apr 20 11:14:33 2004
+@@ -2,13 +2,13 @@
+
+ void hier()
+ {
+- h(auto_home,-1,-1,02755);
++ h(auto_home,-1,-1,0755);
+
+- d(auto_home,"bin",-1,-1,02755);
+- d(auto_home,"doc",-1,-1,02755);
+- d(auto_home,"man",-1,-1,02755);
+- d(auto_home,"man/man1",-1,-1,02755);
+- d(auto_home,"man/cat1",-1,-1,02755);
++ d(auto_home,"bin",-1,-1,0755);
++ d(auto_home,"doc",-1,-1,0755);
++ d(auto_home,"man",-1,-1,0755);
++ d(auto_home,"man/man1",-1,-1,0755);
++ d(auto_home,"man/cat1",-1,-1,0755);
+
+ c(auto_home,"doc","MATCHUP",-1,-1,0644);
+ c(auto_home,"doc","ACCOUNTING",-1,-1,0644);
diff --git a/www/publicfile/Makefile b/www/publicfile/Makefile
index 0b68c9ca1b23..5e9ce066be84 100644
--- a/www/publicfile/Makefile
+++ b/www/publicfile/Makefile
@@ -7,6 +7,7 @@
PORTNAME= publicfile
PORTVERSION= 0.52
+PORTREVISION= 1
CATEGORIES= www ftp
MASTER_SITES= http://cr.yp.to/publicfile/ \
ftp://cr.yp.to/publicfile/
diff --git a/www/publicfile/files/patch-hier.c b/www/publicfile/files/patch-hier.c
new file mode 100644
index 000000000000..587e3885207b
--- /dev/null
+++ b/www/publicfile/files/patch-hier.c
@@ -0,0 +1,14 @@
+--- hier.c.orig Tue Apr 20 11:26:00 2004
++++ hier.c Tue Apr 20 11:26:06 2004
+@@ -2,9 +2,9 @@
+
+ void hier()
+ {
+- h(auto_home,-1,-1,02755);
++ h(auto_home,-1,-1,0755);
+
+- d(auto_home,"bin",-1,-1,02755);
++ d(auto_home,"bin",-1,-1,0755);
+
+ c(auto_home,"bin","configure",-1,-1,0755);
+ c(auto_home,"bin","httpd",-1,-1,0755);