summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--x11/XFree86-4-clients/Makefile1
-rw-r--r--x11/XFree86-4-libraries/files/patch-startx54
2 files changed, 55 insertions, 0 deletions
diff --git a/x11/XFree86-4-clients/Makefile b/x11/XFree86-4-clients/Makefile
index 74d0586803fb..3b5f056bfa8d 100644
--- a/x11/XFree86-4-clients/Makefile
+++ b/x11/XFree86-4-clients/Makefile
@@ -7,6 +7,7 @@
PORTNAME= clients
PORTVERSION= 4.2.0
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_XFREE} \
ftp://psych.psy.uq.oz.au/pub/X11R5/:wrap \
diff --git a/x11/XFree86-4-libraries/files/patch-startx b/x11/XFree86-4-libraries/files/patch-startx
new file mode 100644
index 000000000000..bda120efac80
--- /dev/null
+++ b/x11/XFree86-4-libraries/files/patch-startx
@@ -0,0 +1,54 @@
+--- programs/xinit/startx.cpp.orig Fri Nov 30 21:57:48 2001
++++ programs/xinit/startx.cpp Fri Jan 18 23:59:42 2002
+@@ -80,8 +80,12 @@
+ fi
+
+ whoseargs="client"
++listen_tcp="-nolisten tcp"
+ while [ x"$1" != x ]; do
+ case "$1" in
++ -listen_tcp)
++ listen_tcp=""
++ ;;
+ # '' required to prevent cpp from treating "/*" as a C comment.
+ /''*|\./''*)
+ if [ "$whoseargs" = "client" ]; then
+@@ -164,7 +168,7 @@
+ done
+ #endif
+
+-xinit $client $clientargs -- $server $display $serverargs
++xinit $client $clientargs -- $server $display $serverargs $listen_tcp
+
+ if [ x"$removelist" != x ]; then
+ xauth remove $removelist
+--- programs/xinit/startx.man.orig Fri Dec 14 21:01:56 2001
++++ programs/xinit/startx.man Fri Jan 18 23:56:03 2002
+@@ -46,10 +46,17 @@
+ somewhat nicer user interface for running a single session of the X
+ Window System. It is often run with no arguments.
+ .PP
+-Arguments immediately following the
++Except for the
++.RB '-listen_tcp'
++option, arguments immediately following the
+ .I startx
+ command are used to start a client in the same manner as
+ .IR xinit (1).
++The
++.RB '-listen_tcp'
++option of startx enables the TCP/IP transport type which is needed for remote X
++displays. This is disabled by default for security reasons.
++.PP
+ The special argument
+ .RB '--'
+ marks the end of client arguments and the beginning of server options.
+@@ -70,6 +77,8 @@
+ startx -- -dpi 100
+ .PP
+ startx -- -layout Multihead
++.PP
++startx -listen_tcp -- -depth 16
+ .RE
+ .PP
+ To determine the client to run,