summaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2004-01-25 10:14:08 +0000
committerEric Anholt <anholt@FreeBSD.org>2004-01-25 10:14:08 +0000
commita60d3aa8954736c6f561ce25f619605310838225 (patch)
treed59f2bdd6194474e3532ec08c1793dc66cddba0b /x11
parent- Update cdrtools-devel port to 2.01a25 which fixes a crash of cdrecord. (diff)
New port: X Pixmap library from freedesktop.org
Testing is encouraged, but please do not use these ports as dependencies until the XFree86 ports have been updated to depend on them.
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/libXpm/Makefile31
-rw-r--r--x11/libXpm/distinfo1
-rw-r--r--x11/libXpm/pkg-descr6
-rw-r--r--x11/libXpm/pkg-plist5
5 files changed, 44 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index cbe203ad0e59..8ee12ea37062 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -90,6 +90,7 @@
SUBDIR += libXfixes
SUBDIR += libXfont
SUBDIR += libXi
+ SUBDIR += libXpm
SUBDIR += libXrandr
SUBDIR += libXrender
SUBDIR += libXres
diff --git a/x11/libXpm/Makefile b/x11/libXpm/Makefile
new file mode 100644
index 000000000000..eaa93344538d
--- /dev/null
+++ b/x11/libXpm/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: libXpm
+# Date Created: 25 Jan, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libXpm
+PORTVERSION= 3.5.0
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~xlibs/release/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X Pixmap library
+
+LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/x11.pc:${PORTSDIR}/x11/libX11
+BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/xproto.pc:${PORTSDIR}/x11/xproto \
+ ${LIB_PC_DEPENDS}
+RUN_DEPENDS= ${LIB_PC_DEPENDS}
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_LIBTOOL= yes
+CFLAGS+= -DMALLOC_0_RETURNS_NULL
+INSTALLS_SHLIB= yes
+USE_GNOME= gnomehack pkgconfig
+
+.include <bsd.port.mk>
diff --git a/x11/libXpm/distinfo b/x11/libXpm/distinfo
new file mode 100644
index 000000000000..e8ee19525cba
--- /dev/null
+++ b/x11/libXpm/distinfo
@@ -0,0 +1 @@
+MD5 (libXpm-3.5.0.tar.bz2) = 9c0989b118ae29b5d68d93685504a9cb
diff --git a/x11/libXpm/pkg-descr b/x11/libXpm/pkg-descr
new file mode 100644
index 000000000000..dcf853a3c354
--- /dev/null
+++ b/x11/libXpm/pkg-descr
@@ -0,0 +1,6 @@
+This package contains the X Pixmap library.
+
+WWW: http://www.freedesktop.org/Software/xlibs
+
+- Eric Anholt
+anholt@FreeBSD.org
diff --git a/x11/libXpm/pkg-plist b/x11/libXpm/pkg-plist
new file mode 100644
index 000000000000..96b3bab06b7b
--- /dev/null
+++ b/x11/libXpm/pkg-plist
@@ -0,0 +1,5 @@
+lib/libXpm.a
+lib/libXpm.la
+lib/libXpm.so
+lib/libXpm.so.3
+libdata/pkgconfig/xpm.pc