summaryrefslogtreecommitdiff
path: root/x11/xscreensaver/Makefile
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2001-03-03 01:49:13 +0000
committerDoug Barton <dougb@FreeBSD.org>2001-03-03 01:49:13 +0000
commitd33199033bf9a2331eecc9ee8f7c828078569c46 (patch)
tree50035523d83d39f5bb064ebc54c16542eb1c3541 /x11/xscreensaver/Makefile
parentUse random() because rand() is just too lame (diff)
* Assume maintainership. Mail to jseger went unanswered, and this port
has been periodically maintained by others for 9 months in any case. * Upgrade 3.26 -> 3.29 * Specify full path to fortune, since many of the screen saver programs could not find it on their own. * Fix the -lpthread -> -pthread problem. * Re-generate patch files. * Eliminate patch-ae, whose only purpose in life was to prevent the building and installation of the xscreensaver-demo program which, in addition to being the method used to configure the server and all the little screensaver programs; works just fine, and doesn't actually hurt anything. The report in the PR is a little out of date with reference to the latest xscreensaver version, but all parts of the thing are working for me now in any case. PR: ports/23619 Submitted by: Lars Eggert <larse@isi.edu>
Diffstat (limited to 'x11/xscreensaver/Makefile')
-rw-r--r--x11/xscreensaver/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/x11/xscreensaver/Makefile b/x11/xscreensaver/Makefile
index 7a863b195dc6..33bec5195604 100644
--- a/x11/xscreensaver/Makefile
+++ b/x11/xscreensaver/Makefile
@@ -6,20 +6,21 @@
#
PORTNAME= xscreensaver
-PORTVERSION= 3.26
+PORTVERSION= 3.29
CATEGORIES= x11
MASTER_SITES= http://www.jwz.org/xscreensaver/
-MAINTAINER= jseger@FreeBSD.org
+MAINTAINER= DougB@FreeBSD.org
USE_X_PREFIX= yes
USE_XPM= yes
USE_MESA= yes
WANT_GTK= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --without-pam --with-gl --with-gle --with-xpm --without-gnome
+CONFIGURE_ARGS= --without-pam --with-gl --with-gle --with-xpm --without-gnome \
+ --with-zippy=/usr/games/fortune
-MAN1= attraction.1 blitspin.1 bouboule.1 braid.1 \
+MAN1= attraction.1 blitspin.1 bouboule.1 braid.1 \
bsod.1 bubbles.1 critical.1 decayscreen.1 \
deco.1 distort.1 drift.1 epicycle.1 flag.1 flame.1 \
forest.1 galaxy.1 gflux.1 goop.1 grav.1 greynetic.1 \
@@ -30,10 +31,15 @@ MAN1= attraction.1 blitspin.1 bouboule.1 braid.1 \
rd-bomb.1 rocks.1 rorschach.1 sierpinski.1 slidescreen.1 \
slip.1 sonar.1 sphere.1 spiral.1 spotlight.1 squiral.1 \
starfish.1 strange.1 swirl.1 t3d.1 vidwhacker.1 vines.1 \
- webcollage.1 xflame.1 xjack.1 xlyap.1 xmatrix.1 xroger.1 \
+ webcollage.1 xflame.1 xjack.1 xlyap.1 xmatrix.1 \
xscreensaver-command.1 xscreensaver-gl-helper.1 \
xscreensaver.1 xsublim.1 xteevee.1
+post-patch:
+ @ ${CP} ${WRKSRC}/configure ${WRKSRC}/configure.Patched
+ @ ${SED} -e 's#-lpthread#-pthread#g' \
+ ${WRKSRC}/configure.Patched > ${WRKSRC}/configure
+
.include <bsd.port.pre.mk>
.if defined(HAVE_GTK)