summaryrefslogtreecommitdiff
path: root/x11/rxvt-unicode
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-12-16 20:15:09 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-12-16 20:15:09 +0000
commit38de26770cc935abee2ccd549c44ccd7a11b9427 (patch)
tree87380f86af19506b1a7669a8f56b4bab2fab71e8 /x11/rxvt-unicode
parentRemove offending chown-age. (diff)
Upgrade to 4.6.
Diffstat (limited to 'x11/rxvt-unicode')
-rw-r--r--x11/rxvt-unicode/Makefile2
-rw-r--r--x11/rxvt-unicode/distinfo4
-rw-r--r--x11/rxvt-unicode/files/patch-src::command.C24
3 files changed, 6 insertions, 24 deletions
diff --git a/x11/rxvt-unicode/Makefile b/x11/rxvt-unicode/Makefile
index 39438c6adb9c..b1a3ab1830ae 100644
--- a/x11/rxvt-unicode/Makefile
+++ b/x11/rxvt-unicode/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= rxvt-unicode
-PORTVERSION= 4.5
+PORTVERSION= 4.6
CATEGORIES= x11
MASTER_SITES= http://dist.schmorp.de/rxvt-unicode/%SUBDIR%/
MASTER_SITE_SUBDIR= . Attic
diff --git a/x11/rxvt-unicode/distinfo b/x11/rxvt-unicode/distinfo
index da7740e2230b..ca2d0ce3a8ff 100644
--- a/x11/rxvt-unicode/distinfo
+++ b/x11/rxvt-unicode/distinfo
@@ -1,2 +1,2 @@
-MD5 (rxvt-unicode-4.5.tar.bz2) = 6c50844b781cb56f34b56b1452792352
-SIZE (rxvt-unicode-4.5.tar.bz2) = 903285
+MD5 (rxvt-unicode-4.6.tar.bz2) = f8b5058808125de3412d13668ee2316c
+SIZE (rxvt-unicode-4.6.tar.bz2) = 889915
diff --git a/x11/rxvt-unicode/files/patch-src::command.C b/x11/rxvt-unicode/files/patch-src::command.C
index 574168368631..1022081b9c7f 100644
--- a/x11/rxvt-unicode/files/patch-src::command.C
+++ b/x11/rxvt-unicode/files/patch-src::command.C
@@ -1,5 +1,5 @@
---- src/command.C.orig Wed Dec 1 01:41:39 2004
-+++ src/command.C Wed Dec 1 21:25:37 2004
+--- src/command.C.orig Wed Dec 15 06:38:28 2004
++++ src/command.C Thu Dec 16 20:33:55 2004
@@ -51,6 +51,8 @@
#include "command.h"
@@ -9,7 +9,7 @@
#include <signal.h>
/*----------------------------------------------------------------------*/
-@@ -2698,7 +2700,9 @@
+@@ -2700,7 +2702,9 @@
if (len == (size_t)-2)
{
// the mbstate stores incomplete sequences. didn't know this :/
@@ -19,21 +19,3 @@
break;
}
-@@ -4296,7 +4300,7 @@
- {
- if (v_buflen == 0)
- {
-- ssize_t written = write (pty.pty, data, min (len, MAX_PTY_WRITE));
-+ ssize_t written = write (pty.pty, data, min (len, (unsigned int) MAX_PTY_WRITE));
-
- if ((unsigned int)written == len)
- return;
-@@ -4314,7 +4318,7 @@
-
- for (;;)
- {
-- int written = write (pty.pty, v_buffer, min (v_buflen, MAX_PTY_WRITE));
-+ int written = write (pty.pty, v_buffer, min (v_buflen, (unsigned int) MAX_PTY_WRITE));
-
- if (written > 0)
- {