summaryrefslogtreecommitdiff
path: root/x11/libXres
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2003-12-22 00:23:26 +0000
committerEric Anholt <anholt@FreeBSD.org>2003-12-22 00:23:26 +0000
commit1f7ea8c5d62da4d8406474e8826c1ab1c4fc1111 (patch)
treee622ff6838ba38c33ddb6602ed98c506ed6d86d5 /x11/libXres
parentNew port: Prerelease version of resourceext from freedesktop.org: (diff)
New port: Prerelease version of libXres from freedesktop.org:
X Resource usage library Testing is encouraged, but please do not use these ports as dependencies until they are updated to release tarballs and the XFree86 ports have been updated to depend on them.
Diffstat (limited to 'x11/libXres')
-rw-r--r--x11/libXres/Makefile32
-rw-r--r--x11/libXres/distinfo1
-rw-r--r--x11/libXres/files/patch-Makefile.in11
-rw-r--r--x11/libXres/pkg-descr6
-rw-r--r--x11/libXres/pkg-plist6
5 files changed, 56 insertions, 0 deletions
diff --git a/x11/libXres/Makefile b/x11/libXres/Makefile
new file mode 100644
index 000000000000..7f4945a7e7d7
--- /dev/null
+++ b/x11/libXres/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: libXext
+# Date Created: 29 Oct, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libXres
+PORTVERSION= 1.0.1.p1
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X Resource usage library
+
+LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/x11.pc:${PORTSDIR}/x11/libX11
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
+ ${X11BASE}/libdata/pkgconfig/resourceext.pc:${PORTSDIR}/x11/resourceext \
+ ${LIB_PC_DEPENDS}
+RUN_DEPENDS= ${LIB_PC_DEPENDS}
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_LIBTOOL= yes
+CFLAGS+= -DMALLOC_0_RETURNS_NULL
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.0.1
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/x11/libXres/distinfo b/x11/libXres/distinfo
new file mode 100644
index 000000000000..0131709d8c8f
--- /dev/null
+++ b/x11/libXres/distinfo
@@ -0,0 +1 @@
+MD5 (libXres-1.0.1.p1.tar.bz2) = ee16c4d5e730ea28f1c62230ce78be44
diff --git a/x11/libXres/files/patch-Makefile.in b/x11/libXres/files/patch-Makefile.in
new file mode 100644
index 000000000000..6bfb9b6b838c
--- /dev/null
+++ b/x11/libXres/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sun Dec 21 16:10:44 2003
++++ Makefile.in Sun Dec 21 16:16:52 2003
+@@ -177,7 +177,7 @@
+ libXResincludedir = $(includedir)/X11/extensions
+ libXResinclude_HEADERS = XRes.h
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = xres.pc
+
+ EXTRA_DIST = xres.pc.in autogen.sh
diff --git a/x11/libXres/pkg-descr b/x11/libXres/pkg-descr
new file mode 100644
index 000000000000..69153de5975b
--- /dev/null
+++ b/x11/libXres/pkg-descr
@@ -0,0 +1,6 @@
+This package contains the X Resource usage library.
+
+WWW: http://www.freedesktop.org/Software/xlibs
+
+- Eric Anholt
+anholt@FreeBSD.org
diff --git a/x11/libXres/pkg-plist b/x11/libXres/pkg-plist
new file mode 100644
index 000000000000..eb751f99b93f
--- /dev/null
+++ b/x11/libXres/pkg-plist
@@ -0,0 +1,6 @@
+include/X11/extensions/XRes.h
+lib/libXRes.a
+lib/libXRes.la
+lib/libXRes.so
+lib/libXRes.so.0
+libdata/pkgconfig/xres.pc