summaryrefslogtreecommitdiff
path: root/x11/kdebase4-runtime/Makefile
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2007-02-10 03:32:52 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2007-02-10 03:32:52 +0000
commitc1b494c191d87ccd6df52c7b821bbfde1a9f8ed3 (patch)
tree0363872df50481d3896dc64571a329f68a8594c7 /x11/kdebase4-runtime/Makefile
parentA possible build fix on pointyhat. (diff)
Fix various problems in the media kioslave:
- Correct ejecting of mounted volumes (unmount before eject). - Mounting of removable media drives (such as CD-ROM drives) listed in /etc/fstab (removes checking linux's "user" mount option). - Polling floppy drives over the mount state (FreeBSD HAL doesn't do this). - Informing the fileview when HAL notifies that mounting is completed. - Mounting cdrom volume in locale charset. Note: Requires cd9660_iconv! PR: ports/108949 Submitted by: Maxim Samsonov <xors@sendmail.ru> - Disable polling of nfs shares in the fstabbackend. Mounting/Unmounting is broken and the polling can cause DBus aborts that take kded with them.
Diffstat (limited to 'x11/kdebase4-runtime/Makefile')
-rw-r--r--x11/kdebase4-runtime/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/x11/kdebase4-runtime/Makefile b/x11/kdebase4-runtime/Makefile
index 870bc4b6b30c..993cd069c13b 100644
--- a/x11/kdebase4-runtime/Makefile
+++ b/x11/kdebase4-runtime/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
@@ -71,7 +71,8 @@ RUN_DEPENDS+= htdig:${PORTSDIR}/textproc/htdig
.endif
.if defined(WITH_HAL) && ${OSVERSION} > 500035
-EXTRA_PATCHES= ${FILESDIR}/extrapatch-kioslave_media_mediamanager-halbackend.cpp
+EXTRA_PATCHES= ${FILESDIR}/extrapatch-kioslave_media_mediamanager-halbackend.cpp \
+ ${FILESDIR}/extrapatch-kioslave_media_mediamanager-halbackend.h
LIB_DEPENDS+= dbus-qt-1.1:${PORTSDIR}/devel/dbus-qt3 \
hal.1:${PORTSDIR}/sysutils/hal
PLIST_SUB+= MEDIA=""