summaryrefslogtreecommitdiff
path: root/x11/idesk/Makefile
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2003-02-27 21:55:55 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2003-02-27 21:55:55 +0000
commit2ed98e249634eec9b7362f4d7d5793421aa9706a (patch)
tree5f186dab46f40df0aa893e996341f0f1c63b9c0f /x11/idesk/Makefile
parent* Update to 0.73. (diff)
Import idesk 0.3.5.
iDesk lets you put launch icons directly on the root window of your X. PR: 48345 Submitted by: Sascha Holzleiter <sascha@root-login.org>
Diffstat (limited to 'x11/idesk/Makefile')
-rw-r--r--x11/idesk/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11/idesk/Makefile b/x11/idesk/Makefile
new file mode 100644
index 000000000000..7a97f96f67af
--- /dev/null
+++ b/x11/idesk/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: idesk
+# Date created: 16 February 2003
+# Whom: Sascha Holzleiter <sascha@root-login.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= idesk
+PORTVERSION= 0.3.5
+CATEGORIES= x11
+MASTER_SITES= http://linuxhelp.hn.org/
+
+MAINTAINER= sascha@root-login.org
+COMMENT= Place launch icons directly on your desktop
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOMENG= yes
+USE_GNOME= imlib
+
+CXXFLAGS+= `imlib-config --cflags` `freetype-config --cflags`
+MAKE_ARGS= cc="${CXX}" cflags="${CXXFLAGS}"
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/idesk ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>