summaryrefslogtreecommitdiff
path: root/x11/gdm/files
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-05-12 19:46:32 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-05-12 19:46:32 +0000
commit6d01da656bded20882dc44eba56342df13d3231d (patch)
treec76502eda66fba48d3481ef69049e567ad1a480f /x11/gdm/files
parentStatically depend on libgnome again as it's easier to test this way and includes (diff)
Update to 2.14.6.
Diffstat (limited to 'x11/gdm/files')
-rw-r--r--x11/gdm/files/patch-config_Makefile.in10
-rw-r--r--x11/gdm/files/patch-configure25
-rw-r--r--x11/gdm/files/patch-daemon_gdmconfig.c10
-rw-r--r--x11/gdm/files/patch-daemon_server.c10
4 files changed, 5 insertions, 50 deletions
diff --git a/x11/gdm/files/patch-config_Makefile.in b/x11/gdm/files/patch-config_Makefile.in
index 9678f710c061..7c844f55cefd 100644
--- a/x11/gdm/files/patch-config_Makefile.in
+++ b/x11/gdm/files/patch-config_Makefile.in
@@ -1,11 +1,11 @@
---- config/Makefile.in.orig Fri Jun 11 15:40:03 2004
-+++ config/Makefile.in Fri Jun 11 15:41:30 2004
-@@ -400,7 +400,7 @@
-
+--- config/Makefile.in.orig Fri May 12 15:37:48 2006
++++ config/Makefile.in Fri May 12 15:38:05 2006
+@@ -682,7 +682,7 @@ install-data-hook: gdm.conf gdm.conf-cus
if test '!' -d $(DESTDIR)$(logdir); then \
$(mkinstalldirs) $(DESTDIR)$(logdir); \
+ chmod 755 $(DESTDIR)$(logdir); \
- chown root:root $(DESTDIR)$(logdir); \
+ chown root:wheel $(DESTDIR)$(logdir); \
- chmod 755 $(DESTDIR)$(logdir); \
fi
+ if test '!' -d $(DESTDIR)$(authdir); then \
diff --git a/x11/gdm/files/patch-configure b/x11/gdm/files/patch-configure
deleted file mode 100644
index ae54f1460b87..000000000000
--- a/x11/gdm/files/patch-configure
+++ /dev/null
@@ -1,25 +0,0 @@
---- configure.orig Wed Mar 29 13:51:40 2006
-+++ configure Wed Mar 29 14:15:56 2006
-@@ -22965,6 +22965,8 @@ _ACEOF
- cat confdefs.h >>conftest.$ac_ext
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
-+#include <sys/types.h>
-+#include <sys/socket.h>
- $ac_includes_default
- #include <$ac_header>
- _ACEOF
-@@ -32415,6 +32417,13 @@ case "$host" in
- XSESSION_SHELL=/bin/ksh
- SOUND_PROGRAM=/usr/bin/audioplay
- ;;
-+*freebsd*)
-+ GDM_USER_PATH="/bin:/usr/bin"
-+ HALT_COMMAND="/sbin/shutdown -p now;/usr/sbin/shutdown -p now"
-+ REBOOT_COMMAND="/sbin/shutdown -r now;/usr/sbin/shutdown -r now"
-+ SUSPEND_COMMAND="/usr/sbin/zzz"
-+ XSESSION_SHELL=/bin/sh
-+ ;;
- *)
- GDM_USER_PATH="/bin:/usr/bin"
- HALT_COMMAND="/usr/bin/poweroff;/sbin/poweroff;/sbin/shutdown -h now;/usr/sbin/shutdown -h now"
diff --git a/x11/gdm/files/patch-daemon_gdmconfig.c b/x11/gdm/files/patch-daemon_gdmconfig.c
deleted file mode 100644
index 9ebf10c997e1..000000000000
--- a/x11/gdm/files/patch-daemon_gdmconfig.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- daemon/gdmconfig.c.orig Thu Jan 5 16:57:06 2006
-+++ daemon/gdmconfig.c Thu Jan 5 16:57:44 2006
-@@ -39,6 +39,7 @@
- #include <fcntl.h>
- #include <sys/types.h>
- #include <sys/stat.h>
-+#include <sys/resource.h>
- #include <signal.h>
- #include <pwd.h>
- #include <grp.h>
diff --git a/x11/gdm/files/patch-daemon_server.c b/x11/gdm/files/patch-daemon_server.c
deleted file mode 100644
index 57f028bfd263..000000000000
--- a/x11/gdm/files/patch-daemon_server.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- daemon/server.c.orig Thu Jan 5 16:58:37 2006
-+++ daemon/server.c Thu Jan 5 16:58:46 2006
-@@ -29,6 +29,7 @@
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <sys/wait.h>
-+#include <sys/resource.h>
- #include <strings.h>
- #include <signal.h>
- #include <syslog.h>