summaryrefslogtreecommitdiff
path: root/x11/e17-module-uptime
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-10 12:49:20 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-10 12:49:20 +0000
commit7790cb7367ff44c3706b3a1ed33006610fb98c2e (patch)
tree11429e2b85ec6d8960d2f5e205550a8c8193f52e /x11/e17-module-uptime
parentAn E17 module which minimizes all windows in order to show the desktop. (diff)
An e17 module indicating the system's current uptime, load averages and number
of active users in a configurable interval. Author: Matthew Mullins WWW: http://www.enlightenment.org PR: ports/99368 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru>
Diffstat (limited to 'x11/e17-module-uptime')
-rw-r--r--x11/e17-module-uptime/Makefile36
-rw-r--r--x11/e17-module-uptime/distinfo3
-rw-r--r--x11/e17-module-uptime/files/patch-configure11
-rw-r--r--x11/e17-module-uptime/pkg-descr5
-rw-r--r--x11/e17-module-uptime/pkg-plist12
5 files changed, 67 insertions, 0 deletions
diff --git a/x11/e17-module-uptime/Makefile b/x11/e17-module-uptime/Makefile
new file mode 100644
index 000000000000..36d5f8af1395
--- /dev/null
+++ b/x11/e17-module-uptime/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: e17-module-uptime
+# Date created: 23 June 2006
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uptime
+PORTVERSION= 20060707
+CATEGORIES= x11
+MASTER_SITES= http://mbsd.msk.ru/dist/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= An e17 uptime and load average indicator module
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment-devel
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11/e17-module-uptime/distinfo b/x11/e17-module-uptime/distinfo
new file mode 100644
index 000000000000..851ccb9f799e
--- /dev/null
+++ b/x11/e17-module-uptime/distinfo
@@ -0,0 +1,3 @@
+MD5 (uptime-20060707.tar.bz2) = 83d8f63ee637ddcc3eb8cbff01e1a50d
+SHA256 (uptime-20060707.tar.bz2) = 9a4713e04faa55c309cf03d7f431b81ee6ddc36a238f696b7a132a0099926783
+SIZE (uptime-20060707.tar.bz2) = 275549
diff --git a/x11/e17-module-uptime/files/patch-configure b/x11/e17-module-uptime/files/patch-configure
new file mode 100644
index 000000000000..23658b3b18eb
--- /dev/null
+++ b/x11/e17-module-uptime/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Fri Jun 23 17:14:42 2006
++++ configure Fri Jun 23 17:14:53 2006
+@@ -23390,7 +23390,7 @@
+
+
+
+-MODULE_ARCH="$host_os-$host_cpu"
++MODULE_ARCH=""
+
+
+ cat >>confdefs.h <<_ACEOF
diff --git a/x11/e17-module-uptime/pkg-descr b/x11/e17-module-uptime/pkg-descr
new file mode 100644
index 000000000000..fc16d8c5b3b8
--- /dev/null
+++ b/x11/e17-module-uptime/pkg-descr
@@ -0,0 +1,5 @@
+An e17 module indicating the system's current uptime, load averages and number
+of active users in a configurable interval.
+
+Author: Matthew Mullins
+WWW: http://www.enlightenment.org
diff --git a/x11/e17-module-uptime/pkg-plist b/x11/e17-module-uptime/pkg-plist
new file mode 100644
index 000000000000..9e5d90c0caf8
--- /dev/null
+++ b/x11/e17-module-uptime/pkg-plist
@@ -0,0 +1,12 @@
+lib/enlightenment/modules/uptime/module.a
+lib/enlightenment/modules/uptime/module.eap
+lib/enlightenment/modules/uptime/module.la
+lib/enlightenment/modules/uptime/module.so
+lib/enlightenment/modules/uptime/uptime.edj
+%%NLS%%share/locale/bg/LC_MESSAGES/uptime.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/uptime.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/uptime.mo
+%%NLS%%share/locale/it/LC_MESSAGES/uptime.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/uptime.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/uptime.mo
+@dirrm lib/enlightenment/modules/uptime