summaryrefslogtreecommitdiff
path: root/x11/cnslock/Makefile
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2003-04-10 14:29:39 +0000
committerMax Khon <fjoe@FreeBSD.org>2003-04-10 14:29:39 +0000
commit9cdac8966d3cdc165e02f40fd40061edd4d42a1b (patch)
tree154d0783d9cf058b10e5a261c54356ac30b67f92 /x11/cnslock/Makefile
parentNew port: WMxmms (diff)
New port: cnslock
Cnslock is a dock application (dockapp) which provides a visual indication of the states of the three "lock" buttons (caps, num, and scroll). It should be especially useful for people who own a wireless keyboard with no leds on it, and thus have difficulty keeping track of "lock" states. Submitted by: Alexey Dokuchaev
Diffstat (limited to 'x11/cnslock/Makefile')
-rw-r--r--x11/cnslock/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11/cnslock/Makefile b/x11/cnslock/Makefile
new file mode 100644
index 000000000000..39b48e6cbf5e
--- /dev/null
+++ b/x11/cnslock/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: cnslock
+# Date created: 10 May 2003
+# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cnslock
+PORTVERSION= 1.02
+CATEGORIES= x11 windowmaker
+MASTER_SITES= http://www.dockapps.com/download.php/id/181/ \
+ ftp://ftp.nsu.ru/tmp/
+
+MAINTAINER= danfe@regency.nsu.ru
+COMMENT= A visual indicator of the states of the three "lock" buttons
+
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+USE_X_PREFIX= yes
+USE_XPM= yes
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>