summaryrefslogtreecommitdiff
path: root/x11-wm/openbox/Makefile
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-11-20 15:17:44 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-11-20 15:17:44 +0000
commit2d3d0f060880ef1de4759b541a04f4f066d8bb62 (patch)
tree9dab124b5187ff8223f99ae8075cd85dba3580fd /x11-wm/openbox/Makefile
parent- The tarball has been rerolled, because the URL of the (diff)
Attempt to create and delete share/gnome/wm-properties/.
Submitted by: Darren "igla" of batterybackups.net (also noticed by Andreas Semborg) Install header files where they can be found during compilation of obconf. This fixes the problem addressed by Tim Bishop in PR 58836, but in a different way.
Diffstat (limited to '')
-rw-r--r--x11-wm/openbox/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/x11-wm/openbox/Makefile b/x11-wm/openbox/Makefile
index 5cdf303ba1b5..b32a39928717 100644
--- a/x11-wm/openbox/Makefile
+++ b/x11-wm/openbox/Makefile
@@ -66,8 +66,8 @@ pre-install:
.for ii in openbox/xdg/openbox openbox/xdg openbox
${ECHO_CMD} @dirrm etc/${ii} >> ${PLIST}
.endfor
-.for ii in openbox/3.0 3.0
- ${ECHO_CMD} @dirrm include/${ii} >> ${PLIST}
+.for ii in include/openbox share/gnome/wm-properties
+ ${ECHO_CMD} @dirrm ${ii} >> ${PLIST}
.endfor
.for ii in la lai so so.1
${ECHO_CMD} lib/libobparser.${ii} >> ${PLIST}
@@ -81,10 +81,10 @@ pre-install:
.endif
do-install:
- ${MKDIR} ${DATADIR} ${PREFIX}/etc/openbox/xdg/openbox \
- ${PREFIX}/include/openbox/3.0
+ ${MKDIR} ${DATADIR} ${PREFIX}/share/gnome/wm-properties \
+ ${PREFIX}/etc/openbox/xdg/openbox ${PREFIX}/include/openbox
.for ii in parser/parse render/theme render/render
- ${INSTALL_DATA} ${WRKSRC}/${ii}.h ${PREFIX}/include/openbox/3.0
+ ${INSTALL_DATA} ${WRKSRC}/${ii}.h ${PREFIX}/include/openbox
.endfor
.for ii in parser render
${INSTALL_DATA} ${WRKSRC}/${ii}/ob${ii}-3.0.pc \