summaryrefslogtreecommitdiff
path: root/x11-wm/fluxter/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2003-08-19 23:03:23 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2003-08-19 23:03:23 +0000
commitf5fc49dc7e7f9cf03bb3be4f6426921ca910ad0c (patch)
tree605b7fd2c30e6d4f270736f04884d416301feae9 /x11-wm/fluxter/Makefile
parentUpdate to 3.02.07a: fix more bugs. (diff)
fluxter is a newer incarnation of bbpager, which is like the name suggests a
pager tool for Blackbox. The major changes to bbpager are: - Accesses fluxbox configuration files, e.g. in ~/.fluxbox, rather than in blackbox directories. - Default styles come from the fluxbox configuration. Without customization it will track the look of the current theme. - The configuration files have been renamed to fluxter.bb (used in a fluxbox environment) and fluxter.nobb (used in a non-fluxbox environment). These files should go in fluxbox configuration directories, such as ~/.fluxbox. - The X resource entries in the configuration files use fluxter as a label, rather than bbpager. - Per-workspace wallpaper changing is supported by the addition of per-workspace rootCommand configuration entries. For example: fluxter.workspace0.rootCommand: Esetroot /usr/share/pixmaps/bg1.png fluxter.workspace1.rootCommand: Esetroot /usr/share/pixmaps/bg2.png fluxter.workspace2.rootCommand: Esetroot /usr/share/pixmaps/bg3.png WWW: http://benedict.isomedia.com/homes/stevencooper/projects/fluxter.html
Diffstat (limited to 'x11-wm/fluxter/Makefile')
-rw-r--r--x11-wm/fluxter/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-wm/fluxter/Makefile b/x11-wm/fluxter/Makefile
new file mode 100644
index 000000000000..c7b62145bbe8
--- /dev/null
+++ b/x11-wm/fluxter/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: fluxter
+# Date created: 18 Aug 2003
+# Whom: Adam Weinberger
+#
+# $FreeBSD$
+#
+
+PORTNAME= fluxter
+PORTVERSION= 0.1.0
+CATEGORIES= x11-wm
+MASTER_SITES= http://benedict.isomedia.com/homes/stevencooper/files/
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Dekstop pager for the Fluxbox Slit
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|/fluxbox|/${PORTNAME}|g" \
+ ${WRKSRC}/Makefile.in ${WRKSRC}/data/README.fluxter \
+ ${WRKSRC}/data/Makefile.in
+
+.include <bsd.port.mk>