summaryrefslogtreecommitdiff
path: root/x11-wm/afterstep/Makefile
diff options
context:
space:
mode:
authorJames FitzGibbon <jfitz@FreeBSD.org>1996-08-27 17:49:06 +0000
committerJames FitzGibbon <jfitz@FreeBSD.org>1996-08-27 17:49:06 +0000
commit74fbae9b0f6b2108b78672328c547c72592d92c3 (patch)
tree77a7fa69f26abd90408cd9d5cd35be4fcf97528c /x11-wm/afterstep/Makefile
parentmaster locations changed again (diff)
Fixed incorrect use of INSTALL_ aliases in Makefile
Diffstat (limited to 'x11-wm/afterstep/Makefile')
-rw-r--r--x11-wm/afterstep/Makefile23
1 files changed, 15 insertions, 8 deletions
diff --git a/x11-wm/afterstep/Makefile b/x11-wm/afterstep/Makefile
index 68bb442c3070..66cce059035b 100644
--- a/x11-wm/afterstep/Makefile
+++ b/x11-wm/afterstep/Makefile
@@ -1,13 +1,13 @@
# New ports collection makefile for: afterstep
-# Version required: 0.98b27
+# Version required: 0.98b30
# Date created: 17 July 96
# Whom: james@bdd.net
#
-# $Id: Makefile,v 1.6 1996/08/20 10:57:38 jfitz Exp $
+# $Id: Makefile,v 1.7 1996/08/24 15:19:15 jfitz Exp $
#
-DISTNAME= as-b27
-PKGNAME= afterstep-0.98b27
+DISTNAME= as-b30
+PKGNAME= afterstep-0.98b30
CATEGORIES+= x11
MASTER_SITES= ftp://oak.sfasu.edu/pub/AfterStep/
@@ -17,14 +17,21 @@ LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
RUN_DEPENDS= fvwm:${PORTSDIR}/x11/fvwm
USE_X11= yes
-WRKSRC= ${WRKDIR}/AfterStep-0.98aBETA27
+WRKSRC= ${WRKDIR}/AfterStep-0.98aBETA30
pre-build:
@cd ${WRKSRC}; sh MakeMakefiles
post-install:
- @mkdir -p ${PREFIX}/include/X11/pixmaps
- @cp ${WRKSRC}/icons/*.xpm ${PREFIX}/include/X11/pixmaps
- @cp ${WRKSRC}/icons/8bit/*.xpm ${PREFIX}/include/X11/pixmaps
+ @mkdir -p ${PREFIX}/lib/X11/afterstep/backgrounds/
+ ${INSTALL_DATA} ${WRKSRC}/backgrounds/* ${PREFIX}/lib/X11/afterstep/backgrounds/
+ @mkdir -p ${PREFIX}/lib/X11/afterstep/sounds/
+ ${INSTALL_DATA} ${WRKSRC}/sounds/* ${PREFIX}/lib/X11/afterstep/sounds/
+ ${INSTALL_DATA} ${WRKSRC}/icons/*.xpm ${PREFIX}/include/X11/pixmaps/
+ ${INSTALL_DATA} ${WRKSRC}/icons/8bit/*.xpm ${PREFIX}/include/X11/pixmaps/
+ @mkdir -p ${PREFIX}/lib/X11/afterstep/doc/
+ for file in CHANGES README README.8bit README.gradient mini-faq; do \
+ ${INSTALL_DATA} ${WRKSRC}/$$file ${PREFIX}/lib/X11/afterstep/doc/; \
+ done
.include <bsd.port.mk>