summaryrefslogtreecommitdiff
path: root/x11-wm/afterstep/Makefile
diff options
context:
space:
mode:
authorBill Fumerola <billf@FreeBSD.org>1999-01-17 03:03:44 +0000
committerBill Fumerola <billf@FreeBSD.org>1999-01-17 03:03:44 +0000
commit3fc856a44254eb87900e51c9551083087d043565 (patch)
treee418c8e2a86e4e832050b28d328049f02b0ede9d /x11-wm/afterstep/Makefile
parentUpgrade from 3.4 to 3.7. (diff)
Complete the AfterStep division between Classic, Stable, and Devel.
Updated MASTER_SITE mirrors and made all appropriate upgrade changes. Add the Afterstep virtual category while I'm here. Provoked by: asami, (ports/9324) Kris Kennaway <kkennawa@physics.adelaide.edu.au>
Diffstat (limited to 'x11-wm/afterstep/Makefile')
-rw-r--r--x11-wm/afterstep/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/x11-wm/afterstep/Makefile b/x11-wm/afterstep/Makefile
index 1c6515395c27..ed30871041aa 100644
--- a/x11-wm/afterstep/Makefile
+++ b/x11-wm/afterstep/Makefile
@@ -3,13 +3,16 @@
# Date created: October 29th 1996
# Whom: jfitz@FreeBSD.ORG
#
-# $Id: Makefile,v 1.24 1999/01/10 14:54:27 simokawa Exp $
+# $Id: Makefile,v 1.25 1999/01/11 05:03:10 steve Exp $
#
DISTNAME= AfterStep-1.0
PKGNAME= afterstep-1.0
-CATEGORIES= x11-wm
+CATEGORIES= x11-wm afterstep
MASTER_SITES= ftp://ftp.afterstep.org/stable/archives/ \
+ ftp://ftp.digex.net/pub/os/wm/AfterStep/stable/archives/ \
+ ftp://ftp.alpha1.net/pub/mirrors/ftp.afterstep.org/stable/archives/ \
+ ftp://ftp.starshadow.com/pub/afterstep/stable/archives/ \
ftp://ftp.cs.tu-berlin.de/pub/X/afterstep/
MAINTAINER= jfitz@FreeBSD.ORG
@@ -29,19 +32,19 @@ SRCDIRS= afterstep \
post-patch:
@ for i in ${SRCDIRS}; do \
cd ${WRKSRC}/$$i; \
- mv Imakefile Imakefile.orig; \
- sed -e 's/#ifdef AlphaArchitecture/#if defined(AlphaArchitecture) \&\& !defined(FreeBSDArchitecture)/' < Imakefile.orig > Imakefile; \
+ ${MV} Imakefile Imakefile.orig; \
+ ${SED} -e 's/#ifdef AlphaArchitecture/#if defined(AlphaArchitecture) \&\& !defined(FreeBSDArchitecture)/' < Imakefile.orig > Imakefile; \
done
pre-build:
@ cd ${WRKSRC}; sh MakeMakefiles
-post-install:
- @ ${MKDIR} -p ${PREFIX}/lib/X11/afterstep/backgrounds/
+post-install:
+ @ ${MKDIR} ${PREFIX}/lib/X11/afterstep/backgrounds/
${INSTALL_DATA} ${WRKSRC}/backgrounds/* ${PREFIX}/lib/X11/afterstep/backgrounds/
- @ ${MKDIR} -p ${PREFIX}/lib/X11/afterstep/sounds/
+ @ ${MKDIR} ${PREFIX}/lib/X11/afterstep/sounds/
${INSTALL_DATA} ${WRKSRC}/sounds/* ${PREFIX}/lib/X11/afterstep/sounds/
- @ ${MKDIR} -p ${PREFIX}/include/X11/pixmaps/
+ @ ${MKDIR} ${PREFIX}/include/X11/pixmaps/
.if defined(USE_HICOLOR_ICONS)
${INSTALL_DATA} ${WRKSRC}/icons/*.xpm ${PREFIX}/include/X11/pixmaps/
.else
@@ -55,7 +58,7 @@ post-install:
done
${INSTALL_DATA} ${WRKSRC}/icons/8bit/*.xpm ${PREFIX}/include/X11/pixmaps/
.endif
- @ ${MKDIR} -p ${PREFIX}/lib/X11/afterstep/doc/
+ @ ${MKDIR} ${PREFIX}/lib/X11/afterstep/doc/
@for file in CHANGES CREDITS README README.8bit INSTALL FAQ module-interface.txt; do \
${INSTALL_DATA} ${WRKSRC}/$$file ${PREFIX}/lib/X11/afterstep/doc/; \
done