summaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-07-09 17:43:11 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-07-09 17:43:11 +0000
commit9e5632dd661f75b5801706e55659a4da501e49b5 (patch)
tree1a0770d8cc1771f94f7777b9a986bb87029c35d9 /x11-toolkits
parentAllow to install and use 3rd party packages in X11BASE. (diff)
Apply a big libtool patch to allow porters to use the libtool installed by
the libtoolX ports instead of the one included with each port. Ports that set USE_LIBTOOL_VER=X will now use the ports version of libtool instead of the included version. To restore previous behavior, use the new macro, USE_INC_LIBTOOL_VER. Both macros accept the same argument: a libtool version. For example, to use the ports version of libtool-1.5, add the following to your Makefile: USE_LIBTOOL_VER= 15 To use the included version of libtool with extra hacks provided by libtool-1.5, add the following to your Makefile: USE_INC_LIBTOOL_VER= 15 With this change, ports that had to add additional libtool hacks to prevent .la files from being installed or to fix certain threading issues can now delete those hacks (after appropriate testing, of course). PR: 63944 Based on work by:eik and marcus Approved by: ade (autotools maintainer) Tested by: kris on pointyhat Bound to be hidden problems: You bet
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/bakery/Makefile2
-rw-r--r--x11-toolkits/bakery_gnomeui/Makefile2
-rw-r--r--x11-toolkits/eel2/Makefile2
-rw-r--r--x11-toolkits/fox-devel/Makefile2
-rw-r--r--x11-toolkits/fox14/Makefile2
-rw-r--r--x11-toolkits/freeglut/Makefile2
-rw-r--r--x11-toolkits/fxscintilla/Makefile2
-rw-r--r--x11-toolkits/gal/Makefile2
-rw-r--r--x11-toolkits/gal2/Makefile2
-rw-r--r--x11-toolkits/gdl/Makefile2
-rw-r--r--x11-toolkits/gevas/Makefile2
-rw-r--r--x11-toolkits/gtk--/Makefile2
-rw-r--r--x11-toolkits/gtk--2/Makefile2
-rw-r--r--x11-toolkits/gtk12/Makefile2
-rw-r--r--x11-toolkits/gtkextra/Makefile2
-rw-r--r--x11-toolkits/gtkextra2/Makefile2
-rw-r--r--x11-toolkits/gtkglarea/Makefile2
-rw-r--r--x11-toolkits/gtkglarea2/Makefile2
-rw-r--r--x11-toolkits/gtkglext/Makefile2
-rw-r--r--x11-toolkits/gtkmm12/Makefile2
-rw-r--r--x11-toolkits/gtkmm20/Makefile2
-rw-r--r--x11-toolkits/gtkmm24/Makefile2
-rw-r--r--x11-toolkits/gtkmm30/Makefile2
-rw-r--r--x11-toolkits/gtksourceview/Makefile2
-rw-r--r--x11-toolkits/guile-gnome/Makefile2
-rw-r--r--x11-toolkits/guile-gtk/Makefile2
-rw-r--r--x11-toolkits/lesstif/Makefile2
-rw-r--r--x11-toolkits/libXmu/Makefile2
-rw-r--r--x11-toolkits/libbonoboui/Makefile2
-rw-r--r--x11-toolkits/libbonobouimm/Makefile2
-rw-r--r--x11-toolkits/libgail-gnome/Makefile2
-rw-r--r--x11-toolkits/libgnomeprintui/Makefile2
-rw-r--r--x11-toolkits/libgnomeui/Makefile2
-rw-r--r--x11-toolkits/libgnomeuimm/Makefile2
-rw-r--r--x11-toolkits/libgtkeditor/Makefile2
-rw-r--r--x11-toolkits/libpanelappletmm/Makefile2
-rw-r--r--x11-toolkits/libwnck/Makefile2
-rw-r--r--x11-toolkits/libxfce4gui/Makefile2
-rw-r--r--x11-toolkits/libzvt/Makefile2
-rw-r--r--x11-toolkits/movingmotif/Makefile2
-rw-r--r--x11-toolkits/neXtaw/Makefile2
-rw-r--r--x11-toolkits/notif2/Makefile2
-rw-r--r--x11-toolkits/paragui-devel/Makefile2
-rw-r--r--x11-toolkits/paragui/Makefile2
-rw-r--r--x11-toolkits/py-gnome/Makefile2
-rw-r--r--x11-toolkits/py-gnome2/Makefile2
-rw-r--r--x11-toolkits/sdl_gui/Makefile2
-rw-r--r--x11-toolkits/vdk/Makefile2
-rw-r--r--x11-toolkits/vdkbuilder/Makefile2
-rw-r--r--x11-toolkits/vte/Makefile2
50 files changed, 50 insertions, 50 deletions
diff --git a/x11-toolkits/bakery/Makefile b/x11-toolkits/bakery/Makefile
index cade41c469a7..400bb408a0bc 100644
--- a/x11-toolkits/bakery/Makefile
+++ b/x11-toolkits/bakery/Makefile
@@ -24,7 +24,7 @@ USE_X_PREFIX= yes
USE_PERL5= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intltool gnometarget
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/x11-toolkits/bakery_gnomeui/Makefile b/x11-toolkits/bakery_gnomeui/Makefile
index fed55ae1430d..0bfb489cbc4c 100644
--- a/x11-toolkits/bakery_gnomeui/Makefile
+++ b/x11-toolkits/bakery_gnomeui/Makefile
@@ -22,7 +22,7 @@ USE_X_PREFIX= yes
USE_PERL5= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnometarget
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/x11-toolkits/eel2/Makefile b/x11-toolkits/eel2/Makefile
index ae1baff2fc00..4492671abbf6 100644
--- a/x11-toolkits/eel2/Makefile
+++ b/x11-toolkits/eel2/Makefile
@@ -20,7 +20,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack gnomehier gnomevfs2 gail libgnomeui
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-shared --enable-static
diff --git a/x11-toolkits/fox-devel/Makefile b/x11-toolkits/fox-devel/Makefile
index 17804a0fbacf..1267082bcf08 100644
--- a/x11-toolkits/fox-devel/Makefile
+++ b/x11-toolkits/fox-devel/Makefile
@@ -32,7 +32,7 @@ PLIST_SUB+= MAJORVER=${MAJORVER} SHVER=${SHVER}
USE_GNOME= lthack
USE_GL= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 13
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-opengl --with-x --enable-threadsafe
INSTALLS_SHLIB= yes
diff --git a/x11-toolkits/fox14/Makefile b/x11-toolkits/fox14/Makefile
index 17804a0fbacf..1267082bcf08 100644
--- a/x11-toolkits/fox14/Makefile
+++ b/x11-toolkits/fox14/Makefile
@@ -32,7 +32,7 @@ PLIST_SUB+= MAJORVER=${MAJORVER} SHVER=${SHVER}
USE_GNOME= lthack
USE_GL= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 13
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-opengl --with-x --enable-threadsafe
INSTALLS_SHLIB= yes
diff --git a/x11-toolkits/freeglut/Makefile b/x11-toolkits/freeglut/Makefile
index fdd096e0e2f8..5c5b2a185131 100644
--- a/x11-toolkits/freeglut/Makefile
+++ b/x11-toolkits/freeglut/Makefile
@@ -17,7 +17,7 @@ COMMENT= An alternative to the OpenGL Utility Toolkit (GLUT) library
USE_AUTOMAKE_VER= 14
USE_AUTOCONF_VER= 213
USE_AUTOHEADER_VER= 213
-USE_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 13
HAS_CONFIGURE= yes
INSTALLS_SHLIB= yes
USE_XLIB= yes
diff --git a/x11-toolkits/fxscintilla/Makefile b/x11-toolkits/fxscintilla/Makefile
index 477b30095047..41b2be1d8f99 100644
--- a/x11-toolkits/fxscintilla/Makefile
+++ b/x11-toolkits/fxscintilla/Makefile
@@ -16,7 +16,7 @@ COMMENT= A Fox toolkit reimplementation of Scintilla editing widget
LIB_DEPENDS= FOX-1.0.0:${PORTSDIR}/x11-toolkits/fox
-USE_LIBTOOL_VER= 15
+USE_INC_LIBTOOL_VER= 15
CONFIGURE_ARGS= --enable-shared
INSTALLS_SHLIB= yes
diff --git a/x11-toolkits/gal/Makefile b/x11-toolkits/gal/Makefile
index 5814154d7e4e..c4fdf3f829cc 100644
--- a/x11-toolkits/gal/Makefile
+++ b/x11-toolkits/gal/Makefile
@@ -26,7 +26,7 @@ USE_GNOME= gnomehack gnomeprefix gnomehier libglade gnomevfs
USE_ICONV= yes
GNOME_HTML_DIR= ${PREFIX}/share/doc/gal
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
CONFIGURE_ARGS= --enable-static --with-libiconv
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/x11-toolkits/gal2/Makefile b/x11-toolkits/gal2/Makefile
index 9b35e2033222..4f9566ed128c 100644
--- a/x11-toolkits/gal2/Makefile
+++ b/x11-toolkits/gal2/Makefile
@@ -24,7 +24,7 @@ USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix gnomehier libgnomeui libgnomeprintui
GNOME_HTML_DIR= ${PREFIX}/share/doc/gal2
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
CONFIGURE_ARGS= --enable-static --with-libiconv
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/x11-toolkits/gdl/Makefile b/x11-toolkits/gdl/Makefile
index 598507ea2ae6..95f1872694a5 100644
--- a/x11-toolkits/gdl/Makefile
+++ b/x11-toolkits/gdl/Makefile
@@ -18,7 +18,7 @@ COMMENT= Components intended to be shared between GNOME development tools
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack libgnomeui
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/x11-toolkits/gevas/Makefile b/x11-toolkits/gevas/Makefile
index 4af17e4fb56d..4206de73e3e1 100644
--- a/x11-toolkits/gevas/Makefile
+++ b/x11-toolkits/gevas/Makefile
@@ -18,7 +18,7 @@ COMMENT= GTK+ bindings for Evas canvas library
LIB_DEPENDS= evas.6:${PORTSDIR}/graphics/evas
USE_GNOME= gtk12
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
post-install:
diff --git a/x11-toolkits/gtk--/Makefile b/x11-toolkits/gtk--/Makefile
index 7258f8bcdf2c..b86faaba5b9f 100644
--- a/x11-toolkits/gtk--/Makefile
+++ b/x11-toolkits/gtk--/Makefile
@@ -23,7 +23,7 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gtk12
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-static=yes \
diff --git a/x11-toolkits/gtk--2/Makefile b/x11-toolkits/gtk--2/Makefile
index bf1268a579fc..cc080f7dc34b 100644
--- a/x11-toolkits/gtk--2/Makefile
+++ b/x11-toolkits/gtk--2/Makefile
@@ -24,7 +24,7 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
LATEST_LINK= gtkmm2
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
USE_GNOME= gnomehack lthack gtk20
diff --git a/x11-toolkits/gtk12/Makefile b/x11-toolkits/gtk12/Makefile
index 8efe623af661..ac319559cbb9 100644
--- a/x11-toolkits/gtk12/Makefile
+++ b/x11-toolkits/gtk12/Makefile
@@ -19,7 +19,7 @@ COMMENT= Gimp Toolkit for X11 GUI (previous stable version)
USE_X_PREFIX= yes
USE_PERL5= yes
USE_GNOME= glib12
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
LIBTOOLFLAGS= --disable-ltlibs --release-suffix
CONFIGURE_ARGS= --includedir=${PREFIX}/include/gtk12 --with-native-locale \
diff --git a/x11-toolkits/gtkextra/Makefile b/x11-toolkits/gtkextra/Makefile
index 8c4d3821bd84..86bb98223610 100644
--- a/x11-toolkits/gtkextra/Makefile
+++ b/x11-toolkits/gtkextra/Makefile
@@ -18,7 +18,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= A useful widget set complementary to GTK+
USE_X_PREFIX= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_GNOME= gtk12
USE_GMAKE= yes
INSTALLS_SHLIB= yes
diff --git a/x11-toolkits/gtkextra2/Makefile b/x11-toolkits/gtkextra2/Makefile
index 8c4d3821bd84..86bb98223610 100644
--- a/x11-toolkits/gtkextra2/Makefile
+++ b/x11-toolkits/gtkextra2/Makefile
@@ -18,7 +18,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= A useful widget set complementary to GTK+
USE_X_PREFIX= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_GNOME= gtk12
USE_GMAKE= yes
INSTALLS_SHLIB= yes
diff --git a/x11-toolkits/gtkglarea/Makefile b/x11-toolkits/gtkglarea/Makefile
index 86cda5547663..62d4dba08723 100644
--- a/x11-toolkits/gtkglarea/Makefile
+++ b/x11-toolkits/gtkglarea/Makefile
@@ -19,7 +19,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_X_PREFIX= yes
USE_GL= yes
USE_GNOME= gnometarget gtk12 lthack
-USE_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib -lstdc++ ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --with-lib-GL
diff --git a/x11-toolkits/gtkglarea2/Makefile b/x11-toolkits/gtkglarea2/Makefile
index f06bb4fe7c47..7b37e8f05105 100644
--- a/x11-toolkits/gtkglarea2/Makefile
+++ b/x11-toolkits/gtkglarea2/Makefile
@@ -21,7 +21,7 @@ USE_X_PREFIX= yes
USE_GNOME= gnomehack gtk20
USE_BZIP2= yes
USE_GL= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --with-lib-GL
diff --git a/x11-toolkits/gtkglext/Makefile b/x11-toolkits/gtkglext/Makefile
index c22605588007..99fac4824c79 100644
--- a/x11-toolkits/gtkglext/Makefile
+++ b/x11-toolkits/gtkglext/Makefile
@@ -20,7 +20,7 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack gtk20
USE_GL= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_GMAKE= yes
INSTALLS_SHLIB= yes
diff --git a/x11-toolkits/gtkmm12/Makefile b/x11-toolkits/gtkmm12/Makefile
index 7258f8bcdf2c..b86faaba5b9f 100644
--- a/x11-toolkits/gtkmm12/Makefile
+++ b/x11-toolkits/gtkmm12/Makefile
@@ -23,7 +23,7 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gtk12
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-static=yes \
diff --git a/x11-toolkits/gtkmm20/Makefile b/x11-toolkits/gtkmm20/Makefile
index bf1268a579fc..cc080f7dc34b 100644
--- a/x11-toolkits/gtkmm20/Makefile
+++ b/x11-toolkits/gtkmm20/Makefile
@@ -24,7 +24,7 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
LATEST_LINK= gtkmm2
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
USE_GNOME= gnomehack lthack gtk20
diff --git a/x11-toolkits/gtkmm24/Makefile b/x11-toolkits/gtkmm24/Makefile
index 71002b7abf60..6a6fadfa494d 100644
--- a/x11-toolkits/gtkmm24/Makefile
+++ b/x11-toolkits/gtkmm24/Makefile
@@ -26,7 +26,7 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GCC= 3.3
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
USE_GNOME= gnomehack lthack gtk20
diff --git a/x11-toolkits/gtkmm30/Makefile b/x11-toolkits/gtkmm30/Makefile
index bf1268a579fc..cc080f7dc34b 100644
--- a/x11-toolkits/gtkmm30/Makefile
+++ b/x11-toolkits/gtkmm30/Makefile
@@ -24,7 +24,7 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
LATEST_LINK= gtkmm2
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
USE_GNOME= gnomehack lthack gtk20
diff --git a/x11-toolkits/gtksourceview/Makefile b/x11-toolkits/gtksourceview/Makefile
index a8faf425ddf5..b807956224ff 100644
--- a/x11-toolkits/gtksourceview/Makefile
+++ b/x11-toolkits/gtksourceview/Makefile
@@ -18,7 +18,7 @@ COMMENT= A text widget that adds syntax highlighting to the GtkTextView widget
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
USE_GNOME= gnomeprefix gnomehack lthack libgnome libgnomeprintui
CONFIGURE_ARGS= --enable-compile-warnings=no
diff --git a/x11-toolkits/guile-gnome/Makefile b/x11-toolkits/guile-gnome/Makefile
index cb2c5ce16e47..000661e93c8e 100644
--- a/x11-toolkits/guile-gnome/Makefile
+++ b/x11-toolkits/guile-gnome/Makefile
@@ -19,7 +19,7 @@ COMMENT= Guile binding library for GNOME
LIB_DEPENDS= guilegtk-1.2.0:${PORTSDIR}/x11-toolkits/guile-gtk
USE_X_PREFIX= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_GNOME= gnomeprefix bonobo gtkhtml libglade
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --with-bonobo --with-gtkhtml --without-gal \
diff --git a/x11-toolkits/guile-gtk/Makefile b/x11-toolkits/guile-gtk/Makefile
index d67c088e63e2..fe35a502203a 100644
--- a/x11-toolkits/guile-gtk/Makefile
+++ b/x11-toolkits/guile-gtk/Makefile
@@ -24,7 +24,7 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gtk12 gnometarget
USE_REINPLACE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/x11-toolkits/lesstif/Makefile b/x11-toolkits/lesstif/Makefile
index 754d53a9d6fb..514da4a238d8 100644
--- a/x11-toolkits/lesstif/Makefile
+++ b/x11-toolkits/lesstif/Makefile
@@ -20,7 +20,7 @@ WANT_AUTOMAKE_VER= 18
USE_AUTOCONF_VER= 259
USE_X_PREFIX= yes
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 13
LIBTOOLFILES= aclocal.m4 test/aclocal.m4
CONFIGURE_ARGS+= --enable-static --enable-shared --enable-production
CONFIGURE_ARGS+= --disable-build-Xlt --disable-build-Xbae
diff --git a/x11-toolkits/libXmu/Makefile b/x11-toolkits/libXmu/Makefile
index b564ed87cb26..69a1852d6f98 100644
--- a/x11-toolkits/libXmu/Makefile
+++ b/x11-toolkits/libXmu/Makefile
@@ -24,7 +24,7 @@ MTREE_FILE= /etc/mtree/BSD.x11-4.dist
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
CFLAGS+= -DMALLOC_0_RETURNS_NULL
INSTALLS_SHLIB= yes
USE_GNOME= gnomehack pkgconfig
diff --git a/x11-toolkits/libbonoboui/Makefile b/x11-toolkits/libbonoboui/Makefile
index 0c592141f6d9..7e7f0dff66ac 100644
--- a/x11-toolkits/libbonoboui/Makefile
+++ b/x11-toolkits/libbonoboui/Makefile
@@ -20,7 +20,7 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomehier intlhack lthack \
libgnomecanvas libgnome
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
diff --git a/x11-toolkits/libbonobouimm/Makefile b/x11-toolkits/libbonobouimm/Makefile
index ce56eadb6899..13988cede31b 100644
--- a/x11-toolkits/libbonobouimm/Makefile
+++ b/x11-toolkits/libbonobouimm/Makefile
@@ -24,7 +24,7 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomehack lthack gnomeprefix libbonoboui
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-static
diff --git a/x11-toolkits/libgail-gnome/Makefile b/x11-toolkits/libgail-gnome/Makefile
index 5ce92855134d..5f99c4ded8a7 100644
--- a/x11-toolkits/libgail-gnome/Makefile
+++ b/x11-toolkits/libgail-gnome/Makefile
@@ -19,7 +19,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
GNOME_DESKTOP_VERSION=2
USE_GNOME= gnomeprefix gnomehack gnomepanel atspi
CONFIGURE_ARGS= --enable-static
diff --git a/x11-toolkits/libgnomeprintui/Makefile b/x11-toolkits/libgnomeprintui/Makefile
index 726cd9c5ccf6..2b966383db59 100644
--- a/x11-toolkits/libgnomeprintui/Makefile
+++ b/x11-toolkits/libgnomeprintui/Makefile
@@ -26,7 +26,7 @@ USE_GNOME= gnomeprefix gnomehack libgnomeprint libgnomecanvas lthack \
intlhack
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_BISON= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/x11-toolkits/libgnomeui/Makefile b/x11-toolkits/libgnomeui/Makefile
index 1198d4fd97a4..cecbd610282b 100644
--- a/x11-toolkits/libgnomeui/Makefile
+++ b/x11-toolkits/libgnomeui/Makefile
@@ -25,7 +25,7 @@ USE_XPM= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack lthack gnomehier libbonoboui
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_BISON= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
diff --git a/x11-toolkits/libgnomeuimm/Makefile b/x11-toolkits/libgnomeuimm/Makefile
index 59f2735ffad0..608183754305 100644
--- a/x11-toolkits/libgnomeuimm/Makefile
+++ b/x11-toolkits/libgnomeuimm/Makefile
@@ -25,7 +25,7 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomehack libgnomeui
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-static
diff --git a/x11-toolkits/libgtkeditor/Makefile b/x11-toolkits/libgtkeditor/Makefile
index 95c2e4bec631..8b2255fbc801 100644
--- a/x11-toolkits/libgtkeditor/Makefile
+++ b/x11-toolkits/libgtkeditor/Makefile
@@ -24,7 +24,7 @@ USE_X_PREFIX= yes
USE_GNOME= gtk12
USE_GMAKE= yes
USE_PERL5_BUILD=yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CFLAGS+= -fPIC
diff --git a/x11-toolkits/libpanelappletmm/Makefile b/x11-toolkits/libpanelappletmm/Makefile
index cdd64ebdd6d0..603175bc7c47 100644
--- a/x11-toolkits/libpanelappletmm/Makefile
+++ b/x11-toolkits/libpanelappletmm/Makefile
@@ -24,7 +24,7 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnomepanel
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-static
diff --git a/x11-toolkits/libwnck/Makefile b/x11-toolkits/libwnck/Makefile
index b15bfb82a480..5dcc76e40ed6 100644
--- a/x11-toolkits/libwnck/Makefile
+++ b/x11-toolkits/libwnck/Makefile
@@ -23,7 +23,7 @@ USE_GMAKE= yes
USE_GNOME= gnomehack lthack gtk20
USE_BISON= yes
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/x11-toolkits/libxfce4gui/Makefile b/x11-toolkits/libxfce4gui/Makefile
index 662f5d14b293..c036aed6e0de 100644
--- a/x11-toolkits/libxfce4gui/Makefile
+++ b/x11-toolkits/libxfce4gui/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util
USE_GNOME= gtk20
USE_REINPLACE= yes
USE_X_PREFIX= yes
-USE_LIBTOOL_VER=15
+USE_INC_LIBTOOL_VER=15
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-xinerama
INSTALLS_SHLIB= yes
diff --git a/x11-toolkits/libzvt/Makefile b/x11-toolkits/libzvt/Makefile
index 00622ab4b32a..198be8ddcd65 100644
--- a/x11-toolkits/libzvt/Makefile
+++ b/x11-toolkits/libzvt/Makefile
@@ -22,7 +22,7 @@ USE_GMAKE= yes
USE_REINPLACE= yes
USE_BISON= yes
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_GNOME= gnomeprefix gnomehack gtk20 libartlgpl2
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/x11-toolkits/movingmotif/Makefile b/x11-toolkits/movingmotif/Makefile
index c86e919b1723..fe410ddd177e 100644
--- a/x11-toolkits/movingmotif/Makefile
+++ b/x11-toolkits/movingmotif/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Display scientific data as dynamic plot
USE_MOTIF= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
diff --git a/x11-toolkits/neXtaw/Makefile b/x11-toolkits/neXtaw/Makefile
index 9441652d1502..08c077c41bde 100644
--- a/x11-toolkits/neXtaw/Makefile
+++ b/x11-toolkits/neXtaw/Makefile
@@ -15,7 +15,7 @@ COMMENT= Athena Widgets with N*XTSTEP appearance
USE_X_PREFIX= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
LDFLAGS="-L${X11BASE}/lib"
diff --git a/x11-toolkits/notif2/Makefile b/x11-toolkits/notif2/Makefile
index f7ac0716eb39..504287bd6ff0 100644
--- a/x11-toolkits/notif2/Makefile
+++ b/x11-toolkits/notif2/Makefile
@@ -20,7 +20,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_X_PREFIX= yes
USE_GNOME= gtk12
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_GMAKE= yes
GTKVERSION= 1.2
diff --git a/x11-toolkits/paragui-devel/Makefile b/x11-toolkits/paragui-devel/Makefile
index 60616e2adf18..be8caf3e868c 100644
--- a/x11-toolkits/paragui-devel/Makefile
+++ b/x11-toolkits/paragui-devel/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= physfs-1.0.0:${PORTSDIR}/devel/physfs \
USE_X_PREFIX= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_SDL= sdl image ttf
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
diff --git a/x11-toolkits/paragui/Makefile b/x11-toolkits/paragui/Makefile
index 60616e2adf18..be8caf3e868c 100644
--- a/x11-toolkits/paragui/Makefile
+++ b/x11-toolkits/paragui/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= physfs-1.0.0:${PORTSDIR}/devel/physfs \
USE_X_PREFIX= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_SDL= sdl image ttf
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
diff --git a/x11-toolkits/py-gnome/Makefile b/x11-toolkits/py-gnome/Makefile
index 766b74d69d5a..ddca3c0e3d5c 100644
--- a/x11-toolkits/py-gnome/Makefile
+++ b/x11-toolkits/py-gnome/Makefile
@@ -24,7 +24,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_PYTHON= yes
USE_GNOME= gtkhtml gnometarget
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
LIBTOOLFILES= configure pygtk/configure
CONFIGURE_ARGS= --with-python=${PYTHON_CMD} \
--with-gnome-config=${X11BASE}/bin/gnome-config \
diff --git a/x11-toolkits/py-gnome2/Makefile b/x11-toolkits/py-gnome2/Makefile
index e7c7051f5391..17249b05bea8 100644
--- a/x11-toolkits/py-gnome2/Makefile
+++ b/x11-toolkits/py-gnome2/Makefile
@@ -26,7 +26,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_PYTHON= yes
USE_GNOME= gnomehack libgnomeprintui libgtkhtml gnomepanel libzvt nautilus2
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/x11-toolkits/sdl_gui/Makefile b/x11-toolkits/sdl_gui/Makefile
index aa51d2c2ef25..c0b08a2b188d 100644
--- a/x11-toolkits/sdl_gui/Makefile
+++ b/x11-toolkits/sdl_gui/Makefile
@@ -18,7 +18,7 @@ COMMENT= A Graphical User Interface library for SDL
USE_SDL= sdl image ttf
USE_REINPLACE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
INSTALLS_SHLIB= yes
diff --git a/x11-toolkits/vdk/Makefile b/x11-toolkits/vdk/Makefile
index 403400dadebb..785ed4c31153 100644
--- a/x11-toolkits/vdk/Makefile
+++ b/x11-toolkits/vdk/Makefile
@@ -19,7 +19,7 @@ USE_X_PREFIX= yes
WANT_GNOME= yes
USE_GNOME= gnometarget gtk20
USE_REINPLACE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib -lgnuregex ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --enable-opt=no --enable-doc-html=no
diff --git a/x11-toolkits/vdkbuilder/Makefile b/x11-toolkits/vdkbuilder/Makefile
index 8bdbc9ad99eb..c859a578519e 100644
--- a/x11-toolkits/vdkbuilder/Makefile
+++ b/x11-toolkits/vdkbuilder/Makefile
@@ -22,7 +22,7 @@ USE_X_PREFIX= yes
WANT_GNOME= yes
USE_GNOME= gnometarget gtk20
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-opt=no
diff --git a/x11-toolkits/vte/Makefile b/x11-toolkits/vte/Makefile
index a815c53b0aba..ed90fb93a774 100644
--- a/x11-toolkits/vte/Makefile
+++ b/x11-toolkits/vte/Makefile
@@ -21,7 +21,7 @@ USE_GMAKE= yes
USE_REINPLACE= yes
USE_BISON= yes
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_GNOME= gnomeprefix gnomehack lthack gtk20
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \