summaryrefslogtreecommitdiff
path: root/x11-toolkits/tktray
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-11-01 06:42:58 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-11-01 06:42:58 +0000
commit83236873eba55affaddde9db56231c687fa801be (patch)
tree0833c01b29e5d85ebf49f93fdfa26e04164e9759 /x11-toolkits/tktray
parent- Pass maintainership to submitter (diff)
Add port x11-toolkits/tktray:
Tktray is an extension that is able to create system tray icons. It follows http://www.freedesktop.org specifications when looking up the system tray manager. This protocol is supported by modern versions of KDE and Gnome panels, and by some other panel-like application. WWW: http://sw4me.com/wiki/Tktray Author: Anton Kovalenko <anton@sw4me.com>
Diffstat (limited to 'x11-toolkits/tktray')
-rw-r--r--x11-toolkits/tktray/Makefile36
-rw-r--r--x11-toolkits/tktray/distinfo3
-rw-r--r--x11-toolkits/tktray/pkg-descr7
-rw-r--r--x11-toolkits/tktray/pkg-plist4
4 files changed, 50 insertions, 0 deletions
diff --git a/x11-toolkits/tktray/Makefile b/x11-toolkits/tktray/Makefile
new file mode 100644
index 000000000000..40cd9921d030
--- /dev/null
+++ b/x11-toolkits/tktray/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: tktray
+# Date created: 14 October 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tktray
+PORTVERSION= 1.1
+CATEGORIES= x11-toolkits tk84
+MASTER_SITES= http://www.sw4me.com/ CSME
+DISTNAME= ${TKPKG}
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= System tray icon support
+
+LIB_DEPENDS= tk${USE_TK}.1:${PORTSDIR}/x11-toolkits/tk${USE_TK}
+
+USE_TK= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} --with-tk=${TK_LIBDIR} \
+ --with-tkinclude=${TK_INCLUDEDIR} --enable-shared
+CPPFLAGS= -I${TK_INCLUDEDIR}/generic -I${TCL_INCLUDEDIR}/generic
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}"
+TKPKG= ${PORTNAME}${PORTVERSION}
+PLIST_SUB= TKPKG=${TKPKG}
+USE_LDCONFIG= ${PREFIX}/lib/${TKPKG}
+MANN= ${PORTNAME}.n
+
+post-patch:
+ @${REINPLACE_CMD} -Ee '/^.+TCLLIBPATH/s#$$# \\#' ${WRKSRC}/Makefile.in
+
+post-install:
+ @${LN} -sf ${USE_LDCONFIG}/lib${TKPKG}.so ${USE_LDCONFIG}/lib${TKPKG}.so.0
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/tktray/distinfo b/x11-toolkits/tktray/distinfo
new file mode 100644
index 000000000000..1c9d9c863fd1
--- /dev/null
+++ b/x11-toolkits/tktray/distinfo
@@ -0,0 +1,3 @@
+MD5 (tktray1.1.tar.gz) = d033dd0cf47cb6205364868455e01394
+SHA256 (tktray1.1.tar.gz) = e4c4a8ad75eacbdf2a6950dd40249dfb82897d59b999afcc05c9587081c8926f
+SIZE (tktray1.1.tar.gz) = 109936
diff --git a/x11-toolkits/tktray/pkg-descr b/x11-toolkits/tktray/pkg-descr
new file mode 100644
index 000000000000..f27bb41990f9
--- /dev/null
+++ b/x11-toolkits/tktray/pkg-descr
@@ -0,0 +1,7 @@
+Tktray is an extension that is able to create system tray icons. It
+follows http://www.freedesktop.org specifications when looking up the
+system tray manager. This protocol is supported by modern versions of
+KDE and Gnome panels, and by some other panel-like application.
+
+WWW: http://sw4me.com/wiki/Tktray
+Author: Anton Kovalenko <anton@sw4me.com>
diff --git a/x11-toolkits/tktray/pkg-plist b/x11-toolkits/tktray/pkg-plist
new file mode 100644
index 000000000000..7d2e230352e2
--- /dev/null
+++ b/x11-toolkits/tktray/pkg-plist
@@ -0,0 +1,4 @@
+lib/%%TKPKG%%/lib%%TKPKG%%.so
+lib/%%TKPKG%%/lib%%TKPKG%%.so.0
+lib/%%TKPKG%%/pkgIndex.tcl
+@dirrm lib/%%TKPKG%%