summaryrefslogtreecommitdiff
path: root/x11-toolkits/py-qt/files/patch-qt::Makefile.in
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-04-25 15:42:30 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-04-25 15:42:30 +0000
commitabd1119acd66a67e13ae57d1e86ce65b54887194 (patch)
treefdfae8db92d2f93dceeeaff544eb60f1b9966364 /x11-toolkits/py-qt/files/patch-qt::Makefile.in
parentUnbreak after PERL_CONFIGURE change. (diff)
- Unbreak after USE_LIBTOOL change;
- don't build/install useless static library (useless because we want Python module, which is by definition shared object). Not only this reduces the package size and saves disk space, but also halves the time necessary to compile the port; - don't install useless .la file; - remove version number from the shared object - it doesn't serve any meaningful purpose.
Diffstat (limited to '')
-rw-r--r--x11-toolkits/py-qt/files/patch-qt::Makefile.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/x11-toolkits/py-qt/files/patch-qt::Makefile.in b/x11-toolkits/py-qt/files/patch-qt::Makefile.in
new file mode 100644
index 000000000000..21bf550afb7b
--- /dev/null
+++ b/x11-toolkits/py-qt/files/patch-qt::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- qt/Makefile.in 2002/04/25 14:32:42 1.1
++++ qt/Makefile.in 2002/04/25 14:36:47
+@@ -109,7 +109,7 @@
+
+ lib_LTLIBRARIES = libqtcmodule.la
+ libqtcmodule_la_SOURCES = $(PYQT_SOURCES)
+-libqtcmodule_la_LDFLAGS = -release 2.5
++libqtcmodule_la_LDFLAGS = -module -avoid-version
+ libqtcmodule_la_LIBADD = $(SIP_LDLIBDIRS) -lsip -lqt2 $(SIP_LDXFLAGS)
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h