summaryrefslogtreecommitdiff
path: root/x11-toolkits/py-fox/files
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-04-18 20:32:41 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-04-18 20:32:41 +0000
commita145ef44b0219b7620d0f07b570303063785944a (patch)
tree9aad7b14367957980e385d82f27524a0df4b285b /x11-toolkits/py-fox/files
parentAdd patch-regex.c to handle an overflow which is caused by long lines (diff)
Add py-fox, a Python bindings for FOX GUI toolkit.
PR: ports/65256 Submitted by: Radim Kolar <hsn@netmag.cz>
Diffstat (limited to 'x11-toolkits/py-fox/files')
-rw-r--r--x11-toolkits/py-fox/files/patch-setup22
1 files changed, 22 insertions, 0 deletions
diff --git a/x11-toolkits/py-fox/files/patch-setup b/x11-toolkits/py-fox/files/patch-setup
new file mode 100644
index 000000000000..0539958d9409
--- /dev/null
+++ b/x11-toolkits/py-fox/files/patch-setup
@@ -0,0 +1,22 @@
+--- setup.py.orig Wed Apr 3 00:29:06 2002
++++ setup.py Tue Apr 6 11:53:15 2004
+@@ -13,8 +13,10 @@
+ # Location of X libraries
+ if sys.platform == 'win32':
+ XLIBDIR = []
++ XLIBINC = []
+ else:
+ XLIBDIR = ['/usr/X11R6/lib']
++ XLIBINC = ['/usr/X11R6/include']
+
+ # Other libraries
+ OLIBDIRS = ['c:\cygwin\usr\local\lib']
+@@ -43,7 +45,7 @@
+ ]
+
+ # All required include file directories
+-INCDIRS = [FXINCDIR]
++INCDIRS = [FXINCDIR] + XLIBINC
+
+ # All required library file directories
+ LIBDIRS = [FXLIBDIR] + XLIBDIR + OLIBDIRS