summaryrefslogtreecommitdiff
path: root/x11-toolkits/p5-Glade2/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2000-10-29 21:41:38 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2000-10-29 21:41:38 +0000
commit24f960f938f0e53718d7713a02d6c71a14504c8f (patch)
treed1b759a27d4acad93dee892061eb126b0effa1ca /x11-toolkits/p5-Glade2/Makefile
parentIt's a perl module to access gdkpixbuf library. (diff)
It's a perl module to access glade library.
Diffstat (limited to 'x11-toolkits/p5-Glade2/Makefile')
-rw-r--r--x11-toolkits/p5-Glade2/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-toolkits/p5-Glade2/Makefile b/x11-toolkits/p5-Glade2/Makefile
new file mode 100644
index 000000000000..6798026c617e
--- /dev/null
+++ b/x11-toolkits/p5-Glade2/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Glade
+# Date created: 30 Oct 2000
+# Whom: vanilla
+#
+# $FreeBSD$
+#
+
+PORTNAME= Glade
+PORTVERSION= 0.7004
+CATEGORIES= x11-toolkits lang perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Gtk
+PKGNAMEPREFIX= p5-
+DISTNAME= Gtk-Perl-${PORTVERSION}
+
+MAINTAINER= vanilla@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/mach/Gtk.pm:${PORTSDIR}/x11-toolkits/p5-Gtk
+LIB_DEPENDS= glade.4:${PORTSDIR}/devel/libglade
+
+USE_PERL5= yes
+USE_GNOME= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS} -L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>